Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[1С:Бухгалтерия 8]

Счет фактура КПП подскажите!!!

АнтонХудин
Пост №1
АнтонХудин
читатель
офлайн
Дата регистрации: 25.01.2013
Сообщений: 34
Пост №1
 
13.05.2013 15:19

"1с БП КОРП 2.0
в счет фактуру выданной был добавлен реквизит КППКонтрагента, там отображается Кпп контрагента и его можно менять в самой этой счет фактуре, имеется внешняя печатная форма счет фактуры!


Вопрос: Как сделать чтобы у меня КПП бралось именно из счет фактуры выданной а не из контрагента?


вот код:

Если НЕ (СсылкаНаОбъект.ВидСчетаФактуры = Перечисления.ВидСчетаФактурыВыставленного.НалоговыйАгент
И СсылкаНаОбъект.ДоговорКонтрагента.ВидАгентскогоДоговора = Перечисления.ВидыАгентскихДоговоров.Нерезидент) Тогда

КПП = ФормированиеПечатныхФорм.ОписаниеОрганизации(СведенияОПоставщике, "КПП,", Ложь);
// {ОбособленныеПодразделения
ИндексПодразделения = 0;
Если ЗначениеЗаполнено(ДанныеДляПечати.Подразделение)
И ДанныеДляПечати.Подразделение.ОбособленноеПодразделение Тогда
КПП = ДанныеДляПечати.Подразделение.КПП;
ИндексПодразделения = ДанныеДляПечати.Подразделение.ЦифровойИндексОбособленногоПодразделения;
ИначеЕсли ОбщегоНазначения.ЭтоОбособленноеПодразделение(ДанныеДляПечати.Организация) Тогда
КПП = ФормированиеПечатныхФорм.ОписаниеОрганизации(СведенияОбОрганизации, "КПП,", Ложь);
ИндексПодразделения = ДанныеДляПечати.Организация.ЦифровойИндексОбособленногоПодразделения;
КонецЕсли;

Если ИндексПодразделения <> 0 Тогда
ДанныеДляПечати.Номер = ДанныеДляПечати.Номер + "/" + ИндексПодразделения;
КонецЕсли;
// }ОбособленныеПодразделения
Если ЗначениеЗаполнено(КПП) Тогда
КПП = "/" + КПП;
КонецЕсли;
ОбластьМакета.Параметры.ИННпоставщика = "ИНН/КПП продавца: "
+ ФормированиеПечатныхФорм.ОписаниеОрганизации(СведенияОПоставщике, "ИНН,", Ложь) + КПП;

Иначе
ОбластьМакета.Параметры.ИННпоставщика = "ИНН/КПП продавца: --"
КонецЕсли;


Подскажите что и как поменять плиз, ну или наводки какие нибудь. Как подцепить КПП в счет фактуре выданной вместо кпп который указывается из контрагента?"

Prikum
Пост №2
Prikum
читатель
офлайн
Дата регистрации: 18.02.2002
Сообщений: 20454
Пост №2
 
13.05.2013 15:38

"КПП = КППКонтрагента;"

АнтонХудин
Пост №3
АнтонХудин
читатель
офлайн
Дата регистрации: 25.01.2013
Сообщений: 34
Пост №3
 
13.05.2013 15:48

а в какой строке это нужно реализовать? вместо какой?
Выдает что переменная не определена

ZhAmAn
Пост №4
ZhAmAn
читатель
офлайн
Дата регистрации: 23.12.2010
Сообщений: 1333
Пост №4
 
13.05.2013 15:53

Вы бы хоть чуть фантазии проявили

Prikum
Пост №5
Prikum
читатель
офлайн
Дата регистрации: 18.02.2002
Сообщений: 20454
Пост №5
 
13.05.2013 15:55

А ты так и будешь учится по форуму?
Откуда я знаю имя твоего реквизита? Еще можно попробовать ЭтотОбъект.ИмяРеквизита и это уже наконец то хоть чуть чуть усердия проявляй!

АнтонХудин
Пост №6
АнтонХудин
читатель
офлайн
Дата регистрации: 25.01.2013
Сообщений: 34
Пост №6
 
13.05.2013 15:55

да я чет столько уже мучаюсь с этой фигней что мозги не варят уже, если не сложно подскажите

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги
© ООО "1C" 2000-2018 г.