Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[1С:Бухгалтерия 8]

Добавление колонки адрес в справочник Контрагенты!

АнтонХудин
Пост №1
АнтонХудин
читатель
офлайн
Дата регистрации: 25.01.2013
Сообщений: 34
Пост №1
 
16.05.2013 11:44

"Проблема при выводе колонки и данных.
БП 8.2 справочник контрагенты На форму "ФормаСписка" Добавил колонку Юр.Адрес
настройки:данные "Пусто", Элемент управления "Поле ввода", вроде все
далее настройка строки, там тип строка 100
Далее я добавил в модуль этой формы обработчик ну собственно вот этот код:


Процедура СправочникСписокПриПолученииДанных(Элемент, ОформленияСтрок)

НаборЗаписей = РегистрыСведений.КонтактнаяИнформация.СоздатьНаборЗаписей();
Для каждого ОформлениеСтроки из ОформленияСтрок Цикл
НаборЗаписей.Очистить();
УправлениеКонтактнойИнформацией.ПрочитатьКонтактнуюИнформацию(НаборЗаписей, ОформлениеСтроки.ДанныеСтроки.Ссылка);
Для Каждого Запись Из НаборЗаписей Цикл
Если Запись.Тип = Перечисления.ТипыКонтактнойИнформации.Адрес Тогда
Если Запись.Вид.Наименование = "Юридический адрес" Тогда
ОформлениеСтроки.Ячейки.ЮрАдрес.Значение = Запись.Представление;
ИначеЕсли Запись.Вид.Наименование = "Фактический адрес" Тогда
ОформлениеСтроки.Ячейки.ФактАдрес.Значение = Запись.Представление;
КонецЕсли;
ИначеЕсли Запись.Тип = Перечисления.ТипыКонтактнойИнформации.Телефон Тогда
ОформлениеСтроки.Ячейки.Телефон.Значение = Запись.Представление;
КонецЕсли;
КонецЦикла
КонецЦикла;

КонецПроцедуры

Вопрос что я сделал не так? Нужно чтобы выводил Юр. Адрес в эту колонку. Уже много всего перепробывал много тем посмотрел и никак понять не могу....Подскажите плиз кому не сложно. Заранее благодарен!!!"

zak555 (398843952)
Пост №2
zak555 (398843952)
читатель
офлайн
Дата регистрации: 27.03.2008
Сообщений: 4656
Пост №2
 
16.05.2013 12:04

1. зачем очищаете набор?
2. получив заполненный набор из ОМ доставайте из него данные юрЛица по виду юрАдреса и выводите представление

АнтонХудин
Пост №3
АнтонХудин
читатель
офлайн
Дата регистрации: 25.01.2013
Сообщений: 34
Пост №3
 
16.05.2013 12:32

что то не очень понятно, извините не могли бы по подробней сказать, а то мучаюсь незнамо сколько, можете на примере моего кода что убрать а что добавить? и вопрос то есть кроме изменения кода я все правильно сделал? код должен быть именно в этой форме? а не в модуле справочника контрагенты?

ZhAmAn
Пост №4
ZhAmAn
читатель
офлайн
Дата регистрации: 23.12.2010
Сообщений: 1333
Пост №4
 
16.05.2013 13:07

Функция СведенияОЮрФизЛице в модуле УправлениеКонтактнойИнформацией не подойдет?

//  Функция формирует сведения об указанном ЮрФизЛице. К сведениям относятся -// наименование, адрес, номер телефона, банковские реквизиты.//// Параметры://  ЮрФизЛицо   - организация или физическое лицо, о котором собираются сведения.//  ДатаПериода - дата, на которую выбираются сведения о ЮрФизЛице.//  ДляФизЛицаТолькоИнициалы - Для физ. лица выводить только инициалы имени и отчества.//// Возвращаемое значение://  Сведения - собранные сведения.// 

Prikum
Пост №5
Prikum
читатель
офлайн
Дата регистрации: 18.02.2002
Сообщений: 20454
Пост №5
 
16.05.2013 13:10

Я представляю как все это будет тормозить на реальной базе!

АнтонХудин
Пост №6
АнтонХудин
читатель
офлайн
Дата регистрации: 25.01.2013
Сообщений: 34
Пост №6
 
16.05.2013 13:33

"создал запрос для примера телефона но и он тоже не пашет
Подскажите что не так то делаю??


Процедура СписокПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)

Контрагент = Справочники.Контрагенты.НайтиПоКоду(ДанныеСтроки.Код).Ссылка;

Запрос = Новый Запрос();
Запрос.УстановитьПараметр("ФизЛицо", Контрагент);
Запрос.УстановитьПараметр("ТипКИ", Перечисления.ТипыКонтактнойИнформации.Телефон);
Запрос.УстановитьПараметр("ВидКИ", Справочники.ВидыКонтактнойИнформации.ТелефонКонтрагента);

Запрос.Текст =
"ВЫБРАТЬ
| КонтактнаяИнформация.Объект,
| ПРЕДСТАВЛЕНИЕ(КонтактнаяИнформация.Объект),
| КонтактнаяИнформация.Тип,
| КонтактнаяИнформация.Вид,
| ПРЕДСТАВЛЕНИЕ(КонтактнаяИнформация.Вид),
| КонтактнаяИнформация.Представление
|ИЗ
| РегистрСведений.КонтактнаяИнформация КАК КонтактнаяИнформация
|ГДЕ
| КонтактнаяИнформация.Объект = &ФизЛицо
| И КонтактнаяИнформация.Тип = &ТипКИ
| И КонтактнаяИнформация.Вид = &ВидКИ";

ТелефонКонтрагента = Запрос.Выполнить().Выгрузить();

Для каждого Строка из ТелефонКонтрагента Цикл
Телефон = Строка.Представление;
КонецЦикла;

ОформлениеСтроки.Ячейки.Телефон.УстановитьТекст(Телефон);

КонецПроцедуры"

Денис (САМАРА)
Пост №7
Денис (САМАРА)
активный пользователь
офлайн
Дата регистрации: 09.04.2008
Сообщений: 8342
Пост №7
 
16.05.2013 14:01

"> ОформлениеСтроки.Ячейки.ЮрАдрес.Значение = Запись.Представление;

ОформлениеСтроки.Ячейки.ЮрАдрес.УстановитьТекст(Запись.Представление);

P.S. См. на ИТС "Система стандартов и методик разработки...""

Денис (САМАРА)
Пост №8
Денис (САМАРА)
активный пользователь
офлайн
Дата регистрации: 09.04.2008
Сообщений: 8342
Пост №8
 
16.05.2013 14:02

А для этого контрагента есть конт.инф. "ТелефонКонтрагента"?

zak555 (398843952)
Пост №9
zak555 (398843952)
читатель
офлайн
Дата регистрации: 27.03.2008
Сообщений: 4656
Пост №9
 
16.05.2013 14:21

опишет ещё раз задачу и что нужно сделать

АнтонХудин
Пост №10
АнтонХудин
читатель
офлайн
Дата регистрации: 25.01.2013
Сообщений: 34
Пост №10
 
16.05.2013 14:28

> опишет ещё раз задачу и что нужно сделать

нужно чтобы в контрагентах была добавочная колонка где будет выводиться Юр Адрес контрагента

Вот для пробы был сделан запрос на вывод хотябы телефона! и крах, ничего не выводиться. Также код был написал и также ничего!

Все коды представлены выше!

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги
© ООО "1C" 2000-2018 г.