Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[1С:Зарплата и управление персоналом 8]

Зависание при обновлении до релиза 2.5.69.1

Димас1988
Пост №1
Димас1988
читатель
офлайн
Дата регистрации: 22.06.2012
Сообщений: 5
Пост №1
 
25.06.2013 08:25

"Очередной треш-релиз от 1С.
При обновлении программа зависает и зацикливается в модуле ПроцедурыОбновленияИнформационнойБазы, процедура ОбновитьСправкиОЗаработкеДляРасчетаПособий():

....
Пока Н > 0 Цикл
ТекущаяЗапись = ВременнаяТаблица[Н];
Если Не ЗначениеЗаполнено(ТекущаяЗапись.НаименованиеПериода) Тогда
Продолжить;
КонецЕсли;
ПредшествующаяЗапись = ВременнаяТаблица[Н-1];
Если ТекущаяЗапись.НаименованиеПериода = ПредшествующаяЗапись.НаименованиеПериода
И Год(ТекущаяЗапись.ПериодС) = Год(ПредшествующаяЗапись.ПериодС)
И (ТекущаяЗапись.ПериодС = КонецДня(ПредшествующаяЗапись.ПериодПо) + 1
Или КонецДня(ТекущаяЗапись.ПериодС) = КонецДня(ПредшествующаяЗапись.ПериодПо)) Тогда
// объединим записи в одну
ПредшествующаяЗапись.Дни = ПредшествующаяЗапись.Дни + ТекущаяЗапись.Дни;
ПредшествующаяЗапись.ПериодПо = ТекущаяЗапись.ПериодПо;
ВременнаяТаблица.Удалить(ТекущаяЗапись);
КонецЕсли;
Н = Н - 1;
КонецЦикла;
....

Зацикливается на первых пяти строчках"

Татьяна_A
Пост №2
Татьяна_A
читатель
офлайн
Дата регистрации: 09.08.2012
Сообщений: 78
Пост №2
 
25.06.2013 10:01

На партнерском форуме уже тоже такое же сообщение есть. Пока без ответа. (но много присоединившися, столкнувшихся с такой же проблемой).

Тэра
Пост №3
Тэра
активный пользователь
офлайн
Дата регистрации: 25.12.2008
Сообщений: 22001
Пост №3
 
25.06.2013 10:25

а подробнее? на демке обновилось без проблем.

Sh_S
Пост №4
Sh_S
читатель
офлайн
Дата регистрации: 02.03.2007
Сообщений: 7730
Пост №4
 
25.06.2013 10:39

а на демке справки есть в базе?
а вообще на партнерском такое же сообщение, присоединившиеся люди и Закиров, поблагодаривший за сообщение. исправляется легко, но если неохота сниматься с "замочка", ждать исправления

Денис (САМАРА)
Пост №5
Денис (САМАРА)
активный пользователь
офлайн
Дата регистрации: 09.04.2008
Сообщений: 8342
Пост №5
 
25.06.2013 10:39

Видимо в демке нет этих записей, которые данный код пытается "объединить".

Тэра
Пост №6
Тэра
активный пользователь
офлайн
Дата регистрации: 25.12.2008
Сообщений: 22001
Пост №6
 
25.06.2013 10:47

ага! вы правы, в реальной базе - зациклилось. Буду ждать исправления.

Денис (САМАРА)
Пост №7
Денис (САМАРА)
активный пользователь
офлайн
Дата регистрации: 09.04.2008
Сообщений: 8342
Пост №7
 
25.06.2013 12:25

"Ну можно же перед "Продолжить" просто поставить

Н = Н - 1; 
"

Тэра
Пост №8
Тэра
активный пользователь
офлайн
Дата регистрации: 25.12.2008
Сообщений: 22001
Пост №8
 
25.06.2013 12:35

Можно,но не хочу я замочек снимать!

Денис (САМАРА)
Пост №9
Денис (САМАРА)
активный пользователь
офлайн
Дата регистрации: 09.04.2008
Сообщений: 8342
Пост №9
 
25.06.2013 12:48

Ну если вдруг так срочно надо кому... Да и замочек можно и обратно застегнуть потом после исправления. А вообще странно, что обход строк сделали через итератор, а не обходом коллекции. Стажер чтоли модуль писал новый...

SergioBargio
Пост №10
SergioBargio
читатель
офлайн
Дата регистрации: 28.05.2012
Сообщений: 17
Пост №10
 
25.06.2013 18:08

"Дмитрий, спасибо, что указали место где проблема. сам бы долго искал ;-)"

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги
© ООО "1C" 2000-2018 г.