Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Другие решения на платформе "1С:Предприятие 8"]

Подскажите, пожалуйста, как оформить цветом определенную строку в дереве значений

hhh333
Пост №1
hhh333
читатель
офлайн
Дата регистрации: 22.10.2012
Сообщений: 44
Пост №1
 
21.10.2013 13:18

"Здравствуйте!

Появилась проблемка. Необходимо выделить цветом строку в дереве значений по определенному условию. Дерево создаю программно.


Если НайденнаяСтрока.СвязанныйДокумент.ПометкаУдаления = Истина Тогда  УО = УсловноеОформление.Представление.Добавить();                 УО.Оформление.УстановитьЗначениеПараметра("ЦветФона",WebЦвета.Красный);   	      КонецЕсли; 
"

Денис (САМАРА)
Пост №2
Денис (САМАРА)
активный пользователь
офлайн
Дата регистрации: 09.04.2008
Сообщений: 8342
Пост №2
 
22.10.2013 10:13

Это управляемые формы или обычные?

hhh333
Пост №3
hhh333
читатель
офлайн
Дата регистрации: 22.10.2012
Сообщений: 44
Пост №3
 
22.10.2013 10:44

Управляемые

Денис (САМАРА)
Пост №4
Денис (САМАРА)
активный пользователь
офлайн
Дата регистрации: 09.04.2008
Сообщений: 8342
Пост №4
 
22.10.2013 10:58

Дайте сам код формирования дерева.

hhh333
Пост №5
hhh333
читатель
офлайн
Дата регистрации: 22.10.2012
Сообщений: 44
Пост №5
 
22.10.2013 11:19

"

Дерево = РеквизитФормыВЗначение("ДеревоСвязей");
Дерево.Строки.Очистить();


Запрос = Новый Запрос;
Запрос.Текст = "ВЫБРАТЬ РАЗРЕШЕННЫЕ
| СвязиДокументов.ТипСвязи КАК ТипСвязи,
| СвязиДокументов.ДатаУстановки,
| СвязиДокументов.СвязанныйДокумент,
| СвязиДокументов.СвязаннаяСтрока,
| СвязиДокументов.Комментарий,
| 1 КАК КоличествоДокументов
|ИЗ
| РегистрСведений.СвязиДокументов КАК СвязиДокументов
|ГДЕ
| СвязиДокументов.Документ = &Документ
|
|УПОРЯДОЧИТЬ ПО
| ТипСвязи"; Запрос.УстановитьПараметр("Документ", Объект.Ссылка);
Результат = Запрос.Выполнить().Выгрузить();
Результат.Сортировать("ТипСвязи");


ТабКоличествоСвязей = Результат.Скопировать();
ТабКоличествоСвязей.Свернуть("ТипСвязи", "КоличествоДокументов");


КоличествоСвязей = 0;


Для Каждого СтрокаТипСвязи Из ТабКоличествоСвязей Цикл
НоваяСтрока = Дерево.Строки.Добавить();
НоваяСтрока.ТипСвязи = СтрокаТипСвязи.ТипСвязи;
НоваяСтрока.ЭтоРодитель = Истина;
НоваяСтрока.Представление = Строка(СтрокаТипСвязи.ТипСвязи) + " (" + СтрокаТипСвязи.КоличествоДокументов + ")";
НайденныеСтроки = Результат.НайтиСтроки(Новый Структура("ТипСвязи", СтрокаТипСвязи.ТипСвязи));

Для Каждого НайденнаяСтрока Из НайденныеСтроки Цикл
СтрокаДок = НоваяСтрока.Строки.Добавить();
СтрокаДок.ТипСвязи = НайденнаяСтрока.ТипСвязи;
СтрокаДок.СвязанныйДокумент = НайденнаяСтрока.СвязанныйДокумент;
СтрокаДок.СвязаннаяСтрока = НайденнаяСтрока.СвязаннаяСтрока;
СтрокаДок.Комментарий = НайденнаяСтрока.Комментарий;

Если НайденнаяСтрока.СвязанныйДокумент.ПометкаУдаления = Истина Тогда

УО = УсловноеОформление.Представление.Добавить();            
УО.Оформление.УстановитьЗначениеПараметра("ЦветФона",WebЦвета.Красный);      

КонецЕсли;

      
КоличествоСвязей = КоличествоСвязей + 1;
КонецЦикла;
КонецЦикла;
      
ЗначениеВРеквизитФормы(Дерево, "ДеревоСвязей");
"

Денис (САМАРА)
Пост №6
Денис (САМАРА)
активный пользователь
офлайн
Дата регистрации: 09.04.2008
Сообщений: 8342
Пост №6
 
22.10.2013 11:38

Так у Вас на форме уже создана таблица типа "ДеревоЗначений" с нужными колонками и только данные заполняете?

hhh333
Пост №7
hhh333
читатель
офлайн
Дата регистрации: 22.10.2012
Сообщений: 44
Пост №7
 
22.10.2013 11:45

Дерево у меня формируется автоматически из кода представленного выше. Мне надо, чтобы при формировании дерева выделялись цветом строки, удовлетворяющие определенному условию.

Денис (САМАРА)
Пост №8
Денис (САМАРА)
активный пользователь
офлайн
Дата регистрации: 09.04.2008
Сообщений: 8342
Пост №8
 
22.10.2013 11:46

Скриншот формы из конфигуратора можете показать?

hhh333
Пост №9
hhh333
читатель
офлайн
Дата регистрации: 22.10.2012
Сообщений: 44
Пост №9
 
22.10.2013 11:50

Формы чего? Это простое дерево вида:

Строка 1
Строка 1.1
Строка 1.2

Строка 2
Строка 2.1
Строка 2.2

И условие применяется к строкам второго уровня х.х, они и должны выделяться цветом.

Денис (САМАРА)
Пост №10
Денис (САМАРА)
активный пользователь
офлайн
Дата регистрации: 09.04.2008
Сообщений: 8342
Пост №10
 
22.10.2013 12:07

Вот так.

1c.jpg (331.38 КБ)
Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги
© ООО "1C" 2000-2018 г.