Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[1С:Бухгалтерия 8]

Управляемые формы: создание документа, запись в табличнуб часть

Чернякова
Пост №1
Чернякова
читатель
офлайн
Дата регистрации: 18.01.2013
Сообщений: 116
Пост №1
 
28.11.2013 13:34

"Подскажите, кто знает.
Задача: загрузить из внешнегго файла проводки в бух.операцию.
не могу записать проводки - не пишет, так как в Операции Бух нет табличной части.
усложняется еще и управляемой формой.
Создала внешнюю обработку, на ней кнопку с командой Загрузить
Ниже укороченный ( убрала про обрашение к файлу его чтение и прочее).
Интересует только Запись проводок.
//для теста использую счет 51 и текущюю дату
&НаСервере
Функция СоздатьНовыйДокумент(дата,таблицаЗнач)
НовыйДокумент = Документы.ОперацияБух.СоздатьДокумент();
НовыйДокумент.Организация = Справочники.Организации.НайтиПоКоду("00000001");
НовыйДокумент.Дата = Дата;
НовыйДокумент.Записать();
//тут идет запись в таб часть, но не получается.
Строчка = НовыйДокумент.Движения.Хозрасчетный.Добавить();
Строчка.Период = дата;
Строчка.Активность = Истина;
Строчка.СчетДт = ПланыСчетов.Хозрасчетный.НайтиПоКоду(строка("51"));
Строчка.СчетКт = ПланыСчетов.Хозрасчетный.НайтиПоКоду(Строка("51"));//тупо на 51
//НЕ пишет , документ создает, а табличные части пустые//
Возврат НовыйДокумент.Ссылка;

КонецФункции

&НаКлиенте
Процедура Загрузить(Команда)
       ДатаПр= ТекущаяДата();
       дебет = "51";
       ДанныеЗаполнения=Новый массив(0);
       ДанныеЗаполнения.Вставить(0,Дебет);
       СсылкаНаДокумент = СоздатьНовыйДокумент(ДатаПр,ДанныеЗаполнения);
КонецПроцедуры"

Тимур15rus
Пост №2
Тимур15rus
читатель
офлайн
Дата регистрации: 08.11.2008
Сообщений: 612
Пост №2
 
28.11.2013 13:57

"С первого взгляда без тестирования - создаются строки, а потом возврат ссылки идет без записи.
зы. Но мне почему то кажется что обращение "Строчка = НовыйДокумент.Движения.Хозрасчетный.Добавить();" не верно. (если это обращение к движениям, а не к табличной части)"

uinny
Пост №3
uinny
читатель
офлайн
Дата регистрации: 12.01.2008
Сообщений: 4814
Пост №3
 
28.11.2013 14:00

Выдается какая-то ошибка? Если да, на каком этапе и текст.

uinny
Пост №4
uinny
читатель
офлайн
Дата регистрации: 12.01.2008
Сообщений: 4814
Пост №4
 
28.11.2013 14:01

А вы просто создаете движение, и не привязываете его к документу. Нет?

Денис (САМАРА)
Пост №5
Денис (САМАРА)
активный пользователь
офлайн
Дата регистрации: 09.04.2008
Сообщений: 8342
Пост №5
 
28.11.2013 14:05

Добавление верное, но записи движений я не вижу.

Денис (САМАРА)
Пост №6
Денис (САМАРА)
активный пользователь
офлайн
Дата регистрации: 09.04.2008
Сообщений: 8342
Пост №6
 
28.11.2013 14:07

Обращение к свойству документа "Движения" в модуле объекта документа само по себе создает набор записей с установленным отбором по регистратору равному ссылке на этот документ. Собственно, в этом и заложено удобство.

uinny
Пост №7
uinny
читатель
офлайн
Дата регистрации: 12.01.2008
Сообщений: 4814
Пост №7
 
28.11.2013 14:09

Удобно, действительно.
Работать с ним приходится редко, так что забываются нюансы.

Чернякова
Пост №8
Чернякова
читатель
офлайн
Дата регистрации: 18.01.2013
Сообщений: 116
Пост №8
 
28.11.2013 14:47

т.е. не хватает записи регистратора?

Чернякова
Пост №9
Чернякова
читатель
офлайн
Дата регистрации: 18.01.2013
Сообщений: 116
Пост №9
 
28.11.2013 14:47

а как тогда?

Tanya
Пост №10
Tanya
активный пользователь
офлайн
Дата регистрации: 03.12.2001
Сообщений: 8408
Пост №10
 
28.11.2013 14:57

"Как то так

&НаКлиенте
Процедура СоздатьОперацию(Команда)
// Вставить содержимое обработчика.
создатьдок();
КонецПроцедуры

&НаСервере
Процедура создатьдок()
док=Документы.ОперацияБух.СоздатьДокумент();
док.Дата=Текущаядата();
док.Организация=Справочники.Организации.НайтиПоКоду("00-000001");
док.ТиповаяОперация = Неопределено;
док.ЗаполнениеДвижений.Очистить();
док.СторнируемыйДокумент = Неопределено;
док.СуммаОперации=60000;
Док.ОбменДанными.Загрузка = Истина;
Док.Движения.Хозрасчетный.Записывать = Истина;
стр=док.Движения.Хозрасчетный.Добавить();
стр.СчетДт=ПланыСчетов.Хозрасчетный.РасчетныеСчета;
стр.СчетКт=ПланыСчетов.Хозрасчетный.Вспомогательный;
стр.Период=Текущаядата();
стр.Организация=Справочники.Организации.НайтиПоКоду("00-000001");
стр.Активность=истина;
стр.Сумма=10000;
стр=док.Движения.Хозрасчетный.Добавить();
стр.СчетДт=ПланыСчетов.Хозрасчетный.РасчетныеСчета;
стр.СчетКт=ПланыСчетов.Хозрасчетный.Вспомогательный;
стр.Период=Текущаядата();
стр.Организация=Справочники.Организации.НайтиПоКоду("00-000001");
стр.Активность=истина;
стр.Сумма=50000;
док.Записать(РежимЗаписиДокумента.Запись);
КонецПроцедуры"

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги
© ООО "1C" 2000-2018 г.