Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[1С:Бухгалтерия 8]

Свой документ в Журнале Операций и вызвать для него обработку Корректировка движений?

ok2011
Пост №1
ok2011
читатель
офлайн
Дата регистрации: 06.12.2013
Сообщений: 8
Пост №1
 
19.12.2013 10:00

БП редакция 3.0

Подскажите, пожалуйста!

Как добавить свой документ в Журнал операций и вызвать для него обработку Корректировку движений?

ZhAmAn
Пост №2
ZhAmAn
читатель
офлайн
Дата регистрации: 23.12.2010
Сообщений: 1333
Пост №2
 
19.12.2013 10:15

В журнале документов есть вкладка данные,в ней "регистрируемые документы".
Чтобы вызвать обработку корректировки,нужно октрыть форму и передать на Ваш документ ссылку в неё в реквизит ДокументСсылка.

Снимок.JPG (54.49 КБ)
Снимок.JPG (61.75 КБ)
ok2011
Пост №3
ok2011
читатель
офлайн
Дата регистрации: 06.12.2013
Сообщений: 8
Пост №3
 
19.12.2013 11:06

Спасибо большое!

С Журналом все получилось.

С обработкой нет.
Реквизит формы имеет тип Документ.Ссылка. Но я на пробу поставила тип только своего документа и вылетела та же ошибка.

КоррДвиж.bmp (394.11 КБ)
ZhAmAn
Пост №4
ZhAmAn
читатель
офлайн
Дата регистрации: 23.12.2010
Сообщений: 1333
Пост №4
 
19.12.2013 11:43

"Смотрите в типовых пример!

&НаКлиентеПроцедура ОбработкаКоманды(ПараметрКоманды, ПараметрыВыполненияКоманды)       ПараметрыДокумента = ПолучитьПараметрыДокумента(ПараметрКоманды);       Если НЕ ПараметрыДокумента.ПометкаУдаления И НЕ ПараметрыДокумента.ОперацияБух И        НЕ ПараметрыДокумента.РегОперация И НЕ ПараметрыДокумента.РучнаяКорректировка И                                                    НЕ ПараметрыДокумента.Проведен Тогда               Кнопки = Новый СписокЗначений;        Кнопки.Вставить(0, КодВозвратаДиалога.Да, "Провести");        Кнопки.Вставить(1, КодВозвратаДиалога.Нет, "Отмена");        Ответ = Вопрос(НСтр("ru = 'Перед просмотром проводок документ следует провести'"), Кнопки,, КодВозвратаДиалога.Да);        Если Ответ <> КодВозвратаДиалога.Да Тогда            Возврат;        ИначеЕсли Не ПровестиДокумент(ПараметрКоманды) Тогда            Сообщить(НСтр("ru = 'Не удалось провести документ'"), СтатусСообщения.Важное);            Возврат;        КонецЕсли;    КонецЕсли;       ПараметрыФормы = Новый Структура("ДокументСсылка", ПараметрКоманды);    ОткрытьФорму("Обработка.КорректировкаДвижений.Форма",        ПараметрыФормы,        ПараметрыВыполненияКоманды.Источник,        ПараметрКоманды);   КонецПроцедуры 
"

Денис (САМАРА)
Пост №5
Денис (САМАРА)
активный пользователь
офлайн
Дата регистрации: 09.04.2008
Сообщений: 8342
Пост №5
 
19.12.2013 11:54

Не успела новая конфигурация выйти, как ее уже "своими документами" загаживают. :)

P.S. Картинки к сообщению надо в формате jpg или png прикреплять.

ok2011
Пост №6
ok2011
читатель
офлайн
Дата регистрации: 06.12.2013
Сообщений: 8
Пост №6
 
19.12.2013 12:17

СПАСИБО!!! Получилось )))

ok2011
Пост №7
ok2011
читатель
офлайн
Дата регистрации: 06.12.2013
Сообщений: 8
Пост №7
 
19.12.2013 12:21

это был переход с 2.0 на 3.0 нетиповой конфы )))) а сколько их еще будет!

всем успешных переходов!

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги
© ООО "1C" 2000-2018 г.