Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

работа с отсортированной таблицей

Елена_В
Пост №1
Елена_В
читатель
офлайн
Дата регистрации: 26.10.2007
Сообщений: 599
Пост №1
 
17.09.2015 23:36

Пример таблицы


Статья       Контрагент Сумма

ЖД Сидоров100
ЖДПетров 200
АРЕНДА Иванов700
ТабличнаяЧасть.Сортировать("Статья" ;) ;
Для каждого Строка Из ТабличнаяЧасть Цикл
      ...
КонецЦикла;

как в данном случае узнать, что следующее значение в Колонке Статья будет другим? Т.е. находясь во второй строке таблицы, я должна знать, что в третьей строке уже будет другая статья

Ответили: пост №2 , пост №5
Prikum
Пост №2
Prikum
читатель
офлайн
Дата регистрации: 18.02.2002
Сообщений: 20454
Пост №2
 
17.09.2015 23:42
Ответ на пост №1

каждая строка имеет свой индекс, поэтом достаточно считать строку по индексу+1

Ответили: пост №3
Елена_В
Пост №3
Елена_В
читатель
офлайн
Дата регистрации: 26.10.2007
Сообщений: 599
Пост №3
 
17.09.2015 23:53
Ответ на пост №2

Prikum,т.е. так?

ТабличнаяЧасть.Сортировать("Статья" ;) ;
к=1;
Для каждого Строка Из ТабличнаяЧасть Цикл
Если Строка.Статья[к] <> Строка.Статья[к+1] Тогда
...
Иначе
КонецЕсли;
КонецЦикла;

Елена_В
Пост №4
Елена_В
читатель
офлайн
Дата регистрации: 26.10.2007
Сообщений: 599
Пост №4
 
18.09.2015 00:19

СледующаяСтрока = ТабличнаяЧасть[Строка.НомерСтроки];

Valentin46
Пост №5
Valentin46
активный пользователь
офлайн
Дата регистрации: 10.02.2011
Сообщений: 808
Пост №5
 
18.09.2015 11:48
Ответ на пост №1

Елена_В, а зачем писать какие-то циклы, почему бы не воспользоваться стандартным методом: ТЧ.Сортировать(<Колонки>, <ОбъектСравнения>)?

Елена_В
Пост №6
Елена_В
читатель
офлайн
Дата регистрации: 26.10.2007
Сообщений: 599
Пост №6
 
18.09.2015 11:50

Valentin46 пишет:

Цитата

      
                  
                   Ответ на
                   пост №1
            
      
Елена_В , а зачем писать какие-то циклы, почему бы не воспользоваться стандартным методом: ТЧ. Сортировать (<Колонки>, <ОбъектСравнения> ?
да, я поняла. что так некрасиво. Для себя правильный ответ написала в посте 4

Ответили: пост №7
Valentin46
Пост №7
Valentin46
активный пользователь
офлайн
Дата регистрации: 10.02.2011
Сообщений: 808
Пост №7
 
18.09.2015 11:59
Ответ на пост №6

Елена_В, простите, недоглядел - цикл Вами используется для обработки содержимого ТЧ, что собственно и заявлено в теме.

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги
© ООО "1C" 2000-2018 г.