Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[1С:Предприятие 7.7]

Ошибка при обновлении на релиз 7.70.609 "Бухгалтерский учет"

Looking
читатель
офлайн
Дата регистрации: 01.02.2005
Сообщений: 170
Пост №1
 
03.02.2016 01:17

При обновлении ошибка, если в справочнике сотрудники есть группы

Цитата
"Периодический.ИспользоватьОбъект("Статус",СпрСотр удники.ТекущийЭлемент()); : {Обработка.ОбновлениеИБ.Форма.Модуль(11733)**: Статус не является константой или периодическим параметром!"
Лечится заменой штатного кода

Цитата
Периодический.ИспользоватьОбъект("Статус", СпрСотрудники);
на код

Цитата
Если СпрСотрудники.ЭтоГруппа()=0 ТогдаПериодический.ИспользоватьОбъект("Статус",СпрСотрудники.ТекущийЭлемент());
...........
...........
КонецЕсли;

Ответили: пост №2
ka3na4ei
читатель
офлайн
Дата регистрации: 04.02.2016
Сообщений: 1
Пост №2
 
04.02.2016 12:50
Ответ на пост №1

Looking, а где именно это надо менять?

Looking
читатель
офлайн
Дата регистрации: 01.02.2005
Сообщений: 170
Пост №3
 
04.02.2016 13:50

в обработке ОбновлениеИБ

Цитата
ИначеЕсли Номер = 770609 Тогда
      
       Периодический = СоздатьОбъект("Периодический");
       СпрСотрудники = СоздатьОбъект("Справочник.Сотрудники");
      
       СпрСотрудники.ВыбратьЭлементы();
       Пока СпрСотрудники.ПолучитьЭлемент() = 1 Цикл
            //МДВ
            //Периодический.ИспользоватьОбъект("Статус", СпрСотрудники);
             Если СпрСотрудники.ЭтоГруппа()=0 Тогда
            Периодический.ИспользоватьОбъект("Статус",СпрСотрудники.ТекущийЭлемент());

            //МДВ
            
            Периодический.ВыбратьЗначения();
            Пока Периодический.ПолучитьЗначение() = 1 Цикл
             СпрСотрудники.СтатусНеРезидента.Установить(Периодический.ДатаЗнач, Периодический.Значение);
            КонецЦикла;
            //МДВ
             КонецЕсли;
            //МДВ
       КонецЦикла;

Val.
читатель
офлайн
Дата регистрации: 08.02.2016
Сообщений: 2
Пост №4
 
08.02.2016 11:23

СПАСИБО!!!
СПАСИБО!!!
СПАСИБО!!!

Val.
читатель
офлайн
Дата регистрации: 08.02.2016
Сообщений: 2
Пост №5
 
08.02.2016 12:49

У Меня еще одна проблема была у сотрудника со статусом "5" в справке 2НДФЛ выводила 30% НДФЛ
в глобальном модуле исправила:

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги