Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[1С:Предприятие 7.7]

отчет

Kamila Chajkina
читатель
офлайн
Дата регистрации: 11.10.2016
Сообщений: 19
Пост №1
 
19.10.2016 16:37

На форме выбирается период и контрагент,если контрагент не выбран,то выводится по всем ,а если выбран (только например Петров)по только по нему.Как это реализовать,сведения берутся из расходной накладной

Vladko
активный пользователь
офлайн
Дата регистрации: 27.08.2007
Сообщений: 2352
Пост №2
 
20.10.2016 09:10

Извините, а вы кто? Программист?

Ответили: пост №3
Kamila Chajkina
читатель
офлайн
Дата регистрации: 11.10.2016
Сообщений: 19
Пост №3
 
20.10.2016 09:44
Ответ на пост №2

Нет

Thorvardr
читатель
офлайн
Дата регистрации: 25.02.2005
Сообщений: 3077
Пост №4
 
20.10.2016 09:45

В форму диалога размещаем реквизиты диалога НачДата, КонДата и НужныйКонтрагент.
В алгоритме потом:

Код
ТекстЗапроса="Период с НачДата по КонДата;
                       |РасходнаяНакладная=Документ.РасходнаяНакладная.ТекущийДокумент;
                       |Группировка РасходнаяНакладная;";
Если ПустоеЗначение(НужныйКонтрагент)=0 Тогда
      ТекстЗапроса=ТекстЗапроса+"
                       |Контрагент=Документ.РасходнаяНакладная.Контрагент;
                       |Условие(Контрагент=НужныйКонтрагент);";
КонецЕсли;
Запрос=СоздатьОбъект("Запрос");
Если Запрос.Выполнить(ТекстЗапроса)=1 Тогда
      Пока Запрос.Группировка(1)=1 Цикл
            Сообщить(Запрос.РасходнаяНакладная);
      КонецЦикла;
КонецЕсли;

Вот какая штука. Если вы в начале пути и у вас есть выбор, не тратьте время на изучение версии 7.7, ориентируйтесь на последние версии платформы.

Ответили: пост №5
Kamila Chajkina
читатель
офлайн
Дата регистрации: 11.10.2016
Сообщений: 19
Пост №5
 
22.10.2016 17:34
Ответ на пост №4

Thorvardr,спасибо,вы мой герой!
выбора нету,увы

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги