Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

Добавить данные в поле ввода табличной части без источника данных

Максим Гринюк
активный пользователь
офлайн
Дата регистрации: 05.09.2016
Сообщений: 38
Пост №1
 
15.11.2016 19:30

Всем здравствуйте.
В табличную часть Товары документа Заказ покупателя добавил новую колонку. Источника данных у неё нет. Нужно при открытии документа заполнить колонку данными. Только никак не получается "увидеть" это поле. Если обращаться через Товары.ИмяКолонки, система не видит её. Через ЭлементыФормы и ЭтаФорма то же самое. Получается только если использовать стандартную процедуру ПриИзменении, но этот вариант мне не подходит.
Не добавил в табличную часть новую колонку как реквизит, потому что данные в ней необходимы лишь при открытии документа, и то не каждого, а на который сработает условие. В базу их нет смысла записывать.
Подскажите, как заполнить построчно новую колонку.

Ответили: пост №2
Prikum
читатель
офлайн
Дата регистрации: 18.02.2002
Сообщений: 20454
Пост №2
 
15.11.2016 22:20
Ответ на пост №1

Максим Гринюк, добавили именно в ТЧ или на форму?

Ответили: пост №3
Максим Гринюк
активный пользователь
офлайн
Дата регистрации: 05.09.2016
Сообщений: 38
Пост №3
 
15.11.2016 22:26
Ответ на пост №2

Prikum, в ТЧ, правой кнопкой мыши - добавить колонку.

Ответили: пост №4
Prikum
читатель
офлайн
Дата регистрации: 18.02.2002
Сообщений: 20454
Пост №4
 
15.11.2016 22:30
Ответ на пост №3

Максим Гринюк, один из моих ранних быдло кодов:

Код
&НаСервере
Процедура ОбновитьПроцентыНадбавки()
      Для Каждого СтрокаТЧ ИЗ Объект.Фармация Цикл
            //Вычислим надбавку                        //(СтрокаТЧ.ЦенаИзготовителя*(ДопустимаяНаценка/100))
            Если СтрокаТЧ.Номенклатура.ТипЛекарства=Перечисления.ТипыЛекарств.ДетскоеПитание Тогда
                  Если Объект.СуммаВключаетНДС Тогда
                        СтрокаТЧ.Надбавка = ((СтрокаТЧ.ЦенаВрознице -СтрокаТЧ.Цена)/СтрокаТЧ.Цена)*100;
                  Иначе
                        СтрокаТЧ.Надбавка = ((СтрокаТЧ.ЦенаВрознице -СтрокаТЧ.Цена-(СтрокаТЧ.СуммаНДС/СтрокаТЧ.Количество))/СтрокаТЧ.Цена)*100;
                  КонецЕсли;
                  
            Иначе
                  Если Объект.СуммаВключаетНДС Тогда
                        СтрокаТЧ.Надбавка = ((СтрокаТЧ.ЦенаВрознице -СтрокаТЧ.Цена)/СтрокаТЧ.ЦенаИзготовителя)*100;
                  Иначе
                        СтрокаТЧ.Надбавка = ((СтрокаТЧ.ЦенаВрознице -СтрокаТЧ.Цена-(СтрокаТЧ.СуммаНДС/СтрокаТЧ.Количество))/СтрокаТЧ.ЦенаИзготовителя)*100;
                  КонецЕсли;
            КонецЕсли;
            
      КонецЦикла;
      //Сумма документа общая с НДС
      Объект.СуммаДокумента = Объект.Фармация.Итог("Сумма")+Объект.Фармация.Итог("СуммаНДС");
      
КонецПроцедуры
 
Надбавка это колонка добавленная на форму, своего источника не имеет, в процедуре "ПриОткрытии" идет вызов данной процедуры в которой заполняется данная колонка.

Ответили: пост №5
Максим Гринюк
активный пользователь
офлайн
Дата регистрации: 05.09.2016
Сообщений: 38
Пост №5
 
15.11.2016 22:38
Ответ на пост №4

Prikum, я пробовал проходить циклом, конфигуратор не видит добавленную колонку. Вылетает с ошибкой.

Ответили: пост №6
Prikum
читатель
офлайн
Дата регистрации: 18.02.2002
Сообщений: 20454
Пост №6
 
15.11.2016 22:40
Ответ на пост №5

Максим Гринюк, код покажите! и картинку с ТЧ , потому как непонятно, что и где Вы там добавили.

Ответили: пост №7
Максим Гринюк
активный пользователь
офлайн
Дата регистрации: 05.09.2016
Сообщений: 38
Пост №7
 
16.11.2016 08:51
Ответ на пост №6

Prikum,я писал выше как и куда добавлял. Не как реквизит ТЧ, а правой кнопкой на ТЧ - Добавить колонку. Источника данных у колонки нет.

Код
Для Каждого Строка Из ЭтотОбъект.Товары Цикл

      Строка.НоменклатураПоставщика = Отбор.Номенклатура;

КонецЦикла
 

Пробовал вместо ЭтотОбъект ещё ЭтаФорма, ЭлементыФормы и просто Товары. Всё равно не видит.

Ответили: пост №8
Prikum
читатель
офлайн
Дата регистрации: 18.02.2002
Сообщений: 20454
Пост №8
 
16.11.2016 10:16
Ответ на пост №7

Максим Гринюк, мне в принципе все равно что и куда Вы там добавляли, проблема то не у меня! В реквизиты формы добавьте эту колонку, а потом выведите ее на саму форму.

Ответили: пост №9
Максим Гринюк
активный пользователь
офлайн
Дата регистрации: 05.09.2016
Сообщений: 38
Пост №9
 
16.11.2016 10:36
Ответ на пост №8

Prikum, перед тем как отвечать на сообщения, прочитай внимательно проблему. Я по-русски написал почему я не хочу добавить колонку как реквизит. Теперь понятно, откуда у тебя столько звездочек репутации. Пишешь всякую ересь не по делу и советуешь то, что уже написано выше.

Ответили: пост №10 , пост №11
Tanya
активный пользователь
офлайн
Дата регистрации: 03.12.2001
Сообщений: 8411
Пост №10
 
16.11.2016 10:59
Ответ на пост №9

Максим Гринюк,

Цитата
я не хочу добавить колонку как реквизит
А вы не путаете реквизит формы и реквизит документа ?

Ответили: пост №13
Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги