Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Другие решения на платформе "1С:Предприятие 8"]

СписокЗначений в Web-интерфейсе

st_saint
читатель
офлайн
Дата регистрации: 13.09.2011
Сообщений: 40
Пост №1
 
16.02.2018 13:43

Добрый день.
Конфигурация УПП релиз 101,3
Платформа 8.2.19.68
Суть вопроса в следующем: есть дополнительная обработка, в которой есть две табличные части. В первую ТЧ отбираются ПКО и РКО за день по подразделению. во вторую ТЧ с помощью СпискаЗначений отбираются документы из первой ТЧ по оператору.
СписокЗначений получаю так

&НаКлиенте
Процедура ОператорНачалоВыбораИзСписка(Элемент, СтандартнаяОбработка)
      
      Элементы.Оператор.СписокВыбора.Очистить();
      
      Для Каждого СтрокаТаблицыАЗС Из Объект.КассаАЗС Цикл
            Если Элементы.Оператор.СписокВыбора.НайтиПоЗначению(СтрокаТаблицыАЗС.ОператорАЗС) = Неопределено Тогда      
                  Элементы.Оператор.СписокВыбора.Добавить(СтрокаТаблицыАЗС.ОператорАЗС);
            КонецЕсли;      
      КонецЦикла;
      
КонецПроцедуры

При окончании выбора

&НаКлиенте
Процедура ОтобратьПоОператору()
      
      Если Объект.ИзлишкиНедостачи.Количество() > 0 Тогда
            Объект.ИзлишкиНедостачи.Очистить();
      КонецЕсли;
      
      Для Каждого СтрокаТаблицыАЗС Из Объект.КассаАЗС Цикл
            
            Если Элементы.Оператор.ВыделенныйТекст = СокрЛП(СтрокаТаблицыАЗС.ОператорАЗС) Тогда
                  
                  Стр = Объект.ИзлишкиНедостачи.Добавить();
                  Стр.Дата = СтрокаТаблицыАЗС.Дата;
                  Стр.Номер = СтрокаТаблицыАЗС.Номер;
                  Стр.НомерБизнесДняИзОктана = СтрокаТаблицыАЗС.НомерБД;
                  Стр.ФормаОплаты = СтрокаТаблицыАЗС.ФормаОплаты;
                  Стр.Документ = СтрокаТаблицыАЗС.Документ;
                  Стр.ОператорАЗС = СтрокаТаблицыАЗС.ОператорАЗС;
                  Стр.Сумма = СтрокаТаблицыАЗС.Сумма;
                  
            КонецЕсли;      
      
      КонецЦикла;
      
КонецПроцедуры

Так вот в режиме Тонкий клиент все прекрасно работает а в режиме Web-доступа СписокЗначений формируется, но не происходит отбор. как будто я не выбираю оператора...

Если убрать условие Если Элементы.Оператор.ВыделенныйТекст = СокрЛП(СтрокаТаблицыАЗС.ОператорАЗС) Тогда
то тогда полностью список из ТЧ 1 попадает в ТЧ 2

Если у кого есть какие мысли, то буду очень благодарен
с управляемыми формами только начал разбираться

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • МАРКИРОВКА
  • ЕГАИС
  • Учет, налогообложение, автоматизация
Предложения партнеров
Обучение пользователей продуктов 1С