Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[1С:Зарплата и управление персоналом 8]

ЗУП 3.1 Ошибка внешней печатной формы

Paradise89
читатель
офлайн
Дата регистрации: 26.02.2018
Сообщений: 2
Пост №1
 
26.02.2018 09:24

Добрый день. При попытки вызвать внешнюю печатную форму приказа Т-8. Возникает ошибка {ОбщийМодуль.УправлениеПечатью.Модуль(1217)}: Поле объекта не обнаружено (КоличествоЭкземпляров)
            ПечатнаяФорма.ТабличныйДокумент.КоличествоЭкземпляров = ПечатнаяФ
Код:


Код
Процедура Печать(МассивОбъектов, КоллекцияПечатныхФорм, ОбъектыПечати, ПараметрыВывода) Экспорт 
      УправлениеПечатью.ВывестиТабличныйДокументВКоллекцию(
      КоллекцияПечатныхФорм,
      "Т-8 (внешняя)", 
      "Т-8 (внешняя)",
      ПолучитьДанныеДляПечатиКадровогоПриказаТ8(СсылкаНаОбъект, ОбъектыПечати, МассивОбъектов));                        

КонецПроцедуры 

Функция ПолучитьТабличныйДокументПриказаТ8(МассивОбъектов, ОбъектыПечати)
           
      ДокументРезультат = Новый ТабличныйДокумент;
      ДокументРезультат.ЭкземпляровНаСтранице = 1;
      НомерСтрокиНачало = ДокументРезультат.ВысотаТаблицы + 1;
      ДокументРезультат.КлючПараметровПечати = "ПараметрыПечати_ПриказОбУвольнении";
      ДокументРезультат.АвтоМасштаб = Истина;
      //МассивДанныхЗаполнения = ПолучитьДанныеДляПечатиКадровогоПриказаТ8(СсылкаНаОбъект, ОбъектыПечати, МассивОбъектов);
      
      //ВывестиДанныеКадровогоПриказаВТабличныйДокумент(Макет, ДокументРезультат, МассивДанныхЗаполнения, ОбъектыПечати);
             Возврат ДокументРезультат;
КонецФункции 

Процедура ВывестиДанныеКадровогоПриказаВТабличныйДокумент(Макет, ТабличныйДокумент, МассивДанныхЗаполнения, ОбъектыПечати) Экспорт
      
      Если Макет <> Неопределено Тогда
            
            ПервыйПриказ = Истина;
            Для каждого ПараметрыМакета Из МассивДанныхЗаполнения Цикл
                  Если Не ПервыйПриказ Тогда
                        ТабличныйДокумент.ВывестиГоризонтальныйРазделительСтраниц();
                  Иначе
                        ПервыйПриказ = Ложь;
                  КонецЕсли;
                  
                  НомерСтрокиНачало = ТабличныйДокумент.ВысотаТаблицы + 1;
                  
                  ТабличныйДокумент.Параметры.Заполнить(ПараметрыМакета);
                  ТабличныйДокумент.Вывести(Макет);
                  
                  УправлениеПечатью.ЗадатьОбластьПечатиДокумента(ТабличныйДокумент,  ОбъектыПечати, ПараметрыМакета.Ссылка);      
                  
            КонецЦикла;
            
      КонецЕсли;
      
КонецПроцедуры      

Функция ПолучитьДанныеДляПечатиКадровогоПриказаТ8(СсылкаНаОбъект, ОбъектыПечати, МассивОбъектов)
      //ДокументРезультат = Новый ТабличныйДокумент;
      //Макет = ПолучитьМакет ("ПФ_MXL_Т8");
      Выборка = КадровыйУчет.СформироватьЗапросДляТ8(МассивОбъектов).Выбрать();
      
      МассивПараметров = Новый Массив;
      
      Пока  Выборка.Следующий() Цикл
            
                   Параметры = ПараметрыПриказаТ8();            
            
            КадровыйУчет.ЗаполнитьПараметрыКадровогоПриказа(Параметры, Выборка);

            РезультатСклонения = "";
            Если ФизическиеЛицаЗарплатаКадры.Просклонять(Параметры.Работник, 4, РезультатСклонения, Параметры.Пол) Тогда
                  Параметры.Работник      = РезультатСклонения
            КонецЕсли;
            
            ПредставлениеДатыУвольнения  = Формат(Выборка.ДатаУвольнения, "ДЛФ=DD");
            
            Параметры.ДатаУвольненияЧисло = ?(ЗначениеЗаполнено(Выборка.ДатаУвольнения),
                  СокрЛП(Лев(ПредставлениеДатыУвольнения,2)),
                  "      ");
            Параметры.ДатаУвольненияМесяцГод = ?(ЗначениеЗаполнено(Выборка.ДатаУвольнения),
                  СокрЛП(Прав(ПредставлениеДатыУвольнения, СтрДлина(ПредставлениеДатыУвольнения)-2)),
                  "                     г.");
                  
            Если НЕ ПустаяСтрока(Выборка.ТекстОснования) Тогда
                  Параметры.СтатьяТКРФ = Выборка.ТекстОснования + ", " + КадровыйУчет.ПредставлениеСтатьиУвольненияДляТ8(Выборка.СтатьяТКРФ);
            КонецЕсли;
            
                  
      КонецЦикла;
      Возврат МассивПараметров;
 //   Возврат ДокументРезультат;
КонецФункции      

Функция ПараметрыПриказаТ8()
      
      Параметры = КадровыйУчет.ПараметрыКадровогоПриказа();
      
      Параметры.Вставить("ДатаУвольненияЧисло");
      Параметры.Вставить("ДатаУвольненияМесяцГод");
      Параметры.Вставить("СтатьяТКРФ", "");
      Параметры.Вставить("ОснованиеУвольнения", "");
      
      Возврат Параметры;
      
КонецФункции
 

Ответили: пост №5
Лукич
читатель
офлайн
Дата регистрации: 16.02.2010
Сообщений: 448
Пост №2
 
26.02.2018 12:55

Ну а где Вы в своей внешней печатной форме заложили количество эксемпляров?

Ответили: пост №3
Paradise89
читатель
офлайн
Дата регистрации: 26.02.2018
Сообщений: 2
Пост №3
 
26.02.2018 12:59
Ответ на пост №2

Лукич, В том-то и дело, что кол-во экземпляров в модуле обработки нигде не описывается. Я новичок. Делаю все методом "копировать-вставить". С предыдущей обработкой таких проблем не было.

Ответили: пост №4
Лукич
читатель
офлайн
Дата регистрации: 16.02.2010
Сообщений: 448
Пост №4
 
26.02.2018 13:22
Ответ на пост №3

Paradise89,а предыдущая обработка была "Т-7 внешняя"?

Геннадий С
активный пользователь
офлайн
Дата регистрации: 26.03.2017
Сообщений: 609
Пост №5
 
27.02.2018 21:18
Ответ на пост №1

Paradise89, так у Вас тело функций и процедур получения приказа закомментировано, как и ссылка на макет. Посмотрите, как формируется печать в модуле менеджера обработки Печать кадровых приказов. Включите в свою внешнюю форму то, что там относится к форме Т-8. И посмотрите в интернете, как делается ВПФ для 3.0.

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • МАРКИРОВКА
  • ЕГАИС
  • Учет, налогообложение, автоматизация
Предложения партнеров
Обучение пользователей продуктов 1С