Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[1С:Бухгалтерия 8]

Не получается указать измерение отбора набора записей - "Поле объекта не обнаружено"

Bahamut
Пост №1
Bahamut
читатель
офлайн
Дата регистрации: 19.09.2018
Сообщений: 1
Пост №1
 
19.09.2018 04:58

Добрый день!

Собственно сабж. Есть регистр сведений Бригады с измерением ТранспортныеСредства. Регистр подчинён документу ОформлениеБригады и заполняется на его основе. Я хочу сделать так, чтобы при укомплектовании машины новой бригадой 1С не ругалась на уже существующую запись, а затирала старую и записывала новую. Для этого в модуле документа ОформлениеБригады я модифицировал событие ОбработкаПроведения. Получилось следующее:

Код
Процедура ОбработкаПроведения(Отказ, Режим)
      //{{__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ
      // Данный фрагмент построен конструктором.
      // При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!

      // регистр Бригады
      Движения.Бригады.Записывать = Истина;
      Движение = Движения.Бригады.Добавить();
      Если ПолучитьТСНаСервере(ТранспортноеСредство) = ТранспортноеСредство Тогда
            УдалитьЗаписьПоТС(ТранспортноеСредство);
      КонецЕсли;
      Движение.ТранспортноеСредство = ТранспортноеСредство;
      Движение.Грузчик1 = Грузчик1;
      Движение.Грузчик2 = Грузчик2;
      Движение.Водитель = Водитель;

      // регистр ПоездкиИКилометры 
      Движения.ПоездкиИКилометры.Записывать = Истина;
      Движение = Движения.ПоездкиИКилометры.Добавить();
      Движение.Период = Дата;
      Движение.ТранспортноеСредство = ТранспортноеСредство;
      Движение.Километры = НачальноеЗначениеСчетчика;

      //}}__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ
КонецПроцедуры

&НаСервере
Функция ПолучитьТСНаСервере(ТС)
      НаборЗаписей = РегистрыСведений.Бригады.СоздатьНаборЗаписей();
      НаборЗаписей.Отбор.ТранспортноеСредство.Установить(ТС);
      Выборка=НаборЗаписей.Выбрать();
      Если Не Выборка.Следующий() Тогда
            Сообщить("Выборка пуста!");
      Иначе
            Выборка.Следующий();
      КонецЕсли;
КонецФункции

&НаСервере
Процедура УдалитьЗаписьПоТС(ТС)
      НаборЗаписей = РегистрыСведений.Бригады.СоздатьНаборЗаписей();
      НаборЗаписей.Отбор.ТранспортноеСредство.Установить(ТС);
      НаборЗаписей.Записать();
КонецПроцедуры

ПолучитьТСНаСервере(ТС) - проверочная функция, она пока ничего не возвращает. Но на линии      

Код
НаборЗаписей.Отбор.ТранспортноеСредство.Установить(ТС);
система выдаёт ошибку "Поле объекта не обнаружено (ТранспортноеСредство)."
Пробовал включать свойство Ведущее в свойствах измерения ТранспортноеСредство, пробовал устанавливать отбор по регистратору - ничего не помогает. Где я прокололся? Как это можно исправить?
Версия 8.3, управляемые формы.

Заранее спасибо!

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги
© ООО "1C" 2000-2018 г.