Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

Расчет налога на имущество, ошибка проведения регламентной операции

Aksy
читатель
офлайн
Дата регистрации: 01.09.2011
Сообщений: 66
Пост №1
 
22.01.2019 20:00

Здравствуйте.
БП 3.0.67.67 проводим расчет налога на имущество, при проведении выдает сообщения вида: Запись с такими ключевыми полями существует! : РасчетНалогаНаИмущество: 31.12.2018 0:00:00, Наша организация, Кадастровая стоимость, ФНС КПП , , 13, Квартира по адресу: , , Нет, , 31.12.2017 0:00:00 (Регистр сведений: Расчет налога на имущество; Номер строки: 1129)
Расчетов в текущем периоде по налогу на имущество точно нет. Регистр сведений "Расчет налога на имущество" на декабрь 2018 по данным объектам пуст.
В прошлых периодах, а именно, в сентябре 2018 все проходило нормально. Ругается именно на объекты, у которых налоговой базой является кадастровая стоимость. Льготы не применяются. Может, кто-то сталкивался с подобным? Где копать?

Ответили: пост №2 , пост №5
D.G.P.
читатель
офлайн
Дата регистрации: 30.06.2012
Сообщений: 5
Пост №2
 
23.01.2019 02:08
Ответ на пост №1

Aksy, аналогичная проблема.

Ошибка в коде регламентной операции у 1С.
Проявляется, вроде, только при расчёте за год.

Ответьте, пожалуйста, у ваших объектов не менялась регистрация в налоговом органе за прошлый год?

Самое обидное, что нет никакой, даже теоретической, возможности ввести данные вручную через правку регистров - регламентная операция просто не проводится.

Процедура, рассчитывающая налог на имущество, выдаёт таблицу, которую потом записывает в регистр, в этой таблице есть дублированные строки с полным совпадением данных в колонках ресурсов регистра. При записи в регистр происходит ошибка, проведение прерывается.

Код расчёта налога на имущество чудовищно большой, поэтому не очень хочется в него залезать.
Ждать новой версии от 1С выход конечно, но не для нас.

Я не нашёл решения путём изменения учётных данных, если кто-то сможет - прошу написать.

Я решил проблему аккуратно попросив (в коде) свернуть таблицу перед записью в регистр.


Далее. На свой страх и риск.
Результаты расчётов требуют проверки бухгалтером.
Пожалуйста, сделайте резервную копию.

Если в вашей базе разрешены изменения, попросите программистов внести правку, если изменения запрещены или вы не хотите изменять код, можно попробовать через расширение (см. инструкцию внизу и вложение)
Достаточно либо правки кода, либо расширения.

КОД

Код
ОбщийМодуль РасчетИмущественныхНалогов 
Процедура СформироватьДвиженияРасчетНалога(ТаблицыНачислениеНалога, ТаблицаРеквизитов, Движения, Отказ) Экспорт
Закомментировать строку 4258
Код
//ЗакрытиеМесяца.ЗаписьВоВспомогательныеРегистрыСведений(Движения, Параметры.СправкаРасчет, Параметры.Реквизиты, Реквизиты.ИмяРегистраРасчетНалогов);
Добавить после закомментированной строки и перед
Код
КонецПроцедуры 
следующий код
Код
     // D.G.P. 
     // Исправление ошибки - перед записью в регистр не проверяется наличие полных дублей по измерениям регистра
     // При записи в регистр возникает ошибка. 
     // Для исключения полных дублей требуется свернуть таблицу так, чтобы не было суммирования, то есть по измерениям И ресурсам. 
     // Дублирование в исходном запросе, рассчитывающем справку, происходит по неизвестным причинам, 
     // в любом случае лучше оставить исправление логики расчётов программистам 1С.
      
      МетаданныеРегистра = Метаданные.РегистрыСведений[Реквизиты.ИмяРегистраРасчетНалогов];
      ИменаРеквизитов = Новый Массив;
      Колонки = Параметры.СправкаРасчет.Колонки;
      
      Для Каждого ОписаниеРеквизита Из МетаданныеРегистра["Измерения"] Цикл            
            Если Колонки.Найти(ОписаниеРеквизита.Имя) = Неопределено Тогда 
                  Продолжить;
            КонецЕсли;            
            ИменаРеквизитов.Добавить(ОписаниеРеквизита.Имя);            
      КонецЦикла;
      Для Каждого ОписаниеРеквизита Из МетаданныеРегистра["Ресурсы"] Цикл            
            Если Колонки.Найти(ОписаниеРеквизита.Имя) = Неопределено Тогда 
                  Продолжить;
            КонецЕсли;            
            ИменаРеквизитов.Добавить(ОписаниеРеквизита.Имя);            
      КонецЦикла;

      СтрокаГруппировки = СтрСоединить(ИменаРеквизитов, ",");
      СтрокаСуммирования = "";
      
      ЗакрытиеМесяца.ЗаписьВоВспомогательныеРегистрыСведений(Движения, Параметры.СправкаРасчет, Параметры.Реквизиты, Реквизиты.ИмяРегистраРасчетНалогов, 
      истина,СтрокаГруппировки,СтрокаСуммирования);

РАСШИРЕНИЕ (во вложении)
делает то же самое, но не требует правки кода и может работать на базе с запретом изменений.

Внимание. Перед применением расширения, пожалуйста, просмотрите его код Конфигуратором.
В расширении нет закрытого кода и вирусов, но лучше всегда проверять скачанное из интернета.

Расширение не работает в безопасном режиме, при установке расширения в режиме Предприятие нужно снять признак Безопасный режим.

И приведённый код и расширение позволяют провести Расчёт налога на имущество без ошибки, используя стандартную логику расчёта.
Исключаются только дубли из регистра.

Если и когда 1С всё исправит, расширение можно удалить. Если вы не собираетесь перепроводить закрытие года, расширение тоже можно удалить.
      

Ответили: пост №3
Aksy
читатель
офлайн
Дата регистрации: 01.09.2011
Сообщений: 66
Пост №3
 
24.01.2019 21:12
Ответ на пост №2

D.G.P., благодарю за ответ.

Цитата
Ответьте, пожалуйста, у ваших объектов не менялась регистрация в налоговом органе за прошлый год?
Нет не менялась, все то же самое. Заметила особенность, что проблемные объекты только те, которые зарегистрированы в других налоговых органах, если в них же ставить "по месту нахождения организации" расчет проходит нормально. И еще подняла копию со старым релизом 3.0.65.72, тоже все считает без ошибок.

Ответили: пост №4
D.G.P.
читатель
офлайн
Дата регистрации: 30.06.2012
Сообщений: 5
Пост №4
 
25.01.2019 18:08
Ответ на пост №3

Aksy, Проблема в релизе 3.0.67.70 осталась.
Приведённое исправление работает.
Ошибка проявляется именно тогда, когда сменилась регистрация в налоговом органе в течение года.

Нашли вторую ошибку, связанную с первой.
При выводе Справки-расчёта Налога на имущество без детализации по ИФНС не суммируется срок использования, он же Коэффициент К.
При оставленной детализации по ИФНС неправильно считается сумма в итогах по коэффициенту, если стоит фильтр по ОС.

D.G.P.
читатель
офлайн
Дата регистрации: 30.06.2012
Сообщений: 5
Пост №5
 
25.01.2019 20:09
Ответ на пост №1

Aksy, Обновленное расширение, решающее обе проблемы
1. Позволяет провести Расчет налога на имущество
2. Корректно считает Коэффициент К в справке-расчёте в случае, если было изменение регистрации в налоговом органе.

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • МАРКИРОВКА
  • ЕГАИС
  • Учет, налогообложение, автоматизация
Предложения партнеров
Обучение пользователей продуктов 1С