Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

КД2 строка в дату

Денис
читатель
офлайн
Дата регистрации: 31.03.2016
Сообщений: 20
Пост №1
 
02.07.2020 12:37

Конвертация данных, редакция 2.1 (2.1.8.2)
Переношу данные из УТ 11.1.2.29 в БП 3.0.75.37
УТ
Документ источник: СписаниеБезналичныхДенежныхСредств вид операции Перечисление налога
Реквизит источник: ПоказательПериода (строка)
БП
Документ приёмник: СписаниеСРасчётногоСчета
Реквизит приёмник: НалоговыйПериод (Дата)
Данные источника вносятся пользователем с помощью ФормаВводаПериода, которая в обратном порядке раскладывает данные строки в дату и число для вывода пользователю.
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
      
      ПоказательОснования = Параметры.ПоказательОснования;
      
      ПозицияПериода = Найти(СокрЛП(Параметры.ПоказательПериода),".");
      ПозицияГода = Найти(Сред(СокрЛП(Параметры.ПоказательПериода), ПозицияПериода + 1), ".") + ПозицияПериода;
      ПериодичностьНалога = Лев(СокрЛП(Параметры.ПоказательПериода), ПозицияПериода - 1);
      СтрокаНомерПериода = Сред(СокрЛП(Параметры.ПоказательПериода), ПозицияПериода + 1, ПозицияГода - ПозицияПериода - 1);
      СтрокаГодПериода = Сред(СокрЛП(Параметры.ПоказательПериода), ПозицияГода + 1);
      
      Если Найти("ТП, ЗД", ПоказательОснования) > 0 Тогда
            Если СтрДлина(ПериодичностьНалога) = 2
             И СтрДлина(СтрокаНомерПериода) = 2
             И СтрДлина(СтрокаГодПериода) = 4
             И СтроковыеФункцииКлиентСервер.ТолькоЦифрыВСтроке(ПериодичностьНалога)
             И СтроковыеФункцииКлиентСервер.ТолькоЦифрыВСтроке(СтрокаНомерПериода)
             И СтроковыеФункцииКлиентСервер.ТолькоЦифрыВСтроке(СтрокаГодПериода) Тогда
                  ДатаПоказателя = Дата(Число(СтрокаГодПериода), Число(СтрокаНомерПериода), Число(ПериодичностьНалога));
            КонецЕсли;
      КонецЕсли;
      
      НомерПериода = СтрокаНомерПериода;
      ГодПериода = СтрокаГодПериода;
      
      Если Параметры.ПоказательПериода = "0" Тогда
            ПериодичностьНалога = "0";
      ИначеЕсли Найти("МС,КВ,ПЛ,ГД", ПериодичностьНалога) = 0 Тогда
            ПериодичностьНалога = "-";
      КонецЕсли;
      
      УправлениеЭлементамиФормы();
      
КонецПроцедуры
Вопрос. КАК перенести данные строки в дату? Строка источник выглядит МС.12.2019.
Мои предположиения: перед выгрузкой на стороне источника необходимо привести строку к началу месяца, используя механиз процедуры ПриСозданииНаСервере. Далее педать получившуюся дату в приёмник. Главная проблема как это правильно сделать.

Thorvardr
читатель
офлайн
Дата регистрации: 25.02.2005
Сообщений: 3080
Пост №2
 
18.07.2020 12:48

Написать в обработчик ПередВыгрузкой что-нибудь такое:
ОписаниеПериода = СокрЛП(Источник.ПоказательПериода);
Значение = Прав(ОписаниеПериода,4) + "-" + Сред(ОписаниеПериода,4,2) + "-01T00:00:00";

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • МАРКИРОВКА
  • ЕГАИС
  • Учет, налогообложение, автоматизация
Предложения партнеров
Обучение пользователей продуктов 1С