Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

Как писать Процедуры и Функции в Обработке?

1lord
читатель
офлайн
Дата регистрации: 30.09.2002
Сообщений: 6
Пост №1
 
13.10.2002 22:36

При создании новой(не Выполнить()) функции или процедуры в обработеке возникает ошибка

{Обработка.Загрузка.Форма.Модуль(5)}: Определения процедур и функций должны размещаться перед операторами основной программы

При проверке модуля обнаружены синтаксические ошибки!

ЧТо делать?

Кот, который гуляет сам по себе
читатель
офлайн
Дата регистрации: 29.10.2001
Сообщений: 882
Пост №2
 
14.10.2002 14:16

"Вот пример правильного написания:



Перем Текст;



Процедура ВыдатьСообщение(Текст)

Сообщить(Текст);

КонецПроцедуры



Процедура Сформировать()

Текст = "Вывести сообщенеие";

ВыдатьСообщение(Текст)

КонецПроцедуры





А вот неправильного:



Перем Текст;



Процедура Сформировать()

Текст = "Вывести сообщенеие";

ВыдатьСообщение(Текст)

КонецПроцедуры



Процедура ВыдатьСообщение(Текст)

Сообщить(Текст);

КонецПроцедуры

"

inko
читатель
офлайн
Дата регистрации: 15.09.2002
Сообщений: 117
Пост №3
 
14.10.2002 19:57

В начале процедуры объявите её, например:

Процедура Печать(), а в конце описания процедуры не забудьте дописать: Конец процедуры. То же и с функцией.

Антон
читатель
офлайн
Дата регистрации: 17.10.2002
Сообщений: 7
Пост №4
 
17.10.2002 09:41

"А некоторые, бывает, ставят ; после скобок в объявлении процедуры/функции или после КонецПроцедуры/КонецФункции, что приводит к описанным последствиям."

KV
читатель
офлайн
Дата регистрации: 26.07.2002
Сообщений: 40
Пост №5
 
17.10.2002 10:07

Проверьте глобальные переменные. Они должны находиться перед всеми процедурами и функциями модуля.

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Учет, налогообложение, автоматизация
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги