Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

Как удалить программно элемент справочника в ситуации, нижеизложенной ?

mistletoe
читатель
офлайн
Дата регистрации: 23.09.2002
Сообщений: 22
Пост №1
 
13.11.2002 12:19

"Такая ситуация. Есть справочник Заявок и есть справочник Договоров. В элементе справочника Заявки есть кнопка Сформировать договор, при нажатии на которую формируется новый элемент справочника Договоры и отркывается его форма. После этого заявку нужно удалить. В какой процедуре ее можно удалить?

Я делаю так:

В форме элемента справочника Заявки:



Процедура СформироватьДоговор()

...

Форма.Закрыть();

КонецПроцедуры

Процедура ПриЗакрытии()

....

ОткрытьФорму(Договор,Заявка);

КонецПроцедуры



В форме элемента справочника Договоры:

Процедура ПриОткрытии()

.....

Форма.Параметр.Удалить();

//и тут он мне пишет , что элемент Заявка заблокирован

// это понятно, но не знаю где можно удалить

КонецПроцедуры

Пожалуйста, помогите."

moroder
читатель
офлайн
Дата регистрации: 16.06.2002
Сообщений: 526
Пост №2
 
14.11.2002 07:48

У вас форма договора открывается из процедуры Заявки ПриЗакрытии(), соответственно заявка еще не закрыта в момент вызова метода ПриОткрытии() договора, я бы предложил удалять заявку в Методе ПриЗаписи() Договора...

Лунный
читатель
офлайн
Дата регистрации: 22.05.2002
Сообщений: 11
Пост №3
 
14.11.2002 16:34

"Попробуй



Процедура СформироватьДоговор()

...

Форма.Закрыть(0); // Без запроса

КонецПроцедуры



Вдруг получится"

Анвил
читатель
офлайн
Дата регистрации: 31.10.2002
Сообщений: 12
Пост №4
 
15.11.2002 15:24

"Процедура СформироватьДоговор()

ОткрытьФорму("Элемент.Договор",ТекущийЭлемент());

Форма.Закрыть(0);

КонецПроцедуры



В форме элемента справочника Договоры:



Перем Спр1;



Procedure ПриОткрытии()

спр1=создатьобъект("Справочник.Заявка");

спр1.найтиэлемент(Форма.Параметр);

EndProcedure



Procedure Призаписи()

Спр1.Удалить();

EndProcedure



"

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • МАРКИРОВКА
  • ЕГАИС
  • Учет, налогообложение, автоматизация
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги