Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Новая тема Ответить
Развернуть все [Прочее]

Работа с запросами

Adoff
Пост №1
Adoff
читатель
офлайн
Дата регистрации: 18.09.2002
Сообщений: 19
Пост №1
 
20.11.2002 06:23

"Вопрос программистам:

Составляю запрос для получения списка заявок на выбранную дату отгрузки:



ТекстЗапроса="

|Период с Дата1 по Дата2;

|ОбрабатыватьДокументы Все;

|Обрабатывать НеПомеченныеНаУдаление;

|ЗаявкаПокупателя = Документ.ЗаявкаПокупателя.ТекущийДокумент;

|ДатаОтгрузки = Документ.ЗаявкаПокупателя.ДатаОтгрузки;

|Группировка Заявка;

|Условие(Дата=ДатаОтгрузки);";

Если Запрос.Выполнить(ТекстЗапроса)=0 Тогда

Возврат;

КонецЕсли;



Пока Запрос.Группировка()=1 Цикл

Заявка = Запрос.ЗаявкаПокупателя;

...



КонецЦикла;

      

Так вот, если в запрос попадает хотя бы одна существующая заявка, то в него последней также попадает пустая заявка,

т.е ПустоеЗначение(ЗаявкаПокупателя) = 1. Почему это происходит и как от этого избавиться? Это происходит для любого вида документов.

Заранее спасибо!"

 
Adoff
Пост №1
20.11.2002 06:23
 

"Вопрос программистам:

Составляю запрос для получения списка заявок на выбранную дату отгрузки:



ТекстЗапроса="

|Период с Дата1 по Дата2;

|ОбрабатыватьДокументы Все;

|Обрабатывать НеПомеченныеНаУдаление;

|ЗаявкаПокупателя = Документ.ЗаявкаПокупателя.ТекущийДокумент;

|ДатаОтгрузки = Документ.ЗаявкаПокупателя.ДатаОтгрузки;

|Группировка Заявка;

|Условие(Дата=ДатаОтгрузки);";

Если Запрос.Выполнить(ТекстЗапроса)=0 Тогда

Возврат;

КонецЕсли;



Пока Запрос.Группировка()=1 Цикл

Заявка = Запрос.ЗаявкаПокупателя;

...



КонецЦикла;

      

Так вот, если в запрос попадает хотя бы одна существующая заявка, то в него последней также попадает пустая заявка,

т.е ПустоеЗначение(ЗаявкаПокупателя) = 1. Почему это происходит и как от этого избавиться? Это происходит для любого вида документов.

Заранее спасибо!"

 
Лунный
Пост №2
"Что-то не пойму|Группировка Заявка; А не |Группир...
20.11.2002 10:58
 

Читают тему:

1 гостей
Быстрый переход
Учет, налогообложение, автоматизация
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги
© ООО "1C" 2000-2018 г.