Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

Как перенести элемент справочника из группы в "корень" справочника программно?

Натусик.Ру
читатель
офлайн
Дата регистрации: 10.11.2004
Сообщений: 52
Пост №1
 
30.03.2006 10:57

"Требуется изменить Родителя элемента справочника, а именно - сделать так, чтобы он не входил ни в какую группу.<br>Пишу так:<br>Спр.ВыбратьЭлементы;<br> Пока Спр.ПолучитьЭлемент()=1 Цикл <br> ТекЭл=Спр.ТекущийЭлемент(); <br> Если (ТекЭл.ЭтоГруппа()=0) и (ТекЭл.Уровень()>1) Тогда<br> ТекЭл.Родитель=ПолучитьПустоеЗначение("Справочник.Номенклатура"); <br> КонецЕсли;<br> КонецЦикла; <br><br>Выдает: Объект не может быть перепозиционирован!<br>Похожий вопрос нашла на форуме, но четкого ответа там нет.<br><br>Подскажите, пожалуйста, может я что не так делаю? "

Serg_Smi
читатель
офлайн
Дата регистрации: 02.06.2005
Сообщений: 83
Пост №2
 
30.03.2006 21:27

"Пускай длинно, но верно:<br><br> Спр = СоздатьОбъект("Справочник.<вид справочника>");<br> Спс=СоздатьОбъект("СписокЗначений");<br> Спр.ВыбратьЭлементы();<br> Пока Спр.ПолучитьЭлемент()=1 Цикл<br> Если (Спр.ЭтоГруппа()=0) и (Спр.Уровень()>1) Тогда<br> Спс.ДобавитьЗначение(Спр.ТекущийЭлемент());<br> КонецЕсли;<br> КонецЦикла;<br> Для Сч=1 По Спс.РазмерСписка() Цикл<br> Спр.НайтиЭлемент(Спс.ПолучитьЗначение(Сч));<br> Спр.Родитель=""""; <br> Спр.Записать();<br> КонецЦикла;<br><br>"

Tanya
читатель
офлайн
Дата регистрации: 03.12.2001
Сообщений: 8411
Пост №3
 
30.03.2006 21:46

"спр=СоздатьОбъект("Справочник.Номенклатура");<br>спр.ВыбратьЭлементы(0); <br>пока спр.получитьэлемент()=1 цикл <br> если спр.Текущийэлемент().ЭтоГруппа()=0 тогда<br> спр.Родитель="""";<br> спр.записать();                              <br> конецесли;<br>конеццикла;"

Serg_Smi
читатель
офлайн
Дата регистрации: 02.06.2005
Сообщений: 83
Пост №4
 
30.03.2006 21:51

Сколько раз по Вашему я должен прогнать данный цикл?

Tanya
читатель
офлайн
Дата регистрации: 03.12.2001
Сообщений: 8411
Пост №5
 
31.03.2006 09:29

Один раз.<br><br>ВыбратьЭлементы(<Режим>)<br>Параметры: <br><Режим> - как выбирать:<br>1 - выбирать элементы с учетом иерархии,<br>0 - выбирать элементы без учета иерархии (необязателен, по умолчанию - 1).<br>

Serg_Smi
читатель
офлайн
Дата регистрации: 02.06.2005
Сообщений: 83
Пост №6
 
31.03.2006 20:23

Согласен, (0) не заметил.<br>Спасибо за поправку.

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • МАРКИРОВКА
  • ЕГАИС
  • Учет, налогообложение, автоматизация
Предложения партнеров
Обучение пользователей продуктов 1С