Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

Загрузка информации в 1С (форматы файлов загрузки)

Nataly
Пост №1
Nataly
читатель
офлайн
Дата регистрации: 24.08.2001
Сообщений: 3
Пост №1
 
24.08.2001 12:59

Необходимо переместить некоторый объем информации из некой программы оперативного учета в 1С:Бухгалтерию. Как должны выглядеть данные в TXT-шном файле, чтобы попасть в нужное место в 1С???????

Trancer
Пост №2
Trancer
читатель
офлайн
Дата регистрации: 30.08.2001
Сообщений: 3
Пост №2
 
30.08.2001 13:25

Все зависит от того какие данные вы хотите переместить. Думаю лучше использовать не txt-файлы, а dbf. Скорее всего вам понадобится хороший программист, т.к. это не простая задача.

POLYMORF
Пост №3
POLYMORF
читатель
офлайн
Дата регистрации: 07.09.2001
Сообщений: 1
Пост №3
 
07.09.2001 10:06

"да нет, это не так уж и сложно...вот например, загрузка справочника из текстового файла (пусть код немного корявый, зато работает исправно):

////////////////////////////////////////////////////­//////////////

Процедура ЭкспортР()

Рез=Вопрос("Провести обновление РЕЕСТРА?" + РазделительСтрок + "ПРЕДУПРЕЖДЕНИЕ: это займет несколько минут......",1);

Если Рез=1 Тогда





Состояние("Открытие справочника");

aaaa=0;

Спр=СоздатьОбъект("Справочник.Номенклатура");

Текст=СоздатьОбъект("Текст");

Текст.Открыть("xls.txt");

Для Ном=2 По Текст.КоличествоСтрок() Цикл

Стр=Текст.ПолучитьСтроку(Ном);

Поле=0;

Пока СтрДлина(Стр)>0 Цикл

Поле=Поле+1;

Инд=Найти(Стр,СимволТабуляции);

Если Инд>0 Тогда

Стр1=Сред(Стр,1,Инд-1);

Стр=Сред(Стр,Инд+1);

Иначе

Стр1=Сред(Стр,2,(СтрДлина(Стр)-2));

Стр="""";

КонецЕсли;

Если Поле=1 Тогда



Спр.ПорядокКодов();

       Спр.ВыбратьЭлементы();

       aaaa=0;

       Пока Спр.ПолучитьЭлемент()>0 Цикл

       Состояние("Проводится поиск позиции " + Стр1 +" в текущем реестре");

Если Спр.Код=Стр1 Тогда

       goto ~M1;

       КонецЕсли;

       aaaa=aaaa+1;

      

       КонецЦикла;

Спр.Новый();

Спр.Код=Стр1;

ИначеЕсли Поле=2 Тогда

Спр.Наименование=Стр1;

ИначеЕсли Поле=3 Тогда

Спр.Наименование=Спр.Наименование + " " + Стр1;

//Спр.Вид=Стр1;

ИначеЕсли Поле=4 Тогда

Спр.Цена=Стр1;

ИначеЕсли Поле=5 Тогда

ИначеЕсли Поле=6 Тогда

Стр="""";

КонецЕсли;

~M1: КонецЦикла;



Состояние("Обрабатывается "+ Ном +" позиция экспортируемого реестра из "+Текст.КоличествоСтрок());

Спр.Записать();



КонецЦикла;



КонецЕсли;

КонецПроцедуры "

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Учет, налогообложение, автоматизация
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги
© ООО "1C" 2000-2018 г.