Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

Загрузка информации в 1С (форматы файлов загрузки)

Nataly
читатель
офлайн
Дата регистрации: 24.08.2001
Сообщений: 3
Пост №1
 
24.08.2001 12:59

Необходимо переместить некоторый объем информации из некой программы оперативного учета в 1С:Бухгалтерию. Как должны выглядеть данные в TXT-шном файле, чтобы попасть в нужное место в 1С???????

Trancer
читатель
офлайн
Дата регистрации: 30.08.2001
Сообщений: 3
Пост №2
 
30.08.2001 13:25

Все зависит от того какие данные вы хотите переместить. Думаю лучше использовать не txt-файлы, а dbf. Скорее всего вам понадобится хороший программист, т.к. это не простая задача.

POLYMORF
читатель
офлайн
Дата регистрации: 07.09.2001
Сообщений: 1
Пост №3
 
07.09.2001 10:06

"да нет, это не так уж и сложно...вот например, загрузка справочника из текстового файла (пусть код немного корявый, зато работает исправно):<br><br>////////////////////////////////////////////////////­//////////////<br><br>Процедура ЭкспортР()<br><br> Рез=Вопрос("Провести обновление РЕЕСТРА?" + РазделительСтрок + "ПРЕДУПРЕЖДЕНИЕ: это займет несколько минут......",1);<br><br> Если Рез=1 Тогда<br><br> <br><br><br><br> Состояние("Открытие справочника");<br><br>aaaa=0;<br><br>Спр=СоздатьОбъект("Справочник.Номенклатура");<br><br>Текст=СоздатьОбъект("Текст");<br><br>Текст.Открыть("xls.txt");<br><br>Для Ном=2 По Текст.КоличествоСтрок() Цикл <br><br> Стр=Текст.ПолучитьСтроку(Ном);<br><br> Поле=0;<br><br> Пока СтрДлина(Стр)>0 Цикл<br><br> Поле=Поле+1;<br><br> Инд=Найти(Стр,СимволТабуляции);<br><br> Если Инд>0 Тогда <br><br> Стр1=Сред(Стр,1,Инд-1);<br><br> Стр=Сред(Стр,Инд+1);<br><br> Иначе<br><br> Стр1=Сред(Стр,2,(СтрДлина(Стр)-2));<br><br> Стр="""";<br><br> КонецЕсли;<br><br> Если Поле=1 Тогда<br><br> <br><br> Спр.ПорядокКодов();<br><br>       Спр.ВыбратьЭлементы();<br><br>       aaaa=0;<br><br>       Пока Спр.ПолучитьЭлемент()>0 Цикл<br><br>       Состояние("Проводится поиск позиции " + Стр1 +" в текущем реестре");<br><br> Если Спр.Код=Стр1 Тогда <br><br>       goto ~M1; <br><br>       КонецЕсли;<br><br>       aaaa=aaaa+1;<br><br>       <br><br>       КонецЦикла; <br><br> Спр.Новый(); <br><br> Спр.Код=Стр1;<br><br> ИначеЕсли Поле=2 Тогда<br><br> Спр.Наименование=Стр1;<br><br> ИначеЕсли Поле=3 Тогда<br><br> Спр.Наименование=Спр.Наименование + " " + Стр1;<br><br> //Спр.Вид=Стр1;<br><br> ИначеЕсли Поле=4 Тогда<br><br> Спр.Цена=Стр1;<br><br> ИначеЕсли Поле=5 Тогда<br><br> ИначеЕсли Поле=6 Тогда<br><br> Стр="""";<br><br> КонецЕсли;<br><br> ~M1: КонецЦикла;<br><br> <br><br> Состояние("Обрабатывается "+ Ном +" позиция экспортируемого реестра из "+Текст.КоличествоСтрок()); <br><br> Спр.Записать();<br><br> <br><br>КонецЦикла; <br><br><br><br> КонецЕсли;<br><br>КонецПроцедуры "

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • МАРКИРОВКА
  • ЕГАИС
  • Учет, налогообложение, автоматизация
Предложения партнеров
Обучение пользователей продуктов 1С