Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

УстановитьАтрибут почему то не работает

Mr.Firestarter
Пост №1
Mr.Firestarter
читатель
офлайн
Дата регистрации: 08.01.2003
Сообщений: 44
Пост №1
 
03.03.2003 12:50

"Народ,у меня вопрос,мне надо подкорежить обработку документов таким образом,чтобы у всех документов с выключенными проводками автоматически устанавливалось значение реквизита шапки(имеется в виду,что виды документов у которых данные проводки могут быть выключены,известны),являющегося видом субконто(реквизит в документах есть) и потом собственно они и проводились(чтобы в операциях этотоже отражалось):Текст следующий:



Обработка = "ПровестиСПризнаком" Тогда

Если (Док.Операция.ВключитьПроводки()=0) и

(Док.Вид()="ПоступлениеТоваров") Тогда

Если Док.ПометкаУдаления() = 1 Тогда

ИначеЕсли СписокНеПроводимыхДокументов.НайтиЗначение(Док.Вид()) = 0 Тогда

Сообщить("Проведение "+Док);

Док.УстановитьАтрибут("Реквизит",1);

Если МонопольныйРежим() = 1 Тогда

БИ.Рассчитать(, Док.ТекущийДокумент());

КонецЕсли;

Если Док.Провести() = 0 Тогда

Возврат;

КонецЕсли;

КонецЕсли;

Иначе

Сообщить(Док.ТекущийДокумент()+"Не подходит по условию");

Продолжить;

КонецЕсли;



Так вот,после того как все провелось,я захожу,смотрю,операции,а это субконто(связанное с реквизитом) пустое(причем я потом захожу в документ,ставлю нужное,и тогда появляется )...Народ,помогите,а? "

granitv
Пост №2
granitv
читатель
офлайн
Дата регистрации: 08.08.2002
Сообщений: 363
Пост №2
 
03.03.2003 14:07

Вроде, после установки атрибута требуется записать документ?

А то проводить будет со старыми значениями реквизитов. Или я не прав?

Mr.Firestarter
Пост №3
Mr.Firestarter
читатель
офлайн
Дата регистрации: 08.01.2003
Сообщений: 44
Пост №3
 
03.03.2003 14:35

А,Семен Семеныч...,совсем забыл....Кстати,если кто-то разбирался в данной обработке,чегой-то я не понял,где там проведение проходит...Кстати,до сих пор не работает

(вставил Док.Записать() на следующей строчке после Установки аттрибута)

granitv
Пост №4
granitv
читатель
офлайн
Дата регистрации: 08.08.2002
Сообщений: 363
Пост №4
 
03.03.2003 22:23

В модуле обработки документов поищи подстроку "Док.Провести()". В типовой конфигурации будет только одно место с этой подстрокой, где и происходит проведение.



Воспользуйся теперь отладчиком, чтобы найти ошибку.

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Учет, налогообложение, автоматизация
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги
© ООО "1C" 2000-2018 г.