Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

ПУБ274 Закрытие месяца не работает

БИГ
читатель
офлайн
Дата регистрации: 01.05.2003
Сообщений: 2
Пост №1
 
01.05.2003 21:35

В ПУБ 274 документ закрытие месяца считает ЕСН ФФОМС и ЕСН ТФОМС не с зарплаты за месяц, а с зарплаты с начала года.

В чем дело - ошибка программы или какие-либо настройки. Учет ведется с 2002 года (было в ПУБ 263), обновление сделано строго по инструкции.

БИГ
читатель
офлайн
Дата регистрации: 01.05.2003
Сообщений: 2
Пост №2
 
01.05.2003 21:41

А остальные налоги считаются правильно, только ФФОМ и ТФОМС нет.

toxy
читатель
офлайн
Дата регистрации: 11.04.2003
Сообщений: 8
Пост №3
 
05.05.2003 12:01

"Это ошибка программы. Сам недавно натолкнулся на это!

(Модуль документа "Закрытие месяца")



Строки 1289: ТФОМС и ФФОМС считаются как:

ФФОМС = ИсчисленныйФФОМС - ФФОМС_Начисленный - НачисленныйЕСН_ФОМС_СНачалаГода;

ТФОМС = ИсчисленныйТФОМС - ТФОМС_Начисленный - НачисленныйЕСН_ТОМС_СНачалаГода;



Строка 1234: ФФОМС_Начисленный считается как:



Если БухИтЕСН.ПолучитьСчет(, СчетПоКоду("69.3.1")) = 1 Тогда // Обращение к счету 69.3.1 !!!!!!!!!!!!!

Если БухИтЕСН.ПолучитьСубконто(2,, Сотрудник) = 1 Тогда

Если БухИтЕСН.ПолучитьСубконто(1,,Перечисление.ВидыПлатежейВБюджет.Налог) = 1 Тогда

ФФОМС_Начисленный = БухИтЕСН.КО();

КонецЕсли;

КонецЕсли;

КонецЕсли;



Для ТФОМС'а аналогично!

Далее смотрим строку 944: Запрос БухИтЕСН выглядит так:



БухИтЕСН.ВыполнитьЗапрос(НачГода(КонецМесяца),КонецМесяца,"НБ,69.1,69.2.1,69.2.2,69.2.3,69.3",,,2); // обращение только к счету 69.3



Здесь берутся итоги в целом по счету 69.3!!! Хотя в 274 он поделен на 69.3.1 и 69.3.2. Значит при обращении к счету "СчетПоКоду("69.3.1")" , БухИтЕСН.КО() будет давать 0!!!!!! И ФФОМС и ТФОМС будет с зарплаты с начала года



Соответственно исправление ошибки:

Исправляем строку 944 на БухИтЕСН.ВыполнитьЗапрос(НачГода(КонецМесяца),КонецМесяца,"НБ,69.1,69.2.1,69.2.2,69.2.3,69.3.1,69.3.2",,,2);



Всего наилучшего, Ермолин Андрей. aermolin@satis.ru"

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Учет, налогообложение, автоматизация
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги