Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

Что за новая приблуда в Глобальном модуле ЗиК- НомерДняПериода?

sol-adm
читатель
офлайн
Дата регистрации: 27.04.2007
Сообщений: 7
Пост №1
 
30.05.2008 13:02

"Функция глЗаполнитьМассивДней(МассивДней[], Сотрудник, ДатаНачала, ДатаОкончания, Режим=0, СписокВР = 0) Экспорт<br><br>В 282 было так<br>Для инд = 0 по ДнейПо Цикл<br> ИндДня = НомерДняГода(ЖрнЗарплата.ДатаНачала+инд);<br> МассивДней[ИндДня] = ?(МассивДней[ИндДня]<>"Х",МассивДней[ИндДня] + ?(ЖрнЗарплата.Сторно=0,-1,1),"Х");<br>КонецЦикла;<br><br>В 283 стало так<br>Для инд = 0 по ДнейПо Цикл<br> ИндДня = НомерДняПериода(ДатаНачала,ЖрнЗарплата.ДатаНачала+инд);<br> МассивДней[ИндДня] = ?(МассивДней[ИндДня]<>"Х",МассивДней[ИндДня] + ?(ЖрнЗарплата.Сторно=0,-1,1),"Х");<br>КонецЦикла;<br><br>И теперь НомерДняПериода при начислении зарплаты иногода позвращает отрицательное значение... что-то тут перемудрили.<br><br>Можно ли до исправления косяков вернуть вариант 282?"

impuls
читатель
офлайн
Дата регистрации: 24.11.2005
Сообщений: 1798
Пост №2
 
30.05.2008 14:03

Можете привести конкретный пример для записи не сторно?

sol-adm
читатель
офлайн
Дата регистрации: 27.04.2007
Сообщений: 7
Пост №3
 
30.05.2008 14:10

А что для примера?<br>Ну например.. есть штатный сотрудник, на него выписан приказ на оплату по среднему заработку <br>Событие - Командировка<br><br>Период указан с 17.04.2008 по 19.04.2008<br><br>Проведено...<br><br>При расчёте ЗП, на нём вышибает, т.к. эта приблуда, получая от вышеуказанной функции даты 17.04.2008 и 21.04.2008 на выходе выдаёт -3 ... сообветственно массив вылетает с треском.<br><br>До обновления считало дни от начала года и всё было путём, а щас похоже сделали нововведение, но запутались с периодами, где-то нормально, а где смешали мух с котлетами.

sol-adm
читатель
офлайн
Дата регистрации: 27.04.2007
Сообщений: 7
Пост №4
 
30.05.2008 15:02

Пытался пробиться до техподдержи, но так и не дозвонился.

impuls
читатель
офлайн
Дата регистрации: 24.11.2005
Сообщений: 1798
Пост №5
 
31.05.2008 14:34

"У меня такого не наблюдается, не смог найти вариант. Может быть, Вы вручную правили конфигурацию или некорректно обновили? Проверьте ситуацию на типовой или демо базе. Почему у Вас в документе окончание 19.04, а из-за НомерДняПериода(), состоящей из одной строки<br> Возврат ДатаПериода - ДатаНачала + 1;<br>возвращается 21.04? Проверьтесь на вирусы."

tehnik_gor
читатель
офлайн
Дата регистрации: 31.07.2006
Сообщений: 250
Пост №6
 
09.06.2008 10:53

У нас аналогичная ошибка проявилась при вводе расчета сотруднику доплата за замещение, разница в окладах.<br><br>Период 28 мая - 30 мая, на время нахождения замещаемого соитрудника в отпуске.<br><br>Полностью аналогичная ошибка при расчете зарплаты!

TAndrik
читатель
офлайн
Дата регистрации: 09.06.2008
Сообщений: 9
Пост №7
 
09.06.2008 13:22

Проблемма один в один. Появляется при вводе доплаты за замещение процентом.

Вячеслав_81
читатель
офлайн
Дата регистрации: 10.06.2008
Сообщений: 8
Пост №8
 
10.06.2008 12:29

Кто-нибудь смотрел здесь: http://www.forum.mista.ru/topic.php?id=339116&forum=1c , это - полностью правильно?

TAndrik
читатель
офлайн
Дата регистрации: 09.06.2008
Сообщений: 9
Пост №9
 
10.06.2008 13:11

Спасибо за ссылку! Помогло.

TAndrik
читатель
офлайн
Дата регистрации: 09.06.2008
Сообщений: 9
Пост №10
 
10.06.2008 14:06

"Вот что сообщил мне отдел техподдержки:<br><br>Ошибка зарегистрирована.<br>Планируется к исправлению в следующем релизе.<br><br>Способ исправления:<br>В глобальном модуле заменить строки, начиная со строки 33006:<br>Для инд = 0 по ДнейПо Цикл<br>ИндДня = НомерДняПериода(ДатаНачала,ЖрнЗарплата.ДатаНачала+инд);<br>МассивДней[ИндДня] = ?(МассивДней[ИндДня]<>"Х",МассивДней[ИндДня] + ?(ЖрнЗарплата.Сторно=0,-1,1),"Х");<br>КонецЦикла;<br><br>на строки:<br><br>НачалоФрагмента = Макс(ЖрнЗарплата.ДатаНачала,ДатаНачала);<br>Для инд = 0 по ДнейПо Цикл<br>ИндДня = НомерДняПериода(ДатаНачала,НачалоФрагмента+инд);<br>МассивДней[ИндДня] = ?(МассивДней[ИндДня]<>"Х",МассивДней[ИндДня] + ?(ЖрнЗарплата.Сторно=0,-1,1),"Х");<br>КонецЦикла;"

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • МАРКИРОВКА
  • ЕГАИС
  • Учет, налогообложение, автоматизация

Мероприятия

17 ноября 2021 годаБизнес-форум 1С:ERP

1C:Лекторий: 21 октября 2021 года (четверг, начало в 10:00)Прослеживаемость и новая декларация по НДС, реализация в "1С:Бухгалтерии 8"

1C:Лекторий: 28 октября 2021 года (четверг, начало в 10:00)Налоговый мониторинг: порядок перехода, преимущества для налогоплательщиков, поддержка в решениях 1С

Все мероприятия
Предложения партнеров
Обучение пользователей продуктов 1С