Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

Извлечь корень

Avenger
читатель
офлайн
Дата регистрации: 28.04.2009
Сообщений: 2
Пост №1
 
28.04.2009 12:08

Можно ли в редакции 7.7 извлечь корень из числа? Если да то как!?

natulishka
читатель
офлайн
Дата регистрации: 28.04.2009
Сообщений: 4
Пост №2
 
28.04.2009 12:21

"Встроенной функции нет. Нашла в интернете:

Функция Корень(Основание,Степень)
Если Степень = 1 Тогда Возврат(Основание);
КонецЕсли;
Факториал = 1; Степень_ = 1; Сум = 0;
СтепеньЕ = 1/Степень*Лог(Основание);
Для ии = 1 по 28 Цикл
Факториал = Факториал * ии;
Степень_ = Степень_ * СтепеньЕ;
Сум = Сум + Степень_/Факториал
КонецЦикла;
Возврат(1+Сум);
КонецФункции"

Avenger
читатель
офлайн
Дата регистрации: 28.04.2009
Сообщений: 2
Пост №3
 
28.04.2009 13:11

"При "СтепеньЕ = 1/Степень*Лог(Основание);" происходит деление на 0"

natulishka
читатель
офлайн
Дата регистрации: 28.04.2009
Сообщений: 4
Пост №4
 
28.04.2009 15:28

"А так?

Функция Корень(Основание,Степень)
Четность = Степень / 2;
Если (Основание < 0) И (Четность = Окр(Четность)) Тогда
Предупреждение("Для четной степени корня основание должно быть неотрицательным");
Возврат("""");            
ИначеЕсли (Основание < 0) И (Четность <> Окр(Четность)) Тогда
Основание = -1 * Основание;
Флаг = 1;
КонецЕсли;
Если (Степень = 1) ИЛИ (Основание = 1) Тогда
Если Флаг = 0 Тогда
Возврат(Основание);
Иначе
Возврат(- 1 * Основание);
Основание = -1 * Основание;
КонецЕсли;
КонецЕсли;
Если (Степень = 0) И (Основание = 0) Тогда
Возврат(0);
ИначеЕсли (Степень = 0) И (Основание <> 0) Тогда
Возврат(1);
ИначеЕсли (Степень <> 0) И (Основание = 0) Тогда
Возврат(0);
КонецЕсли;
Факториал = 1; Степень_ = 1; Сум = 0;
СтепеньЕ = 1/Степень*Лог(Основание);
Для ии = 1 по 28 Цикл
Факториал = Факториал * ии;
Степень_ = Степень_ * СтепеньЕ;
Сум = Сум + Степень_/Факториал
КонецЦикла;
Если Флаг = 1 Тогда
Основание = -1 * Основание;
Возврат(-1 * (1+Сум));
Иначе
Возврат(1+Сум);
КонецЕсли;
КонецФункции"

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Учет, налогообложение, автоматизация
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги