Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[1С:Предприятие 7.7]

7.7 ОШИБКА в релизе Бух664: книги покупок/продаж НЕ выводится ИНН

USSR
активный пользователь
офлайн
Дата регистрации: 12.01.2011
Сообщений: 725
Пост №1
 
30.09.2021 12:28

1С, исправьте ошибку. НЕ выводится ИНН в отчетах:
Книга покупок по Постановлению № 1137
Книга продаж по Постановлению № 1137
из-за вот этой новой функции:

Функция ПечатьИННКПП(СтрИННКПП)
      
      СтрИНН = "";
      СтрКПП = "";
      
      Позиция = Найти(СтрИННКПП, "/");
      
      Если Позиция > 0 Тогда
            СтрИНН = СокрЛП(Лев(СтрИННКПП, Позиция - 1));
            СтрКПП = СокрЛП(Сред(СтрИННКПП, Позиция + 1));
      КонецЕсли;
      
      Возврат СтрИНН + ?(ПустоеЗначение(СтрКПП) = 0, "/", "") + РазделительСтрок + СтрКПП;
      
КонецФункции

1) контрагент может быть ИП и тогда у него нет КПП и соответственно слеша, т.е. "Позиция=0"
2) пользователь может забыть указать КПП у контрагента, раньше хотя бы выводился ИНН, теперь просто - ПУСТО

Ответили: пост №4
USSR
активный пользователь
офлайн
Дата регистрации: 12.01.2011
Сообщений: 725
Пост №2
 
30.09.2021 12:32

И вообще, эту функцию
Функция ПечатьИННКПП(СтрИННКПП)
можно было написать в глобальном модуле, чтобы не править в нескольких местах.

USSR
активный пользователь
офлайн
Дата регистрации: 12.01.2011
Сообщений: 725
Пост №3
 
30.09.2021 12:43

Для тех, кто "дружит" с Конфигуратором, можете в этих отчётах (КнигаПокупок1137 и КнигаПродаж1137) сделать следующую поправку (добавленные строки указаны жирным шрифтом):

Функция ПечатьИННКПП(СтрИННКПП)
      
      СтрИНН = "";
      СтрКПП = "";
      
      // на случай, если КПП не указан
      СтрИНН = СокрЛП(СтрИННКПП);

      Позиция = Найти(СтрИННКПП, "/");
      
      Если Позиция > 0 Тогда
            СтрИНН = СокрЛП(Лев(СтрИННКПП, Позиция - 1));
            СтрКПП = СокрЛП(Сред(СтрИННКПП, Позиция + 1));
      КонецЕсли;
      
      Возврат СтрИНН + ?(ПустоеЗначение(СтрКПП) = 0, "/", "") + РазделительСтрок + СтрКПП;
      
КонецФункции

Редакция БУХ 1С
активный пользователь
офлайн
Дата регистрации: 11.05.2016
Сообщений: 64
Пост №4
 
01.10.2021 15:06
Ответ на пост №1

USSR, Ошибка зарегистрирована с кодом 30177158.
В ближайшее время выпустим исправительный релиз.

Ответили: пост №5
USSR
активный пользователь
офлайн
Дата регистрации: 12.01.2011
Сообщений: 725
Пост №5
 
01.10.2021 15:42
Ответ на пост №4

Редакция БУХ 1С, спасибо за ответ. Будем ждать...

zed_ds
читатель
офлайн
Дата регистрации: 25.04.2008
Сообщений: 96
Пост №6
 
11.10.2021 16:37

в 665 не исправили эту ошибку, правда процедуру перенесли в глобальный модуль ))

Ответили: пост №7
TFloater
активный пользователь
онлайн
Дата регистрации: 31.01.2012
Сообщений: 31
Пост №7
 
11.10.2021 18:53
Ответ на пост №6

zed_ds, исправили. У ИП стал выводиться ИНН. Интереснее другое. Зачем вообще вводили всю эту заморочку с функциями печати ИНН/КПП и даты-номера? Я так понимаю, из-за того, что добавились колонки для пресловутого прослеживаемого товара. Чтобы как-то сэкономить ширину таблицы, решили сузить колонки ИНН/КПП и дата-номер СФ (это просто в глаза бросается) и принудительно выводить их на печать в две строки вместо одной.
Соответственно вместо вызова
       ПечИННКПП = глПечатьИННКПП(ПечИННКПП);
можно было спокойно создать пару переменных отчёта:
СлэшСПереносом = "/"+РазделительСтрок;
ОбратныйСлэшСПереносом = "\"+РазделительСтрок;
и написать
       ПечИННКПП = СтрЗаменить(ПечИННКПП,"/",СлэшСПереносом);
       ПечИННКПП = СтрЗаменить(ПечИННКПП,"\",ОбратныйСлэшСПереносом);
Не будет слэша (то бишь КПП) — не будет и замены, так?..

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Представление регламентированной отчетности
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • МАРКИРОВКА
  • ЕГАИС
  • Учет, налогообложение, автоматизация

Мероприятия

17 ноября 2021 годаБизнес-форум 1С:ERP

1C:Лекторий: 19 октября 2021 года (вторник, начало в 12:00, все желающие)Маркировка лекарственных средств на примере "1С:Управление аптечной сетью" и "ОКСи:Рабочее место кассира"

1C:Лекторий: 21 октября 2021 года (четверг, начало в 10:00)Прослеживаемость и новая декларация по НДС, реализация в "1С:Бухгалтерии 8"

Все мероприятия
Предложения партнеров
Обучение пользователей продуктов 1С