Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

Бухгалтерия 7.7 Ошибки в коде документа «Формирование записей книги покупок»

danil
читатель
офлайн
Дата регистрации: 15.10.2004
Сообщений: 45
Пост №1
 
17.03.2006 08:35

"Программные средства:1С Предприятие 7.7 (сетевая версия) (7.70.025) Конфигурация Бухгалтерский учет, редакция 4.5 (7.70.474)
Метод определения выручки от реализации для учета НДС с 01.01.2006 «По отгрузке», ранее «По оплате».

Текст модуля формы документа "Формирование записей книги покупок"

Процедура Заполнить()
...
Если ПустоеЗначение(СФ) = 1 Тогда
ДобавитьСтроку = 0;

ИначеЕсли (ДатаДок >= НачалоГода2006) и (СФ.ДатаДок >= НачалоГода2006) Тогда
ДобавитьСтроку = 1;

Иначе
ДобавитьСтроку = 0;
КонецЕсли;

Если ДобавитьСтроку = 1 Тогда
НоваяСтрокаКнигиПокупок(Док,СФ,СтрокаТабУчтенныхСумм);

Иначе
Если СуммаОплаты > ЗадолженностьПоСФ Тогда
СуммаЗКП = ЗадолженностьПоСФ;
СуммаОплаты = СуммаОплаты - ЗадолженностьПоСФ;
Иначе
СуммаЗКП = СуммаОплаты;
СуммаОплаты = 0;
КонецЕсли;
//Рассчитать НДС и добавить строку в документ
ПоДокументуОплаты(Док,СФ,СуммаЗКП,БухИт,СтрокаТабУчтенныхСумм);
КонецЕсли;
...

Процедура ПоДокументуОплаты(ДокОпл,Док,ЗачестьВсего,Итоги,СтрокаТабУчтенныхСумм)

НоваяСтрока();
ДатаНомерСчетаФактуры = Док.ДатаНомерСчетаФактуры;
...

Спрашивается, если мы передаем заведомо пустое значение, то зачем обращаемся к нему?!!!!!!
"

danil
читатель
офлайн
Дата регистрации: 15.10.2004
Сообщений: 45
Пост №2
 
17.03.2006 10:47

"Извиняюсь, проблема возникала в другом месте, а именно в строке
ПоДокументуОплаты(Док,БухИт.Субконто(3),СуммаЗКП,БухИт,СтрокаТабУчтенныхСумм);
передавалось пустое значение БухИт.Субконто(3). Однако почему срубалось заполнение документа, а не было просто сообщения об ошибке.

Решение.
Нашел документ «Операция» № 0000435 от 01.10.05, в котором были не заполнены Субконто(3) у Кт ЗПК.20.Н и Кт ЗПК.20.Б.
Заполнил эти субконто (СчетаФактурыПолученные) и все стало хорошо.
"

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • МАРКИРОВКА
  • ЕГАИС
  • Учет, налогообложение, автоматизация
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги