Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

Бухгалтерия, запрос не прет !!!!!!!!!!!

Zuf
читатель
офлайн
Дата регистрации: 20.06.2003
Сообщений: 17
Пост №1
 
20.06.2003 16:48

"Написал простенький отчет Процедура Сформировать()<br><br> Перем Запрос, ТекстЗапроса, Таб;<br><br> //Создание объекта типа Запрос<br><br> Запрос = СоздатьОбъект("Запрос");<br><br> ТекстЗапроса = <br><br> "//{{ЗАПРОС(Сформировать)<br><br> |Период с ВыбНачПериода по ВыбКонПериода;<br><br> |Сч = Операция.Счет;<br><br> |КорСч = Операция.КорСчет;<br><br> |Сумма = Операция.Сумма;<br><br> |ПланСчетов = Операция.ПланСчетов;<br><br> |Покупатель = Операция.Субконто.Контрагенты;<br><br> |РУ = Операция.РУ;<br><br> |Функция Кор = ДО(Сумма);<br><br> |Функция КорДО = КорДО(Сумма);<br><br> |Функция КорКО = КорКО(Сумма);<br><br> |Группировка Сч;<br><br> |Группировка КорСч;<br><br> |Группировка Покупатель;<br><br> |Условие(ПланСчетов=ВыбПланСчетов);<br><br> |"//}}ЗАПРОС<br><br> ;<br><br> // Если ошибка в запросе, то выход из процедуры<br><br> Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда<br><br> Возврат;<br><br> КонецЕсли;<br><br> <br><br> // Подготовка к заполнению выходных форм данными запроса<br><br> Таб = СоздатьОбъект("Таблица");<br><br> Таб.ИсходнаяТаблица("Сформировать");<br><br> // Заполнение полей "Заголовок"<br><br> Таб = СоздатьОбъект("Таблица");<br><br> Таб.ИсходнаяТаблица("Сформировать");<br><br> Таб.ВывестиСекцию("Заголовок");<br><br> Состояние("Заполнение выходной таблицы...");<br><br> Таб.Опции(0, 0, Таб.ВысотаТаблицы(), 0);<br><br> Пока Запрос.Группировка(1) = 1 Цикл<br><br> // Заполнение полей Сч<br><br> Таб.ВывестиСекцию("Сч");<br><br> Пока Запрос.Группировка(2) = 1 Цикл<br><br> // Заполнение полей КорСч<br><br> Таб.ВывестиСекцию("КорСч");<br><br> КонецЦикла;<br><br> КонецЦикла;<br><br> // Заполнение полей "Итого"<br><br> Таб.ВывестиСекцию("Итого");<br><br> // Вывод заполненной формы<br><br> Таб.ТолькоПросмотр(1);<br><br> Таб.Показать("Сформировать", """");<br><br>КонецПроцедуры<br><br>Нужно написать довольно сложный отчет, но не идет даже простой!!!!!!!!!!!!<br><br>Все нормально когда ВыбПланСчетов=Основному плану счетов, а по другому планау счетов выходит только итоговая сумма."

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • МАРКИРОВКА
  • ЕГАИС
  • Учет, налогообложение, автоматизация

Мероприятия

17 ноября 2021 годаБизнес-форум 1С:ERP

1C:Лекторий: 28 октября 2021 года (четверг, начало в 10:00)Налоговый мониторинг: порядок перехода, преимущества для налогоплательщиков, поддержка в решениях 1С

1C:Лекторий: 2 ноября 2021 года (вторник, начало в 10:00, все желающие)Новые источники данных в 1С:Аналитике

Все мероприятия
Предложения партнеров
Обучение пользователей продуктов 1С