Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

Не подвязывается владелец к подчиненному справочнику. ЗиК 77

poldarsa
читатель
офлайн
Дата регистрации: 08.02.2007
Сообщений: 604
Пост №1
 
10.06.2008 09:30

"Вот кусок кода.<br>ВидРНС_ПЗ=СоздатьОбъект("СписокЗначений");<br>СпрВРНС_ПЗ = СоздатьОбъект("Справочник.ДополнительныеПроводки");<br>СпрВРНС_ПЗ_база = СоздатьОбъект("Справочник.ДополнительныеПроводкиБаза");<br>СпрВРНС_ПЗ.НайтиПоКоду("ФСС_НС");<br>СпрВРНС_ПЗ_база.ИспользоватьВладельца(СпрВРНС_ПЗ.ТекущийЭлемент());<br>СпрВРНС_ПЗ_база.ВыбратьЭлементы();<br>Пока СпрВРНС_ПЗ_база.ПолучитьЭлемент()=1 Цикл<br> ВидРНС_ПЗ.ДобавитьЗначение(СпрВРНС_ПЗ_база.Расчет,);<br>КонецЦикла;<br>В локальной базе все отрабатывает без проблем. На сетевой базе , почему-то не подвязывается владелец, Список значений получается пустой. Может кто подскажет в чем дело?"

Thorvardr
читатель
офлайн
Дата регистрации: 25.02.2005
Сообщений: 3082
Пост №2
 
10.06.2008 12:44

"Имеется ввиду одна и та же база данных? То есть, копия, работающая в локальном режиме и копия, работающая в сетевом режиме?<br>Вообще, в ЗиК механизм такой. Изначально Справочник.ХХХБаза как раз почти всегда пуст и состав расчетной базы определяется по группам расчетов конфигуратора. Справочник с базой становится непуст, когда пользователь сделает ручную настройку расчетной базы.<br>Для вашего примера ход при работе стандартных алгоритмов такой:<br>Система смотрит в справочник ДополнительныеПроводкиБаза, если там ничего нет, то берутся расчеты, которые входят в ГруппаРасчетов.ОблагаетсяФССнаНСиПЗ. Поэтому, ваш алгоритм, реально должен быть таким:<br>ВидРНС_ПЗ=СоздатьОбъект("СписокЗначений");<br>СпрВРНС_ПЗ = СоздатьОбъект("Справочник.ДополнительныеПроводки");<br>СпрВРНС_ПЗ_база = СоздатьОбъект("Справочник.ДополнительныеПроводкиБаза");<br>Если СпрВРНС_ПЗ.НайтиПоКоду("ФСС_НС")=1 Тогда<br>СпрВРНС_ПЗ_база.ИспользоватьВладельца(СпрВРНС_ПЗ.ТекущийЭлемент());<br>Если СпрВРНС_ПЗ_база.ВыбратьЭлементы()=0 Тогда<br>Для i = 1 по ГраппаРасчетов.ОблагаетсяФССнаНСиПЗ.Количество() Цикл<br>ВидРНС_ПЗ.ДобавитьЗначение(ГраппаРасчетов.ОблагаетсяФССнаНСиПЗ.ПолучитьРасчет(i));<br>КонецЦикла;<br>Иначе<br>Пока СпрВРНС_ПЗ_база.ПолучитьЭлемент()=1 Цикл<br>ВидРНС_ПЗ.ДобавитьЗначение(СпрВРНС_ПЗ_база.Расчет);<br>КонецЦикла;<br>КонецЕсли;<br>КонецЕсли;"

poldarsa
читатель
офлайн
Дата регистрации: 08.02.2007
Сообщений: 604
Пост №3
 
10.06.2008 13:31

Спасибо. Да я его перезаполнил и все заработало.

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • МАРКИРОВКА
  • ЕГАИС
  • Учет, налогообложение, автоматизация

Мероприятия

17 ноября 2021 годаБизнес-форум 1С:ERP

1C:Лекторий: 28 октября 2021 года (четверг, начало в 10:00)Налоговый мониторинг: порядок перехода, преимущества для налогоплательщиков, поддержка в решениях 1С

1C:Лекторий: 2 ноября 2021 года (вторник, начало в 10:00, все желающие)Новые источники данных в 1С:Аналитике

Все мероприятия
Предложения партнеров
Обучение пользователей продуктов 1С