Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

Помогите новичку,запарка по ПУБ 7.7 как добавить код к наименованию в отчете

katr1
читатель
офлайн
Дата регистрации: 26.01.2009
Сообщений: 17
Пост №1
 
26.01.2009 08:50

Бухгалтер попросила в отчете ОСВ по счету, в счете мц.02 добавить код , как по счету мц.01, перерыла всю базу не могу найти в каком месте она это берет, по ОС отслеживает, а по материалам не может, а если написать новый отчет то как вытащить чтобы именно остатки по этому счету.

ValeraH
читатель
офлайн
Дата регистрации: 31.03.2004
Сообщений: 264
Пост №2
 
26.01.2009 10:38

"У бухгалтеров хотелки похожие, я в типовой 7.7 в отчете ОборотноСальдоваяВедомостьПоСчету делал вставку (не знаю, как это поможет в ПУБ, разве что идеологически) :
В процедуре ПоСубконто(Ит, Т, ФлВал)
перед началом цикла вставил строку:
ВидСубконто1=Счет.ВидСубконто(1);
а перед строкой
Т.ВывестиСекцию("Секция_2");
вставил:
//-----------------------------------------------
Если СокрЛП(ВидСубконто1)="Номенклатура" Тогда
ТекСубконто=Ит.Субконто();
Если СокрЛП(ТекСубконто.Вид())="Номенклатура" Тогда
ВидВыводаПредставленияСубконто=""""+ТекСубконто.Код+", "+Ит.ПредставлениеСубконто();
Иначе
ВидВыводаПредставленияСубконто=Ит.ПредставлениеСубконто();
КонецЕсли;
ИначеЕсли СокрЛП(ВидСубконто1)="Контрагенты" Тогда
ТекСубконто=Ит.Субконто();
Если СокрЛП(ТекСубконто.Вид())="Контрагенты" Тогда
ВидВыводаПредставленияСубконто=""""+ТекСубконто.ИНН+", "+Ит.ПредставлениеСубконто();
Иначе
ВидВыводаПредставленияСубконто=Ит.ПредставлениеСубконто();
КонецЕсли;
Иначе
ВидВыводаПредставленияСубконто=Ит.ПредставлениеСубконто();
КонецЕсли;
//-----------------------------------------------
И в печатной форме в 1 столбце Секция_2 теперь стоит ВидВыводаПредставленияСубконто.
Нашим хотелось Номенклатуру видеть с кодом, а Контрагентов с ИНН..."

katr1
читатель
офлайн
Дата регистрации: 26.01.2009
Сообщений: 17
Пост №3
 
26.01.2009 12:36

огромное спасибо,побольше бы таких умных и добрых программистов, вы меня спасли от острых зубов бухгалтеров.
Я заменила на свое что надо мне и все получилось, спасибо.

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • МАРКИРОВКА
  • ЕГАИС
  • Учет, налогообложение, автоматизация
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги