Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

Выгрузка док-та перемещение и загрузка в др. локальную базу как Приходная накладная. 1v7

Freid
читатель
офлайн
Дата регистрации: 31.01.2009
Сообщений: 5
Пост №1
 
31.01.2009 14:26

Есть в первой базе док-т приходная накладная, при проводке стоит флаг "выгружать", каки образом посмотреть куда выгружается (если флаг активирован) приходная накладная(есть ли вообще в конфигураторе данная функция?) . И каким образов выгрузить и загрузить его в др.форме документа, в аналогичную базу?

Alizar
читатель
офлайн
Дата регистрации: 23.08.2007
Сообщений: 311
Пост №2
 
31.01.2009 18:10

О каких конфигурациях, вообще, идет речь?

Freid
читатель
офлайн
Дата регистрации: 31.01.2009
Сообщений: 5
Пост №3
 
01.02.2009 01:01

Даны 2 базы (1с предприятие) с одинаковой конфигурацией, есть док-т приходная накладная, в его форме, стоит флаг, который когда активен, выгружает и загружает док-т во вторую базу, как сделать такойже флаг в др док-те? При попытки создать такойже флаг, индентификатор пишет что невозможно (я новичёк, знаю что названия уникальны) назвать данным именем, а 1м документе, индентификатор изменить вобще нельзя, вписано выгружать.
Где хотя бы посмотреть, какой алгоритм выполняет данный флаг, и какие ссылки исользует? ( в формуле стоит пустое значение)

Freid
читатель
офлайн
Дата регистрации: 31.01.2009
Сообщений: 5
Пост №4
 
01.02.2009 12:54

"С флагом, разобрался, поставил, а выгружатся документ всё по прежнему не хочет,
//!!!(синхронизация документов      
Если (модифицированность()=1) или (Проведен()=0) Тогда
надовыгружать = 1;
КонецЕсли;
//!!!)синхронизация документов
Копировал этот код из приходной, она выгружается, а перемещение всё также не хочет"

Alizar
читатель
офлайн
Дата регистрации: 23.08.2007
Сообщений: 311
Пост №5
 
01.02.2009 13:38

Вы меня извините за мою непонятливость, но из Ваших постов можно понять совсем немногое.

1. Речь идет о самописных конфах или типовых?
2. Если о самописных, то инфы крайне мало.
3. Как проходит обмен? Через xml-файл или через OLE?
4. Если конфы самописные, то правила обмена, соответственно тоже. Т.е. инфы, опять-таки мало.
И это далеко не все вопросы.

Alexandr VA
читатель
офлайн
Дата регистрации: 07.01.2007
Сообщений: 1666
Пост №6
 
01.02.2009 13:49


> И это далеко не все вопросы.

Так, скорее всего, для ответа на все вопросы в этом случае придется последовательно пересказать большую часть содержимого ЖКК по конфигурированию и языку. Все же форум - далеко не лучший способ ОБУЧЕНИЯ программированию...

Alizar
читатель
офлайн
Дата регистрации: 23.08.2007
Сообщений: 311
Пост №7
 
01.02.2009 13:58


> Так, скорее всего, для ответа на все вопросы в этом случае придется последовательно пересказать большую часть содержимого ЖКК по конфигурированию и языку. Все же форум - далеко не лучший способ ОБУЧЕНИЯ программированию...


+1 Согласен.

Freid
читатель
офлайн
Дата регистрации: 31.01.2009
Сообщений: 5
Пост №8
 
01.02.2009 14:05

Да, вы меня тоже извеняйте, ибо только начинающий.
Конфигурации самописные, правила обмена помоему также самописные, При проводке док-та Приходная накладная, при активированном флажке "выгружать", док-т сразу выгружается как .txt файл, и загружается во вторую базу.
Я так думаю за выгрузку отвечает моудль обработки.ВыгрузкаОб, но как его вобще возможно привязать к данному документу?

Alizar
читатель
офлайн
Дата регистрации: 23.08.2007
Сообщений: 311
Пост №9
 
01.02.2009 14:12

> Да, вы меня тоже извеняйте, ибо только начинающий.
> Конфигурации самописные, правила обмена помоему также самописные, При проводке док-та Приходная накладная, при активированном флажке "выгружать", док-т сразу выгружается как .txt файл, и загружается во вторую базу.

Что значит "сразу"? При проведении? Значит надо анализировать процедуру "Обработка проведения". Или в доке есть спец. кнопка для выгрузки? Значит, смотрим процедуру модуля формы дока для этой кнопки.

> Я так думаю за выгрузку отвечает моудль обработки.ВыгрузкаОб, но как его вобще возможно привязать к данному документу?

Если док выгружается при проведении, значит обработка запускается при проведении из указанной мной процедуры. Вообщем, возможны варианты.

Freid
читатель
офлайн
Дата регистрации: 31.01.2009
Сообщений: 5
Пост №10
 
06.02.2009 21:32

"С выгрузкой я разобрался. Но вот возникла ещё одна маленькая проблема.
Мне нужно было чтобы документ "перемещение" выгружался в другую базу, с этой задачей я справился. Но ещё один маленький ньюанс, загружатся уже должен не как документ "Перемещение" а как "ПриходнаяНакладная"

Попробую объйснить
Есть обработка выгрузки, она выгружает .txt файл в таком виде

"ФорматФайла=1","РазделительСтрок=<разделитель строк>","ИБ1","ИБ2"
"Справочник 1","Элемент.Фирмы
"Справочник 2",Элемент.Пользователи"
"Справочник 3",Элемент.МестаХранения
"Справочник 4", --и т.д ещё несколько справочников
далее после справочников следует строка :
"Документ 1","Документ.Перемещение","Проведен","?НомерДок()0000000003","ДатаДок()05.02.2009","ВремяДок()12:00:00","Фирма(#)Справочник 1" .. -- и т.д.

Меня интересует как раз эта строка "Документ". Если в ней изменить значение, "ДокументПеремещение" на "Документ.ПриходнаяНакладная" то он будет выгружать во вторую базу именно как приходная.

В форме модуля обработки "Выгрузка" есть цикл записи
>>
ТекстВыгрузкиДанныхДоп.ВставитьСтроку(2, """");
// выгрузка документов
Для Номер=1 по СписДокументы.РазмерСписка() Цикл
Если СписДокументы.Пометка(Номер)=0 Тогда Продолжить; КонецЕсли;
Идентификатор=СписДокументы.ПолучитьЗначение(Номер);

Стр=РазделительСтрок+"// Документ."+Идентификатор+РазделительСтрок;
ТекстВыгрузкиДанных.ЗаписатьСтроку(Стр);

// строка замещения
Стр=""""",""""Документ."+Идентификатор+""""",""""ЗамещеныВсе"""","+
"""""?ДатаНач()"+Выгрузить(ДатаНач)+""""",""""?ДатаКон()"+Выгрузить(ДатаКон)+"""";
ТекстВыгрузкиДанныхДоп.ВставитьСтроку(2+Номер, Стр);

Объект=СоздатьОбъект("Документ."+Идентификатор);
Объект.ВыбратьДокументы(ДатаНач, ДатаКон);
Пока 1=Объект.ПолучитьДокумент() Цикл
ВыгрузитьОбъект(Объект.ТекущийДокумент(), "Документ");

// состояние("Выгружен объект: Документ."+Идентификатор+" "+Объект);
//Состояние("Записано "+ТекстВыгрузкиДанных.КоличествоСтрок()+" строк");
КонецЦикла;
КонецЦикла;
>>

Отвечает за создание строки
Стр=РазделительСтрок+"// Документ."+Идентификатор+РазделительСтрок;
ТекстВыгрузкиДанных.ЗаписатьСтроку(Стр);
А можно ли зделать так. Если документ перемещение, то в данной строке "Документ" он записался не как текущийдок а как Документ.ПриходнаяНакладная ?
Или это уже нужно править обработку Загрузки?"

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги