Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

Как в печатной форме вывести в цене 4 - ре знака после запятой а в сумме оставить 2

lerik1
читатель
офлайн
Дата регистрации: 30.03.2009
Сообщений: 11
Пост №1
 
29.04.2009 14:19

"Добрый день!
Конфигурация 05.02.2009 Бухгалтерия 7.7 ПРОФ для Украины ред.2.5 7.70.272
Возникла необходимость добавить в печатную форму налоговой накладной вывод 4-рёх знаков после запятой в цене и оставить два знака в сумме.

В модуле налоговой накладной есть слдующая функция

Функция СуммаДляПечати(Сумма)
Если Валюта = Гривня Тогда
СуммаПеч = СокрЛ(Формат(Сумма,"Ч17.2."))
Иначе
СуммаПеч = СокрЛ(Формат(глПересчет(Сумма,Валюта,Гривня,Курс,ДатаДок),"Ч17.2."))
КонецЕсли;
Возврат СуммаПеч
КонецФункции

При коректировки "Ч17.2." на "Ч17.4." изменяется кол. знаков как в сумме та и вцене на 4, а мне необходимо оставить 2 знака после запятой в сумме. Подскажите полуйста как мне решить эту проблему.

"

Thorvardr
читатель
офлайн
Дата регистрации: 25.02.2005
Сообщений: 3077
Пост №2
 
29.04.2009 14:25

Самое простое сделать еще одну функцию:
Функция ЦенаДляПечати(Сумма)
Возврат СокрЛ(Формат(Сумма,"Ч17.4."))
КонецФункции

и в макете печатной формы в ячейке где цена выводится заменить СуммаДляПечати на ЦенаДляПечати

lerik1
читатель
офлайн
Дата регистрации: 30.03.2009
Сообщений: 11
Пост №3
 
29.04.2009 14:25

Причина такой необходимости возникла из-за разницы сумм

Усього по розділу I и Усього по розділах I + II ± IV разница возникает буквально на копейки.

lerik1
читатель
офлайн
Дата регистрации: 30.03.2009
Сообщений: 11
Пост №4
 
29.04.2009 14:36

Дело в том что строка ячейки имеет следующие данные

[ТаблТМЦ.ЦенаБезНДС*ТаблТМЦ.Коэффициент #N17.2.,]

lerik1
читатель
офлайн
Дата регистрации: 30.03.2009
Сообщений: 11
Пост №5
 
29.04.2009 14:54

Помогите разобратся, я в 1с начинающий

BelikovS
читатель
офлайн
Дата регистрации: 05.03.2007
Сообщений: 1701
Пост №6
 
29.04.2009 15:32

Ну и напишите вместо 17.2 17.4

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги