Новости для бухгалтера, бухучет, налогообложение, отчетность, ФСБУ, прослеживаемость и маркировка, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

Помогите пожалуйста с обработкой!

Doz74
читатель
офлайн
Дата регистрации: 03.05.2009
Сообщений: 1
Пост №1
 
03.05.2009 14:57

"Что здесь не так? Пишет: "Число фильтров субконто превысило допустимое значение!". Общий принцип: Выборка итогов по выбранным счетам и разбивкой по субконто. При выборе 1-го субконто, все работает, а нужно с 3. Заранее спасибо!<br><br>Для А = 1 По 3 Цикл <br>Ит=СоздатьОбъект("БухгалтерскиеИтоги");<br>Ит.ИспользоватьСубконто(Счет.ВидСубконто(А), , 1);<br>Ит.ВыполнитьЗапрос(ДатаНачала,ДатаКонца);<br>Ит.ВыбратьСубконто(А);<br>Пока Ит.ПолучитьСубконто(А) = 1 Цикл <br>Если ИтогиНеРавныНулю(Ит, А) = 0 Тогда<br>Продолжить;<br>КонецЕсли; <br>Таб.ВывестиСекцию("Строка_1|Начало");<br>Итого=0; <br>ТЗ2.ВыбратьСтроки();<br>Пока ТЗ2.ПолучитьСтроку() = 1 Цикл <br>Если ТЗ2.Помет = 1 Тогда <br>О=ТЗ2.Наименование;<br>ОС=СоздатьОбъект("Справочник.Подразделения");<br>ОС.НайтиПоНаименованию(О,1);<br>Если ОС.Выбран()>0 Тогда<br>Вывод=0;<br>Если Строка(Ос.ТекущийЭлемент())=Строка(О) Тогда<br>Ит=СоздатьОбъект("БухгалтерскиеИтоги");<br>Ит.ИспользоватьСубконто("Подразделения", ОС.ТекущийЭлемент(),,);<br>Ит.ВыполнитьЗапрос(ДатаНачала,ДатаКонца,СчетПоКоду("50.02"),СЧетПоКоду(Счет.Код),,2,,);<br>КонецЕсли; <br>Если ВидДок.ПолучитьЗначение(ВидДок.ТекущаяСтрока())="Приход" Тогда<br>Таб.ПрисоединитьСекцию("Строка_"+А+"|Колонка_1");<br>Итого = Итого + Ит.ДО()<br>Иначе<br>Таб.ПрисоединитьСекцию("Строка_"+А+"|Колонка_2");<br>Итого = Итого + Ит.КО();<br>КонецЕсли;<br>КонецЕсли; <br>КонецЕсли;<br>КонецЦикла;<br>Таб.ПрисоединитьСекцию("Строка_"+А+"|Итого");<br>КонецЦикла;<br>КонецЦикла;"

Вьюн
читатель
офлайн
Дата регистрации: 14.01.2007
Сообщений: 657
Пост №2
 
03.05.2009 22:31

Ит=ВыполнитьЗапрос... используется 2 раза с одним и тем же именем переменной (Ит), хотя это разные запросы. Поэтому Пока Ит.ПолучитьСубконто(А) = 1 Цикл при А > 1 ругается, т.к. уже работает Ит.ИспользоватьСубконто("Подразделения", ОС.ТекущийЭлемент(),,), где всего 1 субконто, и Ит.ПолучитьСубконто(2) не имеет смысла.<br>

zak555 (398843952)
читатель
офлайн
Дата регистрации: 27.03.2008
Сообщений: 4656
Пост №3
 
04.05.2009 11:27

запрос в цикле

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • МАРКИРОВКА
  • ЕГАИС
  • Учет, налогообложение, автоматизация
Предложения партнеров
Обучение пользователей продуктов 1С