Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

Помогите пожалуйста с обработкой!

Doz74
читатель
офлайн
Дата регистрации: 03.05.2009
Сообщений: 1
Пост №1
 
03.05.2009 14:57

"Что здесь не так? Пишет: "Число фильтров субконто превысило допустимое значение!". Общий принцип: Выборка итогов по выбранным счетам и разбивкой по субконто. При выборе 1-го субконто, все работает, а нужно с 3. Заранее спасибо!

Для А = 1 По 3 Цикл
Ит=СоздатьОбъект("БухгалтерскиеИтоги");
Ит.ИспользоватьСубконто(Счет.ВидСубконто(А), , 1);
Ит.ВыполнитьЗапрос(ДатаНачала,ДатаКонца);
Ит.ВыбратьСубконто(А);
Пока Ит.ПолучитьСубконто(А) = 1 Цикл
Если ИтогиНеРавныНулю(Ит, А) = 0 Тогда
Продолжить;
КонецЕсли;
Таб.ВывестиСекцию("Строка_1|Начало");
Итого=0;
ТЗ2.ВыбратьСтроки();
Пока ТЗ2.ПолучитьСтроку() = 1 Цикл
Если ТЗ2.Помет = 1 Тогда
О=ТЗ2.Наименование;
ОС=СоздатьОбъект("Справочник.Подразделения");
ОС.НайтиПоНаименованию(О,1);
Если ОС.Выбран()>0 Тогда
Вывод=0;
Если Строка(Ос.ТекущийЭлемент())=Строка(О) Тогда
Ит=СоздатьОбъект("БухгалтерскиеИтоги");
Ит.ИспользоватьСубконто("Подразделения", ОС.ТекущийЭлемент(),,);
Ит.ВыполнитьЗапрос(ДатаНачала,ДатаКонца,СчетПоКоду("50.02"),СЧетПоКоду(Счет.Код),,2,,);
КонецЕсли;
Если ВидДок.ПолучитьЗначение(ВидДок.ТекущаяСтрока())="Приход" Тогда
Таб.ПрисоединитьСекцию("Строка_"+А+"|Колонка_1");
Итого = Итого + Ит.ДО()
Иначе
Таб.ПрисоединитьСекцию("Строка_"+А+"|Колонка_2");
Итого = Итого + Ит.КО();
КонецЕсли;
КонецЕсли;
КонецЕсли;
КонецЦикла;
Таб.ПрисоединитьСекцию("Строка_"+А+"|Итого");
КонецЦикла;
КонецЦикла;"

Вьюн
читатель
офлайн
Дата регистрации: 14.01.2007
Сообщений: 655
Пост №2
 
03.05.2009 22:31

Ит=ВыполнитьЗапрос... используется 2 раза с одним и тем же именем переменной (Ит), хотя это разные запросы. Поэтому Пока Ит.ПолучитьСубконто(А) = 1 Цикл при А > 1 ругается, т.к. уже работает Ит.ИспользоватьСубконто("Подразделения", ОС.ТекущийЭлемент(),,), где всего 1 субконто, и Ит.ПолучитьСубконто(2) не имеет смысла.

zak555 (398843952)
читатель
офлайн
Дата регистрации: 27.03.2008
Сообщений: 4656
Пост №3
 
04.05.2009 11:27

запрос в цикле

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги