Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

Помогите плиз!

NCH Robert
читатель
офлайн
Дата регистрации: 12.10.2009
Сообщений: 44
Пост №1
 
29.01.2010 16:01

1С:Предприятие 8.1 (8.1.15.14)
"Управление торговлей", редакция 10.3 (10.3.8.9)

В общем модуле ЗаказПокупателя в Функция ПечатьСчетаЗаказаКорректировки(Тип) хочу поставить условие: если данные берутся из табличной части Товары, то выполнять!
Помогите плиз! Как прописать условие?

BelikovS
читатель
офлайн
Дата регистрации: 05.03.2007
Сообщений: 1701
Пост №2
 
01.02.2010 15:51

"Я использую функцию, для определения табличной части:
Функция ПолучитьИмяТабличнойЧасти (Док, СтрокаТЧ) Экспорт
МД = Док.Метаданные();
Для Каждого ТЧ Из МД.ТабличныеЧасти Цикл
Если Док[ТЧ.Имя].Индекс(СтрокаТЧ) >= 0 Тогда
Возврат ТЧ.Имя;
КонецЕсли;
КонецЦикла;
Возврат Неопределено;
КонецФункции"

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги