Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

Бюджет 7.7 релиз 635 Новое поле в документе- открывает не тот справочник

Svetlana_E
читатель
офлайн
Дата регистрации: 30.08.2006
Сообщений: 2631
Пост №1
 
01.03.2010 06:19

Проблема возникла после обновления с 633 на 635.
Создаю новый документ. Поле "членКомиссии"- тип- Справочник.Сотрудники. Вставляю на форму, проверяю: тип-"Справочник.Сотрудники", серенький, недоступный для редактирования. Все нормально. Запускаю. При выборе упорно открывается справочник Юрлица. Пробовала вставлять такое же поле в уже существующих документах - тот же результат. Вместо Сотрудников- Юрлица. Восстанавливаю копию до обновления - все в порядке. Уже не знаю, где копать. Тестирование запускала, выгрузку-загрузку делала...

ЗаЕц
читатель
офлайн
Дата регистрации: 09.02.2009
Сообщений: 560
Пост №2
 
01.03.2010 06:59

"это не из-за релиза...632, 633, 635 везде открывает спр. юр.лица...может где-то еще какие-то настройки есть
сорудники подчинен юр.лицам(=организации)

вобщем вроде так должно работать
на поле поставила элемент Сотр (Справочник.Сотрудники)
в модуле формы искала процедуру: ПриНачалеВыбораЗначения(ЭлемД, ФлОб)
и вставляла кусочек кода:
Если ЭлемД = "Сотр" Тогда
ФлОб=0;
Если ПустоеЗначение(ВыбраннаяФирма) = 1 Тогда
Предупреждение("Сначала выберите учреждение");
Возврат;
КонецЕсли;
Параметр = ВыбраннаяФирма;
ОткрытьФорму("Справочник.Сотрудники",Параметр);
"

Svetlana_E
читатель
офлайн
Дата регистрации: 30.08.2006
Сообщений: 2631
Пост №3
 
01.03.2010 12:17

"Так в том-то и дело, что фирма выбрана! Понятно, что справочник подчинен, но до обновления все выбиралось правильно. Берем документ "Списание ОС с забаланса". Там комиссия 4 человека ( председатель+3).У нас требовали чтобы обязательно было 4 и это хранилось в базе. Добавила 4-ого члена комиссии. 2 года это работало, а после обновления все поля комиссии заполняются нормально - сразу открывается справочник "Сотрудники", а для этого добавленного поля вдруг стал открываться "Юр.лица", и только потом "Сотрудники"... Самое интересное, что добавляла это поле во все документы списания во всех продолжает работать нормально...

И подобный кусочек в коде процедуры есть...

ИначеЕсли (ЭлемДиалога = "Председатель") или (ЭлемДиалога = "ЧленКомиссии1")
или (ЭлемДиалога = "ЧленКомиссии2") или (ЭлемДиалога = "ЧленКомиссии3")или (ЭлемДиалога = "ЧленКомиссии4") Тогда
Флаг=0;
Параметр = ВыбраннаяФирма;
ОткрытьФорму("Справочник.Сотрудники",Параметр);
КонецЕсли;
КонецПроцедуры
"

ЗаЕц
читатель
офлайн
Дата регистрации: 09.02.2009
Сообщений: 560
Пост №4
 
01.03.2010 12:31

попробуйте базу просто скопировать и посмотреть на копии...бывает глюк, который тестированием не берется...

Svetlana_E
читатель
офлайн
Дата регистрации: 30.08.2006
Сообщений: 2631
Пост №5
 
01.03.2010 12:37

Я и так эскпериментирую дома на копии... Главное, подозреваю, что это какая-то мелочь, которую я пока не нашла...

Svetlana_E
читатель
офлайн
Дата регистрации: 30.08.2006
Сообщений: 2631
Пост №6
 
01.03.2010 12:45

Не знаю в чем было дело, но! Удалила всех пользователей, завела заново - все заработало! Что за настройки испортились - непонятно...

zak555 (398843952)
читатель
офлайн
Дата регистрации: 27.03.2008
Сообщений: 4656
Пост №7
 
01.03.2010 13:05

Svetlana_E работает на таганке ?

Svetlana_E
читатель
офлайн
Дата регистрации: 30.08.2006
Сообщений: 2631
Пост №8
 
01.03.2010 13:16

Нет, в Сибири :)))

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги