Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

Бухгалтерия 8.1 Как в процедуре организовать обход строк табличной части документа

serg208
читатель
офлайн
Дата регистрации: 30.04.2009
Сообщений: 22
Пост №1
 
06.03.2010 12:37

Нужно пересчитать данные после ввода цифр в табичной части документа. Общая сумма к распределению делется на общее количество и умножается на количество в строке.

ПСВ
читатель
офлайн
Дата регистрации: 06.04.2009
Сообщений: 379
Пост №2
 
06.03.2010 22:43

"
Для каждого СтрокаТЧ ИЗ ТабличнаяЧасть Цикл

КонецЦикла;"

serg208
читатель
офлайн
Дата регистрации: 30.04.2009
Сообщений: 22
Пост №3
 
07.03.2010 06:28

"Это все понятно делаю так
Процедура ОсновныеДействияФормыОбновить(Кнопка)

Для Каждого ТекСтрокаТабличнаяЧасть1 Из ТабличнаяЧасть1 Цикл
СтрокаТабличнойЧасти = ЭлементыФормы.ТабличнаяЧасть1.ТекущиеДанные;
СтрокаТабличнойЧасти.Сумма = СуммаСписания/ТабличнаяЧасть1.Итог("Выпуск")*СтрокаТабличнойЧасти.Выпуск;
КонецЦикла;
КонецПроцедуры

Процедура работает с кнопки. Но Расчет идет только по строке. Нет обхода"

Денис (САМАРА)
активный пользователь
офлайн
Дата регистрации: 09.04.2008
Сообщений: 8345
Пост №4
 
07.03.2010 10:51

> ЭлементыФормы.ТабличнаяЧасть1.ТекущиеДанные

Что это за фигня?

Wee
читатель
офлайн
Дата регистрации: 24.11.2007
Сообщений: 464
Пост №5
 
07.03.2010 11:07

"У Вас в цикле ТекущиеДанные не меняются.
Делайте обход не через ЭлементыФормы!

Для Каждого ТекСтрокаТабличнаяЧасть1 Из ТабличнаяЧасть1 Цикл
ТекСтрокаТабличнаяЧасть1.Сумма = СуммаСписания/ТабличнаяЧасть1.Итог("Выпуск")*ТекСтрокаТабличнаяЧасть1.Выпуск;
КонецЦикла;
КонецПроцедуры

И вобще названия сделайте нормальные, а то убого как-то :)"

zak555 (398843952)
читатель
офлайн
Дата регистрации: 27.03.2008
Сообщений: 4656
Пост №6
 
07.03.2010 11:07

> > ЭлементыФормы.ТабличнаяЧасть1.ТекущиеДанные
>
> Что это за фигня?

самопал ?

serg208
читатель
офлайн
Дата регистрации: 30.04.2009
Сообщений: 22
Пост №7
 
07.03.2010 17:53

Спасибо. По Названиям - Просто не стал менять.

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги