Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

Выгрузка номенклатуры за период

cacti
читатель
офлайн
Дата регистрации: 19.03.2010
Сообщений: 1
Пост №1
 
19.03.2010 02:38

"Помогите пожалуйста..опыт в программирование небольшой и я уже просто устала, не знаю что делать. имеется форма где указаны датнач и даткон. Нужно сделать чтобы выгружались все товары справочника номенклатура которые были которые входят в этот период.

Процедура ВыгрузитьРеквизитыТовара(ОбъектXML, Товар, Ид = Неопределено)

Если НЕ ЗначениеЗаполнено(Ид) Тогда

ИдТовара = СформироватьИдентификатовТовара(Товар.НоменклатураСсылка, Товар.ХарактеристикаСсылка);
ЗаписатьТекстовойУзел(ОбъектXML, "Ид", ИдТовара);
Иначе
ЗаписатьТекстовойУзел(ОбъектXML, "Ид", Ид);
КонецЕсли;
ЗаписатьТекстовойУзел(ОбъектXML, "ШтрихКод",             Товар.ШтрихКод);
ЗаписатьТекстовойУзел(ОбъектXML, "Артикул", Товар.Артикул);
ЗаписатьТекстовойУзел(ОбъектXML, "ЦенаЗаЕдиницу", Товар.Цена);
ЗаписатьТекстовойУзел(ОбъектXML, "Дата",        Товар.Дата);
ЗаписатьТекстовойУзел(ОбъектXML, "ЕдиницаИзмерения",       Товар.ЕдиницаИзмерения);
ЗаписатьТекстовойУзел(ОбъектXML, "ТипЦены",       Товар.ЦеноваяГруппа);
ЗаписатьТекстовойУзел(ОбъектXML, "Количество", Товар.Количество);
ЗаписатьТекстовойУзел(ОбъектXML, "Валюта", Товар.Валюта);
ЗаписатьТекстовойУзел(ОбъектXML, "СтранаПроисхождения", Товар.СтранаПроисхождения);
ЗаписатьТекстовойУзел(ОбъектXML, "Группа", Товар.Родитель);


КонецПроцедуры

Процедура ВыгрузитьКаталог(ОбъектXML, ИмяКаталога, ИдКаталога, ВладелецКаталога, Товары)

ОбъектXML.ЗаписатьНачалоЭлемента("Каталог");

ЗаписатьТекстовойУзел(ОбъектXML, "Ид", Строка(ИдКаталога));
Если НЕ ЗначениеЗаполнено(ИмяКаталога) Тогда
ИмяКаталога = "Каталог товаров от "+ Строка(ТекущаяДата());
КонецЕсли;
ЗаписатьТекстовойУзел(ОбъектXML, "Наименование", ИмяКаталога);
ВыгрузитьКонтрагента(ОбъектXML, "Владелец", ВладелецКаталога);

КоличествоВыгруженныхСтрок = 0;
ОбъектXML.ЗаписатьНачалоЭлемента("Товары");
Выборка = Товары.Выбрать();
Пока Выборка.Следующий() Цикл
Если НЕ Выборка.ЭтоГруппа Тогда
ОбъектXML.ЗаписатьНачалоЭлемента("Товар");
ВыгрузитьРеквизитыТовара(ОбъектXML, Выборка);
ОбъектXML.ЗаписатьКонецЭлемента();
КоличествоВыгруженныхСтрок = КоличествоВыгруженныхСтрок + 1;
КонецЕсли;
КонецЦикла;
ОбъектXML.ЗаписатьКонецЭлемента();

ОбъектXML.ЗаписатьКонецЭлемента();

Сообщить(" Количество выгруженных строк каталога товаров: " + КоличествоВыгруженныхСтрок);

КонецПроцедуры


"

ПСВ
читатель
офлайн
Дата регистрации: 06.04.2009
Сообщений: 379
Пост №2
 
19.03.2010 10:01


судя по коду выгружается Справочник Номенклатура (Товары),
откуда может быть у справочника период?
его можно определить только косвенно
например по дате поступления первой партии данного товара и выбирать из регистра накопления "Партии"

если вы при каждом добавлении номенклатуры в справочник как то регитрируете дату его введения
в учетную систему

то метод выбрать имеет 3 параметр:
Выбрать(<Родитель>, <Владелец>, <Отбор>, <Порядок>)

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги