Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

Комплексная 495 Ошибка глобального модуля 43250

Svetlana Nikol
читатель
офлайн
Дата регистрации: 24.02.2010
Сообщений: 58
Пост №1
 
23.03.2010 15:40

Создается документ "Расходы на оплату труда" и "Начисление налогов" в налоговом учете программа выдает ошибку:Дата Рождения = Физ.лицо. Физ. лицо. Дата рождения.
Глобальный модуль 43250
Поле агрегатного объекта не обнаружено. (физ. лицо)
В налоговом учете расходы по Зар.плате не формируются.

zak555 (398843952)
читатель
офлайн
Дата регистрации: 27.03.2008
Сообщений: 4656
Пост №2
 
23.03.2010 17:04

"в 496 это не исправлено !!!


решение заменить кусок :

Функция глНомерШкалыСтраховыхВзносовПФР(ФизЛицо, ДатаОпределения = '31.12.2004') Экспорт

ДатаРождения = ФизЛицо.ФизЛицо.ДатаРождения;
Если ПустоеЗначение(ДатаРождения) = 1 Тогда
Возврат -1
ИначеЕсли ДатаРождения >= РабочаяДата() Тогда
Возврат -2
Иначе
ГодРождения = ДатаГод(ДатаРождения)
КонецЕсли;

Пол = ВРег(Строка(ФизЛицо.ФизЛицо.Пол));
Если ПустоеЗначение(Пол) = 1 Тогда
Возврат -1
КонецЕсли;

Если Найти(Пол,"М") > 0 Тогда // мужчины
глСообщениеТрассировки(глСообщенияТрассировки, "Физическое лицо _П01 является мужчиной "+ГодРождения+" года рождения", 0, 0, ФизЛицо);
Если ГодРождения < 1953 Тогда
       Возврат 1
ИначеЕсли ГодРождения < 1967 Тогда
Возврат 2
Иначе
Возврат 3
КонецЕсли;
ИначеЕсли Найти(Пол,"Ж") > 0 Тогда // женщины
глСообщениеТрассировки(глСообщенияТрассировки, "Физическое лицо _П01 является женщиной "+ГодРождения+" года рождения", 0, 0, ФизЛицо);
Если ГодРождения < 1957 Тогда
       Возврат 1
ИначеЕсли ГодРождения < 1967 Тогда
Возврат 2
Иначе
Возврат 3
КонецЕсли;
КонецЕсли;

Возврат -1

КонецФункции // глНомерШкалыСтраховыхВзносовПФР()


на следующий кусок :

Функция глНомерШкалыСтраховыхВзносовПФР(ФизЛицо, ДатаОпределения = '31.12.2004') Экспорт

ДатаРождения = ФизЛицо.ДатаРождения;
Если ПустоеЗначение(ДатаРождения) = 1 Тогда
Возврат -1
ИначеЕсли ДатаРождения >= РабочаяДата() Тогда
Возврат -2
Иначе
ГодРождения = ДатаГод(ДатаРождения)
КонецЕсли;

Пол = ВРег(Строка(ФизЛицо.Пол));
Если ПустоеЗначение(Пол) = 1 Тогда
Возврат -1
КонецЕсли;

Если Найти(Пол,"М") > 0 Тогда // мужчины
глСообщениеТрассировки(глСообщенияТрассировки, "Физическое лицо _П01 является мужчиной "+ГодРождения+" года рождения", 0, 0, ФизЛицо);
Если ГодРождения < 1953 Тогда
       Возврат 1
ИначеЕсли ГодРождения < 1967 Тогда
Возврат 2
Иначе
Возврат 3
КонецЕсли;
ИначеЕсли Найти(Пол,"Ж") > 0 Тогда // женщины
глСообщениеТрассировки(глСообщенияТрассировки, "Физическое лицо _П01 является женщиной "+ГодРождения+" года рождения", 0, 0, ФизЛицо);
Если ГодРождения < 1957 Тогда
       Возврат 1
ИначеЕсли ГодРождения < 1967 Тогда
Возврат 2
Иначе
Возврат 3
КонецЕсли;
КонецЕсли;

Возврат -1

КонецФункции // глНомерШкалыСтраховыхВзносовПФР()
"

Svetlana Nikol
читатель
офлайн
Дата регистрации: 24.02.2010
Сообщений: 58
Пост №3
 
23.03.2010 17:26

ок, завтра сообщу о результате

zak555 (398843952)
читатель
офлайн
Дата регистрации: 27.03.2008
Сообщений: 4656
Пост №4
 
23.03.2010 17:41

> ок, завтра сообщу о результате

т.е. вхождение в данном куске

заменить
ФизЛицо.ФизЛицо.

на
ФизЛицо.

Svetlana Nikol
читатель
офлайн
Дата регистрации: 24.02.2010
Сообщений: 58
Пост №5
 
24.03.2010 14:03

После изменений в глобальном модуле - ошибка осталась, начисления в налоговом учете не произодятся. Выдает по прежнему все тоже самое.

zak555 (398843952)
читатель
офлайн
Дата регистрации: 27.03.2008
Сообщений: 4656
Пост №6
 
24.03.2010 14:14

> После изменений в глобальном модуле - ошибка осталась, начисления в налоговом учете не произодятся. Выдает по прежнему все тоже самое.

не может быть : код и ошибку покажи

Svetlana Nikol
читатель
офлайн
Дата регистрации: 24.02.2010
Сообщений: 58
Пост №7
 
24.03.2010 14:27

"ДатаРождения = ФизЛицо.ДатаРождения;
{Глобальный модуль (43250)}; Поле агрегатного объекта не обнаружено (ДатаРождения)"

zak555 (398843952)
читатель
офлайн
Дата регистрации: 27.03.2008
Сообщений: 4656
Пост №8
 
24.03.2010 14:39

посмотри отладчиком - ТипЗначенияСтр(ФизЛицо)

zak555 (398843952)
читатель
офлайн
Дата регистрации: 27.03.2008
Сообщений: 4656
Пост №9
 
24.03.2010 14:52

нет, верни назад всё, как было !!!

Svetlana Nikol
читатель
офлайн
Дата регистрации: 24.02.2010
Сообщений: 58
Пост №10
 
24.03.2010 14:55

не понятно что вернуть: в первоначальный вид? до исправлений в ГМ?

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • МАРКИРОВКА
  • ЕГАИС
  • Учет, налогообложение, автоматизация
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги