Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

Комплексная 495 Ошибка глобального модуля 43250

Svetlana Nikol
читатель
офлайн
Дата регистрации: 24.02.2010
Сообщений: 58
Пост №1
 
23.03.2010 15:40

Создается документ "Расходы на оплату труда" и "Начисление налогов" в налоговом учете программа выдает ошибку:Дата Рождения = Физ.лицо. Физ. лицо. Дата рождения.<br>Глобальный модуль 43250<br>Поле агрегатного объекта не обнаружено. (физ. лицо)<br>В налоговом учете расходы по Зар.плате не формируются.

zak555 (398843952)
читатель
офлайн
Дата регистрации: 27.03.2008
Сообщений: 4656
Пост №2
 
23.03.2010 17:04

"в 496 это не исправлено !!!<br><br><br>решение заменить кусок :<br><br>Функция глНомерШкалыСтраховыхВзносовПФР(ФизЛицо, ДатаОпределения = '31.12.2004') Экспорт<br> <br> ДатаРождения = ФизЛицо.ФизЛицо.ДатаРождения;<br> Если ПустоеЗначение(ДатаРождения) = 1 Тогда<br> Возврат -1<br> ИначеЕсли ДатаРождения >= РабочаяДата() Тогда<br> Возврат -2<br> Иначе<br> ГодРождения = ДатаГод(ДатаРождения)<br> КонецЕсли;<br> <br> Пол = ВРег(Строка(ФизЛицо.ФизЛицо.Пол));<br> Если ПустоеЗначение(Пол) = 1 Тогда<br> Возврат -1<br> КонецЕсли;<br> <br> Если Найти(Пол,"М") > 0 Тогда // мужчины<br> глСообщениеТрассировки(глСообщенияТрассировки, "Физическое лицо _П01 является мужчиной "+ГодРождения+" года рождения", 0, 0, ФизЛицо);<br> Если ГодРождения < 1953 Тогда<br>        Возврат 1<br> ИначеЕсли ГодРождения < 1967 Тогда<br> Возврат 2<br> Иначе<br> Возврат 3<br> КонецЕсли;<br> ИначеЕсли Найти(Пол,"Ж") > 0 Тогда // женщины<br> глСообщениеТрассировки(глСообщенияТрассировки, "Физическое лицо _П01 является женщиной "+ГодРождения+" года рождения", 0, 0, ФизЛицо);<br> Если ГодРождения < 1957 Тогда<br>        Возврат 1<br> ИначеЕсли ГодРождения < 1967 Тогда<br> Возврат 2<br> Иначе<br> Возврат 3<br> КонецЕсли;<br> КонецЕсли;<br> <br> Возврат -1<br> <br>КонецФункции // глНомерШкалыСтраховыхВзносовПФР()<br><br><br>на следующий кусок :<br><br>Функция глНомерШкалыСтраховыхВзносовПФР(ФизЛицо, ДатаОпределения = '31.12.2004') Экспорт<br> <br> ДатаРождения = ФизЛицо.ДатаРождения;<br> Если ПустоеЗначение(ДатаРождения) = 1 Тогда<br> Возврат -1<br> ИначеЕсли ДатаРождения >= РабочаяДата() Тогда<br> Возврат -2<br> Иначе<br> ГодРождения = ДатаГод(ДатаРождения)<br> КонецЕсли;<br> <br> Пол = ВРег(Строка(ФизЛицо.Пол));<br> Если ПустоеЗначение(Пол) = 1 Тогда<br> Возврат -1<br> КонецЕсли;<br> <br> Если Найти(Пол,"М") > 0 Тогда // мужчины<br> глСообщениеТрассировки(глСообщенияТрассировки, "Физическое лицо _П01 является мужчиной "+ГодРождения+" года рождения", 0, 0, ФизЛицо);<br> Если ГодРождения < 1953 Тогда<br>        Возврат 1<br> ИначеЕсли ГодРождения < 1967 Тогда<br> Возврат 2<br> Иначе<br> Возврат 3<br> КонецЕсли;<br> ИначеЕсли Найти(Пол,"Ж") > 0 Тогда // женщины<br> глСообщениеТрассировки(глСообщенияТрассировки, "Физическое лицо _П01 является женщиной "+ГодРождения+" года рождения", 0, 0, ФизЛицо);<br> Если ГодРождения < 1957 Тогда<br>        Возврат 1<br> ИначеЕсли ГодРождения < 1967 Тогда<br> Возврат 2<br> Иначе<br> Возврат 3<br> КонецЕсли;<br> КонецЕсли;<br> <br> Возврат -1<br> <br>КонецФункции // глНомерШкалыСтраховыхВзносовПФР()<br>"

Svetlana Nikol
читатель
офлайн
Дата регистрации: 24.02.2010
Сообщений: 58
Пост №3
 
23.03.2010 17:26

ок, завтра сообщу о результате

zak555 (398843952)
читатель
офлайн
Дата регистрации: 27.03.2008
Сообщений: 4656
Пост №4
 
23.03.2010 17:41

> ок, завтра сообщу о результате<br><br>т.е. вхождение в данном куске<br><br>заменить<br>ФизЛицо.ФизЛицо.<br><br>на<br>ФизЛицо.

Svetlana Nikol
читатель
офлайн
Дата регистрации: 24.02.2010
Сообщений: 58
Пост №5
 
24.03.2010 14:03

После изменений в глобальном модуле - ошибка осталась, начисления в налоговом учете не произодятся. Выдает по прежнему все тоже самое.

zak555 (398843952)
читатель
офлайн
Дата регистрации: 27.03.2008
Сообщений: 4656
Пост №6
 
24.03.2010 14:14

> После изменений в глобальном модуле - ошибка осталась, начисления в налоговом учете не произодятся. Выдает по прежнему все тоже самое. <br><br>не может быть : код и ошибку покажи

Svetlana Nikol
читатель
офлайн
Дата регистрации: 24.02.2010
Сообщений: 58
Пост №7
 
24.03.2010 14:27

"ДатаРождения = ФизЛицо.ДатаРождения;<br>{Глобальный модуль (43250)}; Поле агрегатного объекта не обнаружено (ДатаРождения)"

zak555 (398843952)
читатель
офлайн
Дата регистрации: 27.03.2008
Сообщений: 4656
Пост №8
 
24.03.2010 14:39

посмотри отладчиком - ТипЗначенияСтр(ФизЛицо)

zak555 (398843952)
читатель
офлайн
Дата регистрации: 27.03.2008
Сообщений: 4656
Пост №9
 
24.03.2010 14:52

нет, верни назад всё, как было !!!

Svetlana Nikol
читатель
офлайн
Дата регистрации: 24.02.2010
Сообщений: 58
Пост №10
 
24.03.2010 14:55

не понятно что вернуть: в первоначальный вид? до исправлений в ГМ?

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • МАРКИРОВКА
  • ЕГАИС
  • Учет, налогообложение, автоматизация
Предложения партнеров
Обучение пользователей продуктов 1С