Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

ЗиК 7.7 Как вывести в расчетку невыходы?

HITDEVIL
читатель
офлайн
Дата регистрации: 13.11.2007
Сообщений: 9
Пост №1
 
05.05.2010 10:01

"Добрый день всем.
Помогите никак не могу разобраться, как вывести в печатную форму расчетного листа невыходы.
В документе Невыходы дописал:
ИначеЕсли ПричинаОтсутствия = Перечисление.ПричинаОтсутствия.Перевахтовка Тогда
ЖрнЗарплата.ВвестиРасчет(Сотрудник,ВидРасчета.Перевахтовка,Начало,Окончание,0);
ИначеЕсли ПричинаОтсутствия = Перечисление.ПричинаОтсутствия.Межвахтовые_отгулы Тогда
ЖрнЗарплата.ВвестиРасчет(Сотрудник,ВидРасчета.Межвахтовые_отгулы,Начало,Окончание,0);
ИначеЕсли ПричинаОтсутствия = Перечисление.ПричинаОтсутствия.КоммандировкаП Тогда
ЖрнЗарплата.ВвестиРасчет(Сотрудник,ВидРасчета.КоммандировкаП,Начало,Окончание,0);
Виды расчета добавил: Перевахтовка,Межвахтовые_отгулы,КоммандировкаП
В модуле прописал:
Процедура ПровестиРасчет()      

Если (Исправлена=1) или (Фиксирована=1) Тогда
глСообщениеТрассировки(глСообщенияТрассировки, """" + ?(Исправлена=1,"Результат записи исправлен вручную","Запись фиксирована") + ". Расчет не проводился.", , 1);
Возврат
КонецЕсли;                                                            

ГрафикРаботы = Объект.ГрафикРаботы.Получить(ДатаОкончания);
Если ПустоеЗначение(ГрафикРаботы)=1 Тогда
глСообщениеТрассировки(глСообщенияТрассировки, "График работы сотрудника на _П01 не задан! Будет использоваться основной график предприятия.", 0, 1, ДатаОкончания, "ДДДММММГГГГ");
ГрафикРаботы = Константа.ОсновнойГрафик;
КонецЕсли;      
Если ПустоеЗначение(ГрафикРаботы)=1 Тогда
Если глРежимТрассировки = 1 Тогда
глСообщениеТрассировки(глСообщенияТрассировки, "Основной график работы предприятия не задан!", 1, 0);
Иначе
глДобавитьСообщение(глОбработчикСообщений, "Основной график работы предприятия не задан!", , , );
КонецЕсли;
Возврат
КонецЕсли;
Календарь = ГрафикРаботы.ОсновныеЧасы;
Дней = Календарь.Дней(ДатаНачала,ДатаОкончания);
Дни= ?(Сторно=0,Дней,-Дней);

КонецПроцедуры // ПровестиРасчет()

А что дописать в расчетке чтоб они выводились так и не могу понять, помогите кто знает!
Заранее спасибо за помощь!
"

Thorvardr
читатель
офлайн
Дата регистрации: 25.02.2005
Сообщений: 3078
Пост №2
 
05.05.2010 12:15

Наверное, нужно указать, что виды расчетов
Перевахтовка
Межвахтовые_отгулы
Коммандиро­вкаП
входят в группы расчетов по аналогии с "Невыходы":
ВсеНачисления
ВсеОтклонения
ПроводкиНеФормировать (КоммандировкаП - тоже? вам виднее)
РедактированиеБазЗапрещено
УчитыватьДни

HITDEVIL
читатель
офлайн
Дата регистрации: 13.11.2007
Сообщений: 9
Пост №3
 
05.05.2010 12:21

Все так и стоит только все равно не выводит.
Может быть что то еще в модуле расчетный лист добавить?

Thorvardr
читатель
офлайн
Дата регистрации: 25.02.2005
Сообщений: 3078
Пост №4
 
05.05.2010 12:58

"В модуле есть запрос и в нем может срезаться из за:
|Условие((Результат<>0)или(ДниВЖурнале<>0));";
У вас в журнале документов в этих записях реквизит Дни чему равен?"

HITDEVIL
читатель
офлайн
Дата регистрации: 13.11.2007
Сообщений: 9
Пост №5
 
05.05.2010 13:03

Не совсем понял, но равно 0.
Все теперь выводит все начисления и нулевые!
За совет спасибо!

Thorvardr
читатель
офлайн
Дата регистрации: 25.02.2005
Сообщений: 3078
Пост №6
 
05.05.2010 14:08

Теперь у вас там много ненужного будет выводиться, если вы из запроса просто выкинули эту строку :)
По другому сделайте. И вообще, созданные вами виды расчетов в журнале расчетов присутсвуют вместе с невыходами или вы "Невыходы" не создаете, а создаете свои виды расчетов?

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • МАРКИРОВКА
  • ЕГАИС
  • Учет, налогообложение, автоматизация
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги