Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[1С:Зарплата и управление персоналом 8]

Вопрос по заполнению расчетного листка

brotherodd
читатель
офлайн
Дата регистрации: 27.04.2009
Сообщений: 14
Пост №1
 
16.03.2011 15:41

Есть постоянные начисления которые определены для всех пользователей, что бы не заморачиваться потом с созданием документа для каждого сотрудника по отдельности, а просто проставлять показатели для расчета заработной платы. Суть проблемы в том, что даже если у человека не проставлены показатели схем мотивации, эти виды все равно попадают пустыми строчками в расчетный листок. Можно ли каким нибудь способом сделать так что бы эти пустые строчки не попадали в расчетный лист?
Удалять их в документе "начисление заработной платы" мягко скажем неудобно. Стоит ЗуП 8.1 (2.5.32.5)

BelikovS
читатель
офлайн
Дата регистрации: 05.03.2007
Сообщений: 1701
Пост №2
 
16.03.2011 15:48

> Удалять их в документе "начисление заработной платы" мягко скажем неудобно

Удалять можно и обработкой заполнения табличных частей :)

brotherodd
читатель
офлайн
Дата регистрации: 27.04.2009
Сообщений: 14
Пост №3
 
16.03.2011 15:54

А если не сложно, подскажите как это сделать?

Tanya
активный пользователь
офлайн
Дата регистрации: 03.12.2001
Сообщений: 8411
Пост №4
 
16.03.2011 16:44

Если уж так мешают пустые, создайте свою печатную форму р/листа.

Tanya
активный пользователь
офлайн
Дата регистрации: 03.12.2001
Сообщений: 8411
Пост №5
 
16.03.2011 16:45

> Удалять можно и обработкой заполнения табличных частей :)

Мое мнение, этот документ таким образом лучше не трогать.

BelikovS
читатель
офлайн
Дата регистрации: 05.03.2007
Сообщений: 1701
Пост №6
 
16.03.2011 16:49

А вы программист?

brotherodd
читатель
офлайн
Дата регистрации: 27.04.2009
Сообщений: 14
Пост №7
 
16.03.2011 16:50

Нет вообше то, но стараюсь им стать(

BelikovS
читатель
офлайн
Дата регистрации: 05.03.2007
Сообщений: 1701
Пост №8
 
16.03.2011 17:14

"1. Почитайте про внешние обработки заполнения табличной части
2. Что-то в этом духе

Процедура Инициализировать(Объект, ИмяТабличнойЧасти, ТабличноеПолеОбъекта) Экспорт
МасСтр = Новый Массив;
Для Каждого Стр Из Объект[ИмяТабличнойЧасти] Цикл
Если ЗначениеЗаполнено (Стр....) Тогда Продолжить; КонецЕсли; //Условия при которых строка Остается в ТЧ
МасСтр.Добавить(Стр);
КонецЦикла;
Для Каждого Стр Из МасСтр Цикл Объект[ИмяТабличнойЧасти].Удалить(Стр); КонецЦикла;
КонецПроцедуры
"

Тэра
активный пользователь
онлайн
Дата регистрации: 25.12.2008
Сообщений: 22063
Пост №9
 
16.03.2011 18:20

согласна с вами, лучше свой расчетный листок написать

brotherodd
читатель
офлайн
Дата регистрации: 27.04.2009
Сообщений: 14
Пост №10
 
17.03.2011 09:08

Я тоже считаю этот метод крайне плохим, а написать свой расчетный листок пока не в состоянии(мало опыта).

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги