Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Другие решения на платформе "1С:Предприятие 8"]

Конвертация ПОМОГИТЕ

АнтонХудин
Пост №1
АнтонХудин
читатель
офлайн
Дата регистрации: 25.01.2013
Сообщений: 34
Пост №1
 
22.02.2013 12:14

"При загрузке данных из зик в камин, в камине пишет ошибку

Ошибка при загрузке данных: {ВнешняяОбработка.УниверсальныйОбменДаннымиXML.МодульОбъекта(6497)}: Поле объекта не обнаружено (НормыВремени)

Нашел эту строку!! Что тут может быть не так???

Процедура ЗагрузитьТабличнуюЧасть(Объект, Имя, Очистить, ОбщаяИнформацияОТипеДокумента, НужноЗаписатьОбъект,
ПараметрыОбъекта, Правило)

ИмяТабличнойЧасти = Имя + "ТабличнаяЧасть";
Если ОбщаяИнформацияОТипеДокумента <> Неопределено Тогда
ИнформацияОТипах = ОбщаяИнформацияОТипеДокумента[ИмяТабличнойЧасти];
Иначе
ИнформацияОТипах = Неопределено;
КонецЕсли;

ДанныеПоискаПоТЧ = Неопределено;
Если Правило <> Неопределено Тогда
ДанныеПоискаПоТЧ = Правило.ПоискПоТабличнымЧастям.Найти("ТабличнаяЧасть." + Имя, "ИмяЭлемента");
КонецЕсли;

КопияТЧДляПоиска = Неопределено;

Строка 6497!!! ТЧ = Объект[Имя];

Если Очистить
И ТЧ.Количество() <> 0 Тогда

НужноЗаписатьОбъект = Истина;

Попытка

Если ДанныеПоискаПоТЧ <> Неопределено Тогда
КопияТЧДляПоиска = ТЧ.Выгрузить();
КонецЕсли;

ТЧ.Очистить();

Исключение

КонецПопытки;



Что в ней не так?? в правилал посмотрел про нормы времени там в источнике нету такой табличной части, в приемнике есть!"

Jesslina
Пост №2
Jesslina
читатель
офлайн
Дата регистрации: 09.01.2009
Сообщений: 666
Пост №2
 
22.02.2013 12:32

может вам лучше непосредственно на линию консультации Камина написать?

Thorvardr
Пост №3
Thorvardr
читатель
офлайн
Дата регистрации: 25.02.2005
Сообщений: 3077
Пост №3
 
22.02.2013 14:54

В каком то объекте не нашлась табличная часть с идентификатором "НормыВремени".
Я бы точку останова поставил в это место и узнал какого типа и вида объект. Потом посмотрел бы в конфигураторе где там у него такая табличная часть потерялась и должна ли она вообще быть по смыслу.

АнтонХудин
Пост №4
АнтонХудин
читатель
офлайн
Дата регистрации: 25.01.2013
Сообщений: 34
Пост №4
 
22.02.2013 16:34

Объясните где эту точку ставить?? и как сделать чтобы отладка была??? как я узнаю тип и вид объекта можно по подробней?? я в конфиге запускал в8эксчендж и нифига, ставил точку там и запускал отладку и запускалось приложение и ничего....Помогите пожалуйста разобраться!

Денис (САМАРА)
Пост №5
Денис (САМАРА)
активный пользователь
офлайн
Дата регистрации: 09.04.2008
Сообщений: 8342
Пост №5
 
27.02.2013 17:07

> Объясните где эту точку ставить??

В той строке, которую Вы нашли.

> ...и как сделать чтобы отладка была???

Открыть базу конфигуратором и из него запустить отладку (см. документацию по администрированию).

> как я узнаю тип и вид объекта можно по подробней??

После остановки выполнения кода на вашей "точке останова" откроете "Табло" и в ведете в него имя переменной, которая определяет нужный объект. Во второй колонке табло отобразиться тип объекта.

P.S. А в целом надо обладать познаниями программирования для разрешения этой задачи.

Thorvardr
Пост №6
Thorvardr
читатель
офлайн
Дата регистрации: 25.02.2005
Сообщений: 3077
Пост №6
 
27.02.2013 21:06

А уже все. По почте разрулили. Закончилось тем, что прислали им нормальные правила переноса и все.

Денис (САМАРА)
Пост №7
Денис (САМАРА)
активный пользователь
офлайн
Дата регистрации: 09.04.2008
Сообщений: 8342
Пост №7
 
27.02.2013 21:28

Бери их, Володь, на удаленный аутсорт. :)

Thorvardr
Пост №8
Thorvardr
читатель
офлайн
Дата регистрации: 25.02.2005
Сообщений: 3077
Пост №8
 
28.02.2013 08:05

Мне своих хватает. Иногда как навалятся, не продохнешь.

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги
© ООО "1C" 2000-2018 г.