Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

Прогресс бар

АнтонХудин
Пост №1
АнтонХудин
читатель
офлайн
Дата регистрации: 25.01.2013
Сообщений: 34
Пост №1
 
08.04.2013 22:08

"Во внешней обработке есть две процедуры и третья при нажатии которой выполняются поочередно первая и вторая.
Есть код для прогресс бара, я в коде пока новичек, подскажите как реализовать подключение к этим процедурам процесс бара.
код процесс бара вот такой:
Процедура КнопкаВыполнитьНажатие() //вообще изначально это кнопка была, я убрал
ПР=Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент;
Пр.ОтображатьПроцентВывода=Истина ;
Эл=Новый ЭлементРезультатаКомпоновкиДанных;

ПР.НачатьВывод();
Для А=1 По 100 Цикл
      Эл.ПроцентВывода=А;
      //задержка, чтобы разглядеть
      Для Б=1 По 10000 Цикл КонецЦикла;
      ПР.ВывестиЭлемент(Эл);
КонецЦикла;
ПР.ЗакончитьВывод();
КонецПроцедуры"

АнтонХудин
Пост №2
АнтонХудин
читатель
офлайн
Дата регистрации: 25.01.2013
Сообщений: 34
Пост №2
 
08.04.2013 22:10

хочу чтобы при выполнении этих процедур выполнялся процесс бар, чтобы высвечивались проценты состояния выполнения процедур

Prikum
Пост №3
Prikum
читатель
офлайн
Дата регистрации: 18.02.2002
Сообщений: 20454
Пост №3
 
08.04.2013 22:15

Не надо создавать дубли тем! Дождитесь ответа в старой теме!

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги
© ООО "1C" 2000-2018 г.