Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Другие решения на платформе "1С:Предприятие 8"]

Динамическое создание колонок в табличном поле документа.

lou-bega
Пост №1
lou-bega
читатель
офлайн
Дата регистрации: 28.05.2009
Сообщений: 36
Пост №1
 
02.08.2013 16:22

"Добрый день. Есть табличная часть документа, которая заполняется из запроса. Помимо предопределенных колонок, добавляются созданные программно.

ТабличнаяЧастьПрогноза.Загрузить(Запрос.Выполнить().Выгрузить());ТабличнаяЧастьПрогноза.Сортировать("ДатаОкончания Возр");Массив = Новый Массив;Массив = ТабличнаяЧастьПрогноза.ВыгрузитьКолонку("ДатаОкончания");НужнаяДата = Массив[0];КонГода = (КонецГода(НужнаяДата));Для Каждого Строка Из ТабличнаяЧастьПрогноза Цикл  Пока НужнаяДата <= КонГода Цикл     НужнаяДата = ДобавитьМесяц(НужнаяДата, 1);   ДатаОк = Формат(НужнаяДата,"ДФ='MMMM_YYYY'");   ТекущаяТаблица.Колонки.Добавить(ДатаОк);  КонецЦикла;КонецЦикла;


Далее, в колонке "процент повышения" указываю нужный процент и нажимаю кнопку "заполнить". Срабатывает процедура.
НоваяСтрока = ТабличнаяЧастьПрогноза.Добавить();ТекущаяТаблица = ЭлементыФормы.ТабличнаяЧастьПрогноза.Колонки..ДобавитьСтроку();ДобавитьВТаблицу = ЭтотОбъект.ТабличнаяЧастьПрогноза.Добавить();					  Для Каждого Строка Из ТабличнаяЧастьПрогноза Цикл  Если Строка.ПроцентПовышенияСтавки <> 0 Тогда     СуммаСПроцентом = Строка.СтавкаВМесяц / 100 * Строка.ПроцентПовышенияСтавки + Строка.СтавкаВМесяц;   ДобавитьВТаблицу[ДатаОк] = СуммаСПроцентом;  КонецЕсли;КонецЦикла;


Получаю ошибку "поле объекта не обнаружено()". Оно и понятно, ведь этого поля в "ДобавитьВТаблицу" нет, оно есть в "ТекущаяТаблица", но через не го тоже не получается добавить "обращение к процедуре объекта как к функции (добавитьстроку)".
Подскажите, пожалуйста, как мне добавить строку в созданную колонку?"

Денис (САМАРА)
Пост №2
Денис (САМАРА)
активный пользователь
офлайн
Дата регистрации: 09.04.2008
Сообщений: 8342
Пост №2
 
05.08.2013 10:28

"Всякая фигня в созданных колонках отображается через текст ячейки. Доступ к заполнению получают через предопределенную процедуру табличного поля "ПриПолученииДанных()", а в ней через коллекцию ОформленияСтрок.


ОформлениеСтроки.Ячейки["<имя колонки>"].УстановитьТекст(<строковое значение>); 
"

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги
© ООО "1C" 2000-2018 г.