Новости для бухгалтера, бухучет, налогообложение, отчетность, ФСБУ, прослеживаемость и маркировка, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[1С:Бухгалтерия 8]

Не получается открыть обработку из справочника "ВнешниеОбработки"

Елена_В
читатель
офлайн
Дата регистрации: 26.10.2007
Сообщений: 611
Пост №1
 
08.08.2013 14:31

"Доброе время суток!<br>Конфигурация - БП 2.0<br> <br>В справочник "ВнешниеОбработки" добавлена обработка1. Из другой внешней обработки2 мне нужно открыть модально Обработку1. Нашла такой способ <br> <br>&НаКлиенте<br>Процедура ОбработкаКоманды(ПараметрКоманды, ПараметрыВыполненияКоманды) <br>//Помещаем обработку во временном хранилище <br>АдресХранилища = """"; <br>Результат = ПоместитьФайл(АдресХранилища, "C:\ВнешняяОбработка.epf", , Ложь);             <br>ИмяОбработки = ПодключитьВнешнююОбработку(АдресХранилища);       <br>// Откроем форму подключенной внешней обработки <br>ОткрытьФорму("ВнешняяОбработка."+ ИмяОбработки +".Форма");<br>КонецПроцедуры<br> <br>&НаСервере<br>Функция ПодключитьВнешнююОбработку(АдресХранилища) <br>Возврат ВнешниеОбработки.Подключить(АдресХранилища); <br>КонецФункции <br> <br>но мне он не подходит, т.к. здесь с локального диска обработку1 помещают во временное хранилище, а у меня эта обработка загружена в справочник. Поробовала так, но не работает<br>ВнешняяОбработка = Справочники.ВнешниеОбработки.НайтиПоНаименованию("Обработка1");<br>Если НЕ ВнешняяОбработка = Справочники.ВнешниеОбработки.ПустаяСсылка() Тогда<br>Обработка1 = ВнешниеОбработки.Подключить(ВнешняяОбработка.ХранилищеВнешнейОбработки); <br>КонецЕсли;"

Thorvardr
читатель
офлайн
Дата регистрации: 25.02.2005
Сообщений: 3082
Пост №2
 
08.08.2013 14:56

"может так?<br> <br>ИмяФайла = ПолучитьИмяВременногоФайла();<br>ДвоичныеДанные = ВнешняяОбработка.ХранилищеВнешнейОбработки.Получить();<br>ДвоичныеДанные.Записать(ИмяФайла);<br>Обработка1 = ВнешниеОбработки.Создать(ИмяФайла);"

Денис (САМАРА)
читатель
офлайн
Дата регистрации: 09.04.2008
Сообщений: 8351
Пост №3
 
08.08.2013 14:58

- Получаешь ссылку справочника внешних обработок.<br> - Сохраняешь данные из реквизита "ХранилищеВнешнейОбработки" во внешний файл (во временный каталог 1С).<br> - Открываешь форму внешней обработки модально.<br> - По закрытию формы удаляешь файл обработки.

Елена_В
читатель
офлайн
Дата регистрации: 26.10.2007
Сообщений: 611
Пост №4
 
08.08.2013 15:24

Всем спасибо!! сработало!

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • МАРКИРОВКА
  • ЕГАИС
  • Учет, налогообложение, автоматизация
Предложения партнеров
Обучение пользователей продуктов 1С