Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[1С:Бухгалтерия 8]

Не получается открыть обработку из справочника "ВнешниеОбработки"

Елена_В
Пост №1
Елена_В
читатель
офлайн
Дата регистрации: 26.10.2007
Сообщений: 599
Пост №1
 
08.08.2013 14:31

"Доброе время суток!
Конфигурация - БП 2.0

В справочник "ВнешниеОбработки" добавлена обработка1. Из другой внешней обработки2 мне нужно открыть модально Обработку1. Нашла такой способ

&НаКлиенте
Процедура ОбработкаКоманды(ПараметрКоманды, ПараметрыВыполненияКоманды)
//Помещаем обработку во временном хранилище
АдресХранилища = """";
Результат = ПоместитьФайл(АдресХранилища, "C:\ВнешняяОбработка.epf", , Ложь);            
ИмяОбработки = ПодключитьВнешнююОбработку(АдресХранилища);      
// Откроем форму подключенной внешней обработки
ОткрытьФорму("ВнешняяОбработка."+ ИмяОбработки +".Форма");
КонецПроцедуры

&НаСервере
Функция ПодключитьВнешнююОбработку(АдресХранилища)
Возврат ВнешниеОбработки.Подключить(АдресХранилища);
КонецФункции

но мне он не подходит, т.к. здесь с локального диска обработку1 помещают во временное хранилище, а у меня эта обработка загружена в справочник. Поробовала так, но не работает
ВнешняяОбработка = Справочники.ВнешниеОбработки.НайтиПоНаименованию("Обработка1");
Если НЕ ВнешняяОбработка = Справочники.ВнешниеОбработки.ПустаяСсылка() Тогда
Обработка1 = ВнешниеОбработки.Подключить(ВнешняяОбработка.ХранилищеВнешнейОбработки);
КонецЕсли;"

Thorvardr
Пост №2
Thorvardr
читатель
офлайн
Дата регистрации: 25.02.2005
Сообщений: 3077
Пост №2
 
08.08.2013 14:56

"может так?

ИмяФайла = ПолучитьИмяВременногоФайла();
ДвоичныеДанные = ВнешняяОбработка.ХранилищеВнешнейОбработки.Получить();
ДвоичныеДанные.Записать(ИмяФайла);
Обработка1 = ВнешниеОбработки.Создать(ИмяФайла);"

Денис (САМАРА)
Пост №3
Денис (САМАРА)
активный пользователь
офлайн
Дата регистрации: 09.04.2008
Сообщений: 8342
Пост №3
 
08.08.2013 14:58

- Получаешь ссылку справочника внешних обработок.
- Сохраняешь данные из реквизита "ХранилищеВнешнейОбработки" во внешний файл (во временный каталог 1С).
- Открываешь форму внешней обработки модально.
- По закрытию формы удаляешь файл обработки.

Елена_В
Пост №4
Елена_В
читатель
офлайн
Дата регистрации: 26.10.2007
Сообщений: 599
Пост №4
 
08.08.2013 15:24

Всем спасибо!! сработало!

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги
© ООО "1C" 2000-2018 г.