Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

Не обновляется БП 3.0 на сервере LInux в автоматическом режиме

caletre
читатель
офлайн
Дата регистрации: 10.07.2012
Сообщений: 9
Пост №1
 
18.10.2016 12:03

С какого-то релиза последнего релиза БП 3.0 почему-то закрыли возможность обновлять стандартную конфигурацию БП 3.0 в автоматическом режиме.
Пишет ошибку "Получение обновлений программы недоступно в текущем режиме работы."

Почему то это убрали для платформ серверов отличных от Windows.


Функция из общего модуля "ПолучениеОбновленияПрограммы"

Код
Функция ДоступноИспользованиеОбновленияПрограммы(ПроверитьВозможностьПримененияОбновлений = Ложь) Экспорт
      
      Если ОбщегоНазначенияКлиентСервер.ЭтоВебКлиент()
            Или ОбщегоНазначенияПовтИсп.РазделениеВключено()
            Или (ПроверитьВозможностьПримененияОбновлений И Не Пользователи.ЭтоПолноправныйПользователь(, Истина, Ложь))
            Или Не Пользователи.РолиДоступны("ПросмотрИнформацииОДоступныхОбновленияхПрограммы", , Ложь)
            Или ПользователиКлиентСервер.ЭтоСеансВнешнегоПользователя()
            Или ОбщегоНазначения.ЭтоПодчиненныйУзелРИБ() Тогда
            Возврат Ложь;
      КонецЕсли;
      
      СистИнфо = Новый СистемнаяИнформация;
      Если СистИнфо.ТипПлатформы <> ТипПлатформы.Windows_x86
            И СистИнфо.ТипПлатформы <> ТипПлатформы.Windows_x86_64 Тогда
            Возврат Ложь;
      КонецЕсли;
      
      Возврат Истина;
      
КонецФункции

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги