Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[1С:Бухгалтерия 8]

Дополнительные печатные формы и обработки для нетиповых объектов конфигурации Бухгалтерия 3.0.52.32

Иван Лазаренко
читатель
офлайн
Дата регистрации: 27.04.2012
Сообщений: 72
Пост №1
 
07.09.2017 08:13

Здравствуйте. Возникла проблема при переходе на редакцию Бухгалтерия 3.0.52.32.
В не типовых документах перестали работать дополнительные печатные формы добавленные через справочник "Дополнительные отчеты и обработки".
Это произошло потому, что в новой конфигурации исчезли общие команды ДополнительныеПечатныеФормыОбъекта и ЗаполнениеОбъекта в свойства которых я ранее добавлял нетиповые объекты (справочники и документы).
Причем дополнительные печатные формы отображаются на форме документа(т.к. я добавлял ранее нетиповой справочник в ОбщийМодуль УправлениеПечатьюПредопределяемый), но не работают(при нажатии ничего не происходит). А по поводу обработок заполнения: кнопка "заполнение" даже не отображается на форме документа.

Знает ли кто нибудь, что пришло на замену общим командам ДополнительныеПечатныеФормыОбъекта и ЗаполнениеОбъекта ?

Где теперь указывать не типовые документы и справочники что бы у них работали дополнительные печатные формы и обработки?

Иван Лазаренко
читатель
офлайн
Дата регистрации: 27.04.2012
Сообщений: 72
Пост №2
 
07.09.2017 09:33

Причем если эти дополнительные ПФ подключить к типовым справочникам или документам, то они видны и запускаются. Т.е. сами дополнительные отчеты и обработки скорей всего модифицировать не нужно под новую конфигурацию. Надо лишь найти где указать не типовые объекты в конфигурации чтобы всё опять заработало

Ответили: пост №3
Prikum
читатель
офлайн
Дата регистрации: 18.02.2002
Сообщений: 20454
Пост №3
 
07.09.2017 09:37
Ответ на пост №2

Иван Лазаренко, в новых конфигурациях сняли режим совместимости.

Ответили: пост №4
Иван Лазаренко
читатель
офлайн
Дата регистрации: 27.04.2012
Сообщений: 72
Пост №4
 
07.09.2017 09:40
Ответ на пост №3

Prikum,да я знаю что его сняли. Я вижу естественно, что и конфигурация сильно изменилась. Вот от этого и возник вопрос как сейчас быть с доп. пф. и обработками

Prikum
читатель
офлайн
Дата регистрации: 18.02.2002
Сообщений: 20454
Пост №5
 
07.09.2017 09:44

Иван Лазаренко пишет:

Цитата
как сейчас быть с доп. пф. и обработками
переделывать под новые реалии!

Ответили: пост №6
Иван Лазаренко
читатель
офлайн
Дата регистрации: 27.04.2012
Сообщений: 72
Пост №6
 
07.09.2017 09:49
Ответ на пост №5

Prikum,ну и как же на платформе 8.3.10 назначать внешние обработки к не типовым объектам? Режим совместимости и раньше в бухгалтерии менялся: 8.3.6, 8.3.8 и проблем с обработками не было. Может дело всё таки не в платформе, а в конфигурации?

Ответили: пост №7
Prikum
читатель
офлайн
Дата регистрации: 18.02.2002
Сообщений: 20454
Пост №7
 
07.09.2017 10:09
Ответ на пост №6

Иван Лазаренко, может быть теперь все надо в расширение конфигурации пихать?

Ответили: пост №8
Иван Лазаренко
читатель
офлайн
Дата регистрации: 27.04.2012
Сообщений: 72
Пост №8
 
07.09.2017 10:15
Ответ на пост №7

Prikum,тоже думал о расширении. Но ведь те же самые пф прекрасно работают если их подключить к типовым документам. Не могу поверить, что они вырубили возможность добавлять пф и обработки для нетиповых объектов(справочников и документов). К тому же в документации к платформе 8.3.10 я не нашёл ничего об изменении механизма доп отчетов.

Ответили: пост №9
Prikum
читатель
офлайн
Дата регистрации: 18.02.2002
Сообщений: 20454
Пост №9
 
07.09.2017 10:22
Ответ на пост №8

Иван Лазаренко, не знаю, пока еще не разбирался.

Иван Лазаренко
читатель
офлайн
Дата регистрации: 27.04.2012
Сообщений: 72
Пост №10
 
08.09.2017 08:42

Разобрался с проблемой нефункционирования внешних печатных форм на нетиповом справочнике(или документе).

После обновления релиза бухгалтерии на версию 3.0.52 в форму элемента справочника

помимо кода печати который был ранее:

Код
&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
      УправлениеПечатью.ПриСозданииНаСервере(ЭтаФорма, Элементы.ГруппаПечать);
      ДополнительныеОтчетыИОбработки.ПриСозданииНаСервере(ЭтаФорма);
КонецПроцедуры

&НаКлиенте
Процедура Подключаемый_ВыполнитьКомандуПечати(Команда)
  УправлениеПечатьюКлиент.ВыполнитьПодключаемуюКомандуПечати(Команда, ЭтаФорма, Объект);
КонецПроцедуры
 


необходимо добавить ещё 3 процедуры:

Код
// СтандартныеПодсистемы.ПодключаемыеКоманды
&НаКлиенте
Процедура Подключаемый_ВыполнитьКоманду(Команда)
      ПодключаемыеКомандыКлиент.ВыполнитьКоманду(ЭтотОбъект, Команда, Объект);
КонецПроцедуры

&НаСервере
Процедура Подключаемый_ВыполнитьКомандуНаСервере(Контекст, Результат)
      ПодключаемыеКоманды.ВыполнитьКоманду(ЭтотОбъект, Контекст, Объект, Результат);
КонецПроцедуры

&НаКлиенте
Процедура Подключаемый_ОбновитьКоманды()
      ПодключаемыеКомандыКлиентСервер.ОбновитьКоманды(ЭтотОбъект, Объект);
КонецПроцедуры
// Конец СтандартныеПодсистемы.ПодключаемыеКоманды
 
После этого внешние печатные формы заработают.
Скрытый текст
По поводу внешних обработок заполнения пока не разобрался, но скорее всего то же надо будет добавить какой то новый код ну или вернуть общую команду "ЗаполнениеОбъекта" из старой конфигурации(пока этот способ работает)

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги