Новости для бухгалтера, бухучет, налогообложение, отчетность, ФСБУ, прослеживаемость и маркировка, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

Задача

Александр Шевченко
читатель
офлайн
Дата регистрации: 19.12.2017
Сообщений: 4
Пост №1
 
19.12.2017 09:28

Добрый день!
Помогите, пожалуйста.

Розничная фирма с сетью торговых точек ведет бухгалтерский учет в нетиповой конфигурации на платформе «1С:Предприятие 8» в течение десяти лет. Каждая торговая точка ведет учет в своей информационной базе, в которой содержатся проводки за весь период ведения учета. Ежедневно информация о дневной выручке торговой точки отражается проводками следующей структуры (по каждому товару):

Дт счета 50 «Касса» Кт счета 90 «Продажи» Сумма выручки

Для этого на счете 90 ведется аналитический учет в разрезе товаров. В каждой торговой точке – не более 100 наименований товаров.
Основная цель ведения учета для фирмы – анализ выполнения
утвержденного плана по получению выручки от продаж.

Учет ведется в конфигурации, в состав которой входят:
− план счетов бухгалтерского учета, содержащий два счета – 50 «Касса» (активный) и 90 «Продажи» (активно-пассивный);
− регистр бухгалтерии с набором бухгалтерских проводок за период с 01.03.2016 г. по 31.05.2016 г. Каждая проводка содержит корреспонденцию в дебет счета 50 и кредит счета 90 на сумму продаж за соответствующий день по каждому товару. Другие проводки в информационной базе отсутствуют;
− справочник Товар с пятью наименованиями товаров. Имеется возможность для тестирования вводить дополнительные товары;
− документ Ввод данных для ввода проводок при ведении учета, для тестирования программы. Документ генерирует проводки за каждый день в течение заданного периода по всем товарам, содержащимся в справочнике Товар.

Нужно создать отчет который на основе анализа проводок в информационной базе за заданный период ведения учета в торговой точке определяет максимальный непрерывный отрезок (в днях), в течение которого торговая точка выполняла план по выручке. Принимаются следующие допущения:
1. Дневной план выполнен, если полученная выручка больше
или равна планового показателя.
2. В базе представлены данные за каждый торговый день, но если данные о выручке за какую-то дату или период отсутствуют, то эти дни не считаются торговыми днями и не нарушают непрерывность периода выполнения плана по выручке.
Период, за который производится анализ данных информационной базы, и плановая величина выручки должны вводиться в параметры отчета. Необходимо, чтобы по умолчанию устанавливался период с 01.03.2016 г. по 31.05.2016 г., а плановая величина выручки – 19 000 руб.


Пытаюсь сделать, понять как работает. Но ничего не выходит. Вот максимум который смог сделать, да и тот не работает. Помогите, пожалуйста. Хочу узнать, как это реализовать.

Ответили: пост №2
Prikum
активный пользователь
офлайн
Дата регистрации: 18.02.2002
Сообщений: 20726
Пост №2
 
19.12.2017 09:35
Ответ на пост №1

Александр Шевченко, а зачем срез итогов стоит как неделя? А план при этом дневной? А вообще наверное рано еще на работу устраиваться.

Александр Шевченко
читатель
офлайн
Дата регистрации: 19.12.2017
Сообщений: 4
Пост №3
 
19.12.2017 10:06

Изменил, но все равно не работает

Ответили: пост №4
Prikum
активный пользователь
офлайн
Дата регистрации: 18.02.2002
Сообщений: 20726
Пост №4
 
19.12.2017 11:27
Ответ на пост №3

Александр Шевченко, там одним запросом не обойтись, сначала надо выбрать данные по дневной выручке, потом анализировать выполняется план или нет, а уже потом выводить максимальный период.

Александр Шевченко
читатель
офлайн
Дата регистрации: 19.12.2017
Сообщений: 4
Пост №5
 
19.12.2017 18:28

Prikum, Пытаюсь сделать программно. Создал в отчете форму и добавил кнопку.
Получился следующий код
[code]&НаСервере
Процедура Сформировать()
      Запрос = Новый Запрос;
      План = 19000;
      Запрос.Текст =
            "ВЫБРАТЬ
            |      ВложенныйЗапрос.Период,
            |      ВложенныйЗапрос.Сумма
            |ИЗ
            |      (ВЫБРАТЬ
            |            ВложенныйЗапрос.Период КАК Период,
            |            ВложенныйЗапрос.Сумма КАК Сумма
            |      ИЗ
            |            (ВЫБРАТЬ
            |                  РегистрБухгалтерии.Период КАК Период,
            |                  СУММА(РегистрБухгалтерии.Сумма) КАК Сумма
            |            ИЗ
            |                  РегистрБухгалтерии.РегистрБухгалтерии КАК РегистрБухгалтерии
            |            
            |            СГРУППИРОВАТЬ ПО
            |                  РегистрБухгалтерии.Период) КАК ВложенныйЗапрос
            |      ГДЕ
            |            ВложенныйЗапрос.Сумма >= &План) КАК ВложенныйЗапрос";
      
      Запрос.УстановитьПараметр("План", План);
      РезультатЗапроса = Запрос.Выполнить();
      ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
      
//      Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
            // Вставить обработку выборки ВыборкаДетальныеЗаписи
//      КонецЦикла;
      
КонецПроцедуры


&НаКлиенте
Процедура Команда1(Команда)
      Сформировать();      
КонецПроцедуры
[/code]

Как мне теперь посмотреть что у меня получилось? При нажатии на кнопку отчет не формируется. Как его сформировать?

Александр Шевченко
читатель
офлайн
Дата регистрации: 19.12.2017
Сообщений: 4
Пост №6
 
19.12.2017 19:49

Немного переделал, но результат запроса пустой получается. Помогите, пожалуйста

Процедура ПриКомпоновкеРезультата(ДокументРезультат, ДанныеРасшифровки, СтандартнаяОбработка)
      Запрос = Новый Запрос;
      План = 19000;
      Запрос.Текст =
            "ВЫБРАТЬ
            |      ВложенныйЗапрос.Период,
            |      ВложенныйЗапрос.Сумма
            |ИЗ
            |      (ВЫБРАТЬ
            |            ВложенныйЗапрос.Период КАК Период,
            |            ВложенныйЗапрос.Сумма КАК Сумма
            |      ИЗ
            |            (ВЫБРАТЬ
            |                  РегистрБухгалтерии.Период КАК Период,
            |                  СУММА(РегистрБухгалтерии.Сумма) КАК Сумма
            |            ИЗ
            |                  РегистрБухгалтерии.РегистрБухгалтерии КАК РегистрБухгалтерии
            |            
            |            СГРУППИРОВАТЬ ПО
            |                  РегистрБухгалтерии.Период) КАК ВложенныйЗапрос
            |      ГДЕ
            |            ВложенныйЗапрос.Сумма >= &План) КАК ВложенныйЗапрос";
      
      Запрос.УстановитьПараметр("План", План);
      
      ТЗ=Запрос.Выполнить().Выгрузить();
ВнешнийНабор=Новый Структура("Набор",ТЗ);                                                      

СКД=ЭтотОбъект.ПолучитьМакет("ОсновнаяСхемаКомпоновкиДанных");
      
НастройкаСКД=ЭтотОбъект.КомпоновщикНастроек.Настройки;

КомпоновщикМакетаКомпоновкиДанных=Новый КомпоновщикМакетаКомпоновкиДанных;
МакетКомпоновкиДанных=КомпоновщикМакетаКомпоновкиДанных.Выполнить(СКД, НастройкаСКД) ;

ПроцессорКомпоновкиДанных=Новый ПроцессорКомпоновкиДанных;
ПроцессорКомпоновкиДанных.Инициализировать(МакетКомпоновкиДанных,ВнешнийНабор);

ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент=­Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент;
//ЭлементыФормы.Результат.Очистить();
//ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумен­т.УстановитьДокумент(ЭлементыФормы.Результат);
ТД=ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокуме­нт.Вывести(ПроцессорКомпоновкиДанных);
ТД.Показать();
      //РезультатЗапроса = Запрос.Выполнить();
      //ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
      
//Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
//            ВыборкаДетальныеЗаписи
//КонецЦикла;
КонецПроцедуры

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Для технических специалистов
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • МАРКИРОВКА
  • ЕГАИС
  • Учет, налогообложение, автоматизация
Предложения партнеров
Обучение пользователей продуктов 1С