Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

документы, автоматическаянумерация, номера документов

caramba
Пост №1
caramba
читатель
офлайн
Дата регистрации: 15.07.2002
Сообщений: 1
Пост №1
 
15.07.2002 13:44

Нумератор документу не назначен, при автонумерации следующий номер получается прибавлением единицы к самому большому уже существующему номеру. Можно ли сделать так чтобы номер с которого будет происходить автонумерация в дальнейшем был меньше чем самый большой (уже существующий), если учесть что номеров от меньшего до больщего еще нет? Можноли это сделать не изменяя код?

BigAnt
Пост №2
BigAnt
читатель
офлайн
Дата регистрации: 09.07.2002
Сообщений: 8
Пост №2
 
18.07.2002 12:34

"Изменить номер без изменения кода можно только в ручную.

У меня была когда-то такая проблема, я решил ее изменив код. Если захотите проделать тоже, перед работой !!!ОБЯЗАТЕЛЬНО!!! сохраните свою базу, и попробуйте сделать тоже, если не понравится можете восстановить свою базу.

В модуле Вашего документа, назовем его Х (название документа в конфигураторе), в преопределенной процедуре "ВводНового" после строки



Процедура ВводНового(Копирование)



Вставьте следующий код:



Конец = Число(НомерДок);

Док = СоздатьОбъект("Документ.Х"); // Не забудьте Х – название Ваше документа

                               //в конфигураторе

Для Порядок =1 по Конец Цикл

Док.ВыбратьДокументы();

Если Док.ПолучитьДокумент() = 0 Тогда

Возврат

КонецЕсли;

Ном = Число(НомерДок);

Если Порядок = Ном Тогда

продолжить

Иначе

НомерДок = Строка(Порядок);

Для А =1 по (СтрДлинА(НомерДок) - СтрДлина(Строка(Порядок))) Цикл

НомерДок = ("0" + НомерДок)

КонецЦикла;

Возврат

КонецЕсли;

КонецЦикла;



Вот так я, исправил недостаток программы 1С.

Приятной работы.

"

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Учет, налогообложение, автоматизация
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги
© ООО "1C" 2000-2018 г.