Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

Программирование

lvi15
Пост №1
lvi15
читатель
офлайн
Дата регистрации: 18.07.2002
Сообщений: 20
Пост №1
 
18.07.2002 11:34

Простенькая ситуация: Акт ввода в эквплуатацию ОС, выбор

внеоборотного актива из справочника - нужно показывать не

весь список справочника ВнОбАкт, а только не закрытые по 8.* счету

Если кто знает, то подскажите хотя бы на уровне идеи????

Шуляк Александр (Технический центр Сервер, Братск)
Пост №2
Шуляк Александр (Технический центр Сервер, Братск)
читатель
офлайн
Пост №2
 
18.07.2002 12:09

"Я аналогичную задачу решал, чтобы в документе "Счет-фактура выданный" для импортного товара номер ГТД выбирался не из всего списка, а только для выбранного товара, причем товары с этим номером ГТД есть еще в наличии. Для этого в модуле формы списка "Для подбора" Справочника ГТД предопределенная процедура "ПриОткрытии() пишется следующим образом. Дарю, посмотрите, ваш случай совершенно такой же. Т.е. соль в "ИспользоватьСписокЭлементов(Список)", а этот список заполняется так, как вам надо.



Процедура ПриОткрытии() // Предопределенная процедура

БухИт = СоздатьОбъект("БухгалтерскиеИтоги");

СчГТД = СчетПоКоду("ГТД");

Список=СоздатьОбъект("СписокЗначений");

ЗаполнениеФормы(Форма.Параметр);

Буфер=СоздатьОбъект("Справочник.ГТД");

Буфер.ВыбратьЭлементы();

Пока Буфер.ПолучитьЭлемент()=1 Цикл

Остаток = 0;

Если (КонМесяца(КонтекстФормыДокумента.ДатаДок) <= КонецРассчитанногоПериодаБИ())

Тогда

Если Товар.Выбран() = 1 Тогда

Остаток = БухИт.СКД(СчГТД, "К",, Товар, Буфер.ТекущийЭлемент());

КонецЕсли;

КонецЕсли;

       Если Остаток>0 Тогда

Список.ДобавитьЗначение(Буфер.ТекущийЭлемент());

КонецЕсли;

КонецЦикла;

ФлагОстаткиВКолонке = ВосстановитьЗначение("ФормаПодбораГТД_ФлагОстаткиВКолонке");

ПриВыбореПоказаОстатковВКолонке();

Форма.ИспользоватьСлой("Основной", 2);

ИспользоватьСписокЭлементов(Список);

КонецПроцедуры // ПриОткрытии

"

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Учет, налогообложение, автоматизация
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги
© ООО "1C" 2000-2018 г.