Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

Как в коде изменить проводки?

gtsroger
читатель
офлайн
Дата регистрации: 13.07.2002
Сообщений: 14
Пост №1
 
07.08.2002 10:03

Вопрос состоит в следующем - Как в коде документа или регистра изменить сформированные ранее проводки?Простое присваивание не срабатывает - выдается сообщение "Нельзя изменить записанные проводки"

KV
читатель
офлайн
Дата регистрации: 26.07.2002
Сообщений: 40
Пост №2
 
07.08.2002 12:03

"Создать объект типа "Операция", найти нужную (например, по данному документу), перебрать проводки (изменив, что надо), в конце - Операция.Записать();"

gtsroger
читатель
офлайн
Дата регистрации: 13.07.2002
Сообщений: 14
Пост №3
 
07.08.2002 12:16

"Я так и делаю,но ничего не выходит.Привожу подробно:



Опр=СоздатьОбъект("Операция");

Опр.ВыбратьОперацииСПроводками((НачГода(ТекущаяДата())),ТекущаяДата(),,,,,);

Пока Опр.ПолучитьПроводку()=1 Цикл

Для А=1 по 4 Цикл

Дб=Опр.Дебет.Субконто(А);

РезПоиска=Спр.НайтиПоКоду(Строка(Дб));

Если РезПоиска = 1 Тогда

Опр.Дебет.НалоговыйКлассификатор=СтатьяНК; //Изменяем

Опр.Записать();

КонецЕсли;

КонецЦикла;

КонецЦикла;

"

Шуляк Александр (Технический центр Сервер, Братск)
читатель
офлайн
Пост №4
 
07.08.2002 12:57

1.Операции (и проводки), принадлежащие документу (а не ручной операции), изменяются только в модуле документа, в предопределенной процедуре ОбработкаПроведения, причем сначала уничтожаются, а затем создаются заново, что делается автоматически при перепроведении (есть нюансы, но если проводки уже записаны, то только так).

2.В вашем тексте ошибок много(например, субконто проводки оп.присваивания не задается). Обзаведитесь литературой. Ну невозможно выучить встроенный язык, задавая вопросы на форуме.

KV
читатель
офлайн
Дата регистрации: 26.07.2002
Сообщений: 40
Пост №5
 
07.08.2002 16:48

Вы используете метод "ВыбратьОперацииСПроводками", тем самым, перем. "Опр" у Вас является ссылкой на "поток" проводок, а Вам небходима перем. - ссылка на конкретную операцию, принадлежащую конкретному документу, т.е. лучше использовать поиск операции именно по документу. И организовывать соответственно 2 цикла: один по операциям, второй - по проводкам.

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • МАРКИРОВКА
  • ЕГАИС
  • Учет, налогообложение, автоматизация
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги