Бухгалтерский учет, налогообложение, отчетность, МСФО, анализ бухгалтерской информации, 1С:Бухгалтерия

Вход или Регистрация

Показывать по 10 20 40 сообщений
Новая тема Ответить
Письмо в техподдержку 1С
[Прочее]

ЗиК 265 зацикливается при обновлении ИБ. Как исправить?

maximum-mtm
читатель
офлайн
Дата регистрации: 21.02.2006
Сообщений: 29
Пост №1
 
21.03.2006 08:41

"Как исправить? Зацикливается вот в этом месте:

Обработка.ОбновлениеИБ

Если Док.ПервичныйБольничный.Выбран() = 1 Тогда
//сначала поищем самый первый день самого первого больничного:
ПредыдущийПервичный = Док.ПервичныйБольничный;
Пока ПредыдущийПервичный.ПервичныйБольничный.Выбран() = 1 Цикл
      ПредыдущийПервичный = ПредыдущийПервичный.ПервичныйБольничный;
КонецЦикла;
НачалоБЛ = ПредыдущийПервичный.Начало;
КонецЕсли;"

Serg_Smi
читатель
офлайн
Дата регистрации: 02.06.2005
Сообщений: 83
Пост №2
 
23.03.2006 22:06

"Такое ощущение, что неправильно указаны первичные больничные (сори за стиль).
Если не хочешь искать ошибку вручную через отладчик, то напиши:
Спс=СоздатьОбъект("СписокЗначений");
Если Док.ПервичныйБольничный.Выбран() = 1 Тогда
//сначала поищем самый первый день самого первого больничного:
ПредыдущийПервичный = Док.ПервичныйБольничный;
Пока ПредыдущийПервичный.ПервичныйБольничный.Выбран() = 1 Цикл
Если Спс.НайтиЗначение(ПредыдущийПервичный.ПервичныйБольничный)=0 Тогда
       Спс.ДобавитьЗначение(ПредыдущийПервичный.ПервичныйБольничный);
Иначе
       Сообщить("Смотри структуру подчиненности у б/л "+ПредыдущийПервичный.ПервичныйБольничный);
       Прервать;
КонецЕсли;
ПредыдущийПервичный = ПредыдущийПервичный.ПервичныйБольничный;
КонецЦикла;
НачалоБЛ = ПредыдущийПервичный.Начало;
КонецЕсли;

Вроде все так."

Показывать по 10 20 40 сообщений

Читают тему:

1 гостей
Быстрый переход
Учет, налогообложение, автоматизация
  • Учет, налогообложение, автоматизация
  • Книга жалоб и предложений по работе сайта
  • Для технических специалистов
  • Представление регламентированной отчетности
  • Говорильня
  • Бухгалтерский учет: обсуждаем проекты нормативных актов и рекомендаций по ведению учета от БМЦ
  • Новый порядок применения ККТ (онлайн кассы с передачей сведений в ФНС)
  • Интернет-конференция: Оформление командировок по новым правилам
  • ЕГАИС
Предложения партнеров
Обучение пользователей продуктов 1С

1С бесплатно 1С-Отчетность 1С:ERP Управление предприятием 1С:Бесплатно 1С:Бухгалтерия 8 1С:Бухгалтерия 8 КОРП 1С:Бухгалтерия автономного учреждения 1С:Бухгалтерия государственного учреждения 1С:Бюджет муниципального образования 1С:Бюджет поселения 1С:Вещевое довольствие 1С:Деньги 1С:Документооборот 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и кадры государственного учреждения 1С:Зарплата и управление персоналом 1С:Зарплата и управление персоналом КОРП 1С:Комплексная автоматизация 8 1С:Лекторий 1С:Предприятие 1С:Предприятие 7.7 1С:Предприятие 8 1С:Розница 1С:Управление нашей фирмой 1С:Управление производственным предприятием 1С:Управление торговлей 1СПредприятие 8

Все теги